[PATCH] gnu: Add r-svdialogs.

  • Done
  • quality assurance status badge
Details
4 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • pimi
  • Ricardo Wurmus
  • Ricardo Wurmus
Owner
unassigned
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180830102502.10156-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-svdialogs): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e6fb6b8f7..ace86c901 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5012,3 +5012,30 @@ native, ...). It centralizes info about GUI elements currently used, and it
dispatches GUI calls to the particular toolkits in use in function of the
context (is R run at the terminal, within a Tk application, a HTML page?).")
(license license:gpl2)))
+
+(define-public r-svdialogs
+ (package
+ (name "r-svdialogs")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "svDialogs" version))
+ (sha256
+ (base32 "0xqppydfawnwk84kb5qiybwbcmv38vn4imgz01mz2pnq4xb80p97"))))
+ (properties `((upstream-name . "svDialogs")))
+ (build-system r-build-system)
+ (inputs
+ `(("yad" ,yad)
+ ("zenity" ,zenity)))
+ (propagated-inputs
+ `(("r-rstudioapi" ,r-rstudioapi)
+ ("r-svgui" ,r-svgui)))
+ (home-page "https://github.com/SciViews/svDialogs/")
+ (synopsis "Standard dialog boxes for Windows, MacOS and Linux")
+ (description
+ "This package helps to construct rapidly standard dialog boxes for your GUI, including
+message boxes, input boxes, list, file or directory selection, and others. In
+case R cannot display GUI dialog boxes, a simpler command line version of these
+interactive elements is also provided as a fallback solution.")
+ (license license:gpl2)))
--
2.17.1
Ricardo Wurmus wrote 7 years ago
(address . 32586@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrasc@mdc-berlin.de)
idjmusy38bh.fsf@bimsb-sys02.mdc-berlin.net
Hi,

thanks for the patch!

Toggle quote (16 lines)
> +
> +(define-public r-svdialogs
> + (package
> + (name "r-svdialogs")
> + (version "1.0.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (cran-uri "svDialogs" version))
> + (sha256
> + (base32 "0xqppydfawnwk84kb5qiybwbcmv38vn4imgz01mz2pnq4xb80p97"))))
> + (properties `((upstream-name . "svDialogs")))
> + (build-system r-build-system)
> + (inputs
> + `(("yad" ,yad)

I see that you provide a patch for “yad” in another issue. In the
future please send a series of dependent patches together to the same
ticket address. (Create a new ticket first by sending a “cover letter”
to guix-patches@gnu.org first.)

Toggle quote (7 lines)
> + ("zenity" ,zenity)))
> + (propagated-inputs
> + `(("r-rstudioapi" ,r-rstudioapi)
> + ("r-svgui" ,r-svgui)))
> + (home-page "https://github.com/SciViews/svDialogs/")
> + (synopsis "Standard dialog boxes for Windows, MacOS and Linux")

Please use “Portable dialog boxes” instead.

Toggle quote (2 lines)
> + (license license:gpl2)))

This is correct.

--
Ricardo
Ricardo Wurmus wrote 7 years ago
(address . 32586@debbugs.gnu.org)
idjlg8i3893.fsf@bimsb-sys02.mdc-berlin.net
block 32586 by 32584
block 32586 by 32585
thanks
pimi wrote 7 years ago
[PATCH] asasa
(address . 32586@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180906151120.12940-1-madalinionel.patrascu@mdc-berlin.de
---
gnu/packages/cran.scm | 24 +++++++++++++++++++++++
gnu/packages/gtk.scm | 45 +++++++++++++++++++++++++++++++++++++++++++
2 files changed, 69 insertions(+)

Toggle diff (94 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 447be5657..745464ce2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33,6 +33,8 @@
#:use-module (guix build-system r)
#:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages machine-learning)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
@@ -5411,3 +5413,25 @@ maximum cycle number. The @code{r-abcoptim} implements the Artificial bee
colony optimization algorithm @url{http://mf.erciyes.edu.tr/abc/pub/tr06_2005.pdf}.
This version is a work-in-progress and is written in R code.")
(license license:expat)))
+
+(define-public r-svgui
+ (package
+ (name "r-svgui")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "svGUI" version))
+ (sha256
+ (base32 "1r7ab0p4yr8q03gj02hmj7k1ghksgkg4nx750c0ajfs2q9y1dxfc"))))
+ (properties `((upstream-name . "svGUI")))
+ (build-system r-build-system)
+ (home-page "https://github.com/SciViews/svGUI/")
+ (synopsis "Functions for managing GUI clients in R")
+ (description
+ "The SciViews @code{svGUI} package eases the management of Graphical User
+Interfaces (GUI) in R. It is independent from any particular GUI widgets (Tk,
+Gtk2, native, ...). It centralizes info about GUI elements currently used, and
+it dispatches GUI calls to the particular toolkits in use in function of the
+context (is R run at the terminal, within a Tk application, a HTML page?).")
+ (license license:gpl2)))
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 4daaad0eb..e0d52a8dd 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1658,3 +1658,48 @@ Parcellite and adds bugfixes and features.")
it does not deal with windowing system surfaces, drawing, scene graphs, or
input.")
(license license:expat)))
+
+(define-public yad
+ (let ((commit "8957347fc6376bc4ec992adef078a7b53399850e")
+ (revision "1"))
+ (package
+ (name "yad")
+ (version (git-version "0.40.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/v1cont/yad.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04vqm6khqsaar25qa8xaixp6i1jp7v33b32f6i425kfdi6wfr2yb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ '("--with-gtk=gtk3"
+ "--enable-html"
+ "--enable-gio"
+ "--enable-spell"
+ "--enable-icon-browser")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (invoke "autoreconf" "-vif")
+ (invoke "intltoolize" "--force" "--automake")
+ #t)))))
+ (inputs
+ `(("gtk+" ,gtk+)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://sourceforge.net/projects/yad-dialog/")
+ (synopsis "GTK+ dialog boxes for shell scripts")
+ (description
+ "This program allows you to display GTK+ dialog boxes from command line or
+shell scripts. Example of how to use @code{yad} can be consulted at
+@url{https://sourceforge.net/p/yad-dialog/wiki/browse_pages/}.")
+ (license license:gpl3+))))
--
2.17.1
MadalinIonel.Patrascu@mdc-berlin.de wrote 7 years ago
(name . 32586@debbugs.gnu.org)(address . 32586@debbugs.gnu.org)
918DDFCAA65E9447BD6F28DB666521DA98A260@DAGTHREE.mdc-berlin.net
Please do not take into account the previous message!
I need some coffee!
Sorry!
Mădălin Ionel Patrașcu
System Administrator
Bioinformatics Platform
The Berlin Institute for Medical Systems Biology (BIMSB)
Max Delbrück Center (MDC)
Robert-Rössle-Straße 10
House 87, room 1.10
13125 Berlin, Germany
pimi wrote 7 years ago
(address . 32586@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180906151450.13012-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-svdialogs): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 745464ce2..46c37b8bc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5435,3 +5435,30 @@ Gtk2, native, ...). It centralizes info about GUI elements currently used, and
it dispatches GUI calls to the particular toolkits in use in function of the
context (is R run at the terminal, within a Tk application, a HTML page?).")
(license license:gpl2)))
+
+(define-public r-svdialogs
+ (package
+ (name "r-svdialogs")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "svDialogs" version))
+ (sha256
+ (base32 "0xqppydfawnwk84kb5qiybwbcmv38vn4imgz01mz2pnq4xb80p97"))))
+ (properties `((upstream-name . "svDialogs")))
+ (build-system r-build-system)
+ (inputs
+ `(("yad" ,yad)
+ ("zenity" ,zenity)))
+ (propagated-inputs
+ `(("r-rstudioapi" ,r-rstudioapi)
+ ("r-svgui" ,r-svgui)))
+ (home-page "https://github.com/SciViews/svDialogs/")
+ (synopsis "Portable dialog boxes")
+ (description
+ "This package helps to construct standard dialog boxes for your GUI, including
+message boxes, input boxes, list, file or directory selection, and others. In
+case R cannot display GUI dialog boxes, a simpler command line version of these
+interactive elements is also provided as a fallback solution.")
+ (license license:gpl2)))
--
2.17.1
MadalinIonel.Patrascu@mdc-berlin.de wrote 7 years ago
Previous patch is good
(name . 32586@debbugs.gnu.org)(address . 32586@debbugs.gnu.org)
918DDFCAA65E9447BD6F28DB666521DA98A276@DAGTHREE.mdc-berlin.net
Hi!
Sorry for the previous mistake!
It was typo git send-email -2 instead of -1.
Soooorrrry!
Mădălin Ionel Patrașcu
System Administrator
Bioinformatics Platform
The Berlin Institute for Medical Systems Biology (BIMSB)
Max Delbrück Center (MDC)
Robert-Rössle-Straße 10
House 87, room 1.10
13125 Berlin, Germany
Ricardo Wurmus wrote 6 years ago
[bug#32586] [PATCH] gnu: Add r-svdialogs.
(address . 32586-done@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
87y3c5ilyb.fsf@elephly.net
Pushed to “master” branch with commit d1ca3d729. Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32586@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32586
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help