pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
gnu/packages/cran.scm (r-svdialogs): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e6fb6b8f7..ace86c901 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5012,3 +5012,30 @@ native, ...). It centralizes info about GUI elements currently used, and it
dispatches GUI calls to the particular toolkits in use in function of the
context (is R run at the terminal, within a Tk application, a HTML page?).")
(license license:gpl2)))
+
+(define-public r-svdialogs
+ (package
+ (name "r-svdialogs")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "svDialogs" version))
+ (sha256
+ (base32 "0xqppydfawnwk84kb5qiybwbcmv38vn4imgz01mz2pnq4xb80p97"))))
+ (properties `((upstream-name . "svDialogs")))
+ (build-system r-build-system)
+ (inputs
+ `(("yad" ,yad)
+ ("zenity" ,zenity)))
+ (propagated-inputs
+ `(("r-rstudioapi" ,r-rstudioapi)
+ ("r-svgui" ,r-svgui)))
+ (home-page "https://github.com/SciViews/svDialogs/")
+ (synopsis "Standard dialog boxes for Windows, MacOS and Linux")
+ (description
+ "This package helps to construct rapidly standard dialog boxes for your GUI, including
+message boxes, input boxes, list, file or directory selection, and others. In
+case R cannot display GUI dialog boxes, a simpler command line version of these
+interactive elements is also provided as a fallback solution.")
+ (license license:gpl2)))
--
2.17.1