[PATCH] gnu: Add r-svgui.

  • Done
  • quality assurance status badge
Details
2 participants
  • pimi
  • Ricardo Wurmus
Owner
unassigned
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180830101632.9950-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-svgui): New variable
---
gnu/packages/cran.scm | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 016d1b1e4..e6fb6b8f7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -41,7 +41,9 @@
#:use-module (gnu packages python)
#:use-module (gnu packages statistics)
#:use-module (gnu packages tls)
- #:use-module (gnu packages web))
+ #:use-module (gnu packages web)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages gnome))
(define-public r-tidyverse
(package
@@ -4988,3 +4990,25 @@ maximum cycle number. The @code{r-abcoptim} implements the Artificial bee
colony optimization algorithm @url{http://mf.erciyes.edu.tr/abc/pub/tr06_2005.pdf}.
This version is a work-in-progress and is written in R code.")
(license license:expat)))
+
+(define-public r-svgui
+ (package
+ (name "r-svgui")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "svGUI" version))
+ (sha256
+ (base32 "1r7ab0p4yr8q03gj02hmj7k1ghksgkg4nx750c0ajfs2q9y1dxfc"))))
+ (properties `((upstream-name . "svGUI")))
+ (build-system r-build-system)
+ (home-page "https://github.com/SciViews/svGUI/")
+ (synopsis "Functions for managing GUI client in R")
+ (description
+ "The SciViews @code{svGUI} package eases the management of Graphical User Interfaces
+(GUI) in R. It is independent from any particular GUI widgets (Tk, Gtk2,
+native, ...). It centralizes info about GUI elements currently used, and it
+dispatches GUI calls to the particular toolkits in use in function of the
+context (is R run at the terminal, within a Tk application, a HTML page?).")
+ (license license:gpl2)))
--
2.17.1
Ricardo Wurmus wrote 7 years ago
(address . 32585@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrasc@mdc-berlin.de)
idjk1o2382b.fsf@bimsb-sys02.mdc-berlin.net
Hi,

Toggle quote (18 lines)
> gnu/packages/cran.scm (r-svgui): New variable
> ---
> gnu/packages/cran.scm | 26 +++++++++++++++++++++++++-
> 1 file changed, 25 insertions(+), 1 deletion(-)

> diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
> index 016d1b1e4..e6fb6b8f7 100644
> --- a/gnu/packages/cran.scm
> +++ b/gnu/packages/cran.scm
> @@ -41,7 +41,9 @@
> #:use-module (gnu packages python)
> #:use-module (gnu packages statistics)
> #:use-module (gnu packages tls)
> - #:use-module (gnu packages web))
> + #:use-module (gnu packages web)
> + #:use-module (gnu packages gtk)
> + #:use-module (gnu packages gnome))

It looks like these changes belong to another patch as the package added
by this patch doesn’t have any inputs.

Toggle quote (15 lines)
> +(define-public r-svgui
> + (package
> + (name "r-svgui")
> + (version "1.0.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (cran-uri "svGUI" version))
> + (sha256
> + (base32 "1r7ab0p4yr8q03gj02hmj7k1ghksgkg4nx750c0ajfs2q9y1dxfc"))))
> + (properties `((upstream-name . "svGUI")))
> + (build-system r-build-system)
> + (home-page "https://github.com/SciViews/svGUI/")
> + (synopsis "Functions for managing GUI client in R")

“clients"

Toggle quote (7 lines)
> + (description
> + "The SciViews @code{svGUI} package eases the management of Graphical User Interfaces
> +(GUI) in R. It is independent from any particular GUI widgets (Tk, Gtk2,
> +native, ...). It centralizes info about GUI elements currently used, and it
> +dispatches GUI calls to the particular toolkits in use in function of the
> +context (is R run at the terminal, within a Tk application, a HTML page?).")

Please reflow the description — the first line looks unusually long.

Toggle quote (2 lines)
> + (license license:gpl2)))

This is correct.

Could you please send an updated patch?

Thanks!

--
Ricardo
pimi wrote 7 years ago
(address . 32585@debbugs.gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180905105225.29837-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-svgui): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 016d1b1e4..105e81fb4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33,6 +33,8 @@
#:use-module (guix build-system r)
#:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages machine-learning)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
@@ -4988,3 +4990,25 @@ maximum cycle number. The @code{r-abcoptim} implements the Artificial bee
colony optimization algorithm @url{http://mf.erciyes.edu.tr/abc/pub/tr06_2005.pdf}.
This version is a work-in-progress and is written in R code.")
(license license:expat)))
+
+(define-public r-svgui
+ (package
+ (name "r-svgui")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "svGUI" version))
+ (sha256
+ (base32 "1r7ab0p4yr8q03gj02hmj7k1ghksgkg4nx750c0ajfs2q9y1dxfc"))))
+ (properties `((upstream-name . "svGUI")))
+ (build-system r-build-system)
+ (home-page "https://github.com/SciViews/svGUI/")
+ (synopsis "Functions for managing GUI clients in R")
+ (description
+ "The SciViews @code{svGUI} package eases the management of Graphical User
+Interfaces (GUI) in R. It is independent from any particular GUI widgets (Tk,
+Gtk2, native, ...). It centralizes info about GUI elements currently used, and
+it dispatches GUI calls to the particular toolkits in use in function of the
+context (is R run at the terminal, within a Tk application, a HTML page?).")
+ (license license:gpl2)))
--
2.17.1
Ricardo Wurmus wrote 7 years ago
(address . 32585-done@debbugs.gnu.org)
87tvmwjay2.fsf@mdc-berlin.de
Thank you. Pushed to the “master” branch with commit 01af264dc.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32585@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32585
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help