[PATCH] gnu: Add r-abd.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • pimi
Owner
unassigned
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180829083656.16238-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-abd): New variable.
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5a00efccd..caf14af78 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5156,3 +5156,25 @@ working to tie together aspects of quantitative work that students in science,
technology, engineering and mathematics will need in their professional lives,
but which are usually taught in isolation, if at all.")
(license license:gpl2+)))
+
+(define-public r-abd
+ (package
+ (name "r-abd")
+ (version "0.2-8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abd" version))
+ (sha256
+ (base32 "191gspqzdv573vaw624ri0f5cm6v4j524bjs74d4a1hn3kn6r9b7"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lattice" ,r-lattice)
+ ("r-mosaic" ,r-mosaic)
+ ("r-nlme" ,r-nlme)))
+ (home-page "https://cran.r-project.org/web/packages/abd/")
+ (synopsis "Analysis of biological data")
+ (description
+ "The @code{r-abd} package contains data sets and sample code for the Analysis of
+biological data by Michael Whitlock and Dolph Schluter.")
+ (license license:gpl2)))
--
2.17.1
Ludovic Courtès wrote 7 years ago
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32574-done@debbugs.gnu.org)
874lexavj6.fsf@gnu.org
pimi <madalinionel.patrascu@mdc-berlin.de> skribis:

Toggle quote (2 lines)
> gnu/packages/cran.scm (r-abd): New variable.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32574@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32574
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help