[PATCH] gnu: Add r-mosaiccore.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • pimi
Owner
unassigned
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180829081611.15022-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-mosaiccore): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9be759992..77d5528e4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5044,3 +5044,27 @@ and coverage methods to tune the choice of threshold.")
@item vertical versions of @code{r-ggplot2} positions.
@end enumerate")
(license license:gpl3)))
+
+(define-public r-mosaiccore
+ (package
+ (name "r-mosaiccore")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mosaicCore" version))
+ (sha256
+ (base32 "1klw97h6lchw1cpcl8s637ikcl428cckmjq0czi7mibh9q9mw72z"))))
+ (properties `((upstream-name . "mosaicCore")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-lazyeval" ,r-lazyeval)
+ ("r-mass" ,r-mass)
+ ("r-rlang" ,r-rlang)
+ ("r-tidyr" ,r-tidyr)))
+ (home-page "https://github.com/ProjectMOSAIC/mosaicCore/")
+ (synopsis "Common utilities for mosaic family packages")
+ (description
+ "Common utilities used in other Mosaic family packages are collected here.")
+ (license license:gpl2+)))
--
2.17.1
Ludovic Courtès wrote 7 years ago
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32572-done@debbugs.gnu.org)
87o9d9irxc.fsf@gnu.org
pimi <madalinionel.patrascu@mdc-berlin.de> skribis:

Toggle quote (2 lines)
> gnu/packages/cran.scm (r-mosaiccore): New variable.

Applied!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32572@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32572
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help