[PATCH] gnu: Add r-ggstance.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • pimi
Owner
unassigned
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180829080912.14557-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-ggstance): New variable.
---
gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b6667789c..9be759992 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5018,3 +5018,29 @@ including summary statistic selection and assessing coverage. This includes
recent dimension reduction algorithms to tune the choice of summary statistics,
and coverage methods to tune the choice of threshold.")
(license license:gpl2+)))
+
+(define-public r-ggstance
+ (package
+ (name "r-ggstance")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggstance" version))
+ (sha256
+ (base32 "0v7f3xdaaridw6d4jvnsfwxmpjrasvx5vl555wsrn50aah17fkvh"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-plyr" ,r-plyr)
+ ("r-rlang" ,r-rlang)
+ ("r-withr" ,r-withr)))
+ (home-page "https://cran.r-project.org/web/packages/ggstance/")
+ (synopsis "Horizontal and vertical versions of @code{r-ggplot2}")
+ (description
+ "This package is a @code{r-ggplot2} extension that provides flipped components:
+@enumerate
+@item horizontal versions of @code{r-ggplot2} stats and @code{r-ggplot2} geoms;
+@item vertical versions of @code{r-ggplot2} positions.
+@end enumerate")
+ (license license:gpl3)))
--
2.17.1
Ludovic Courtès wrote 7 years ago
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32569-done@debbugs.gnu.org)
87sh2lis79.fsf@gnu.org
pimi <madalinionel.patrascu@mdc-berlin.de> skribis:

Toggle quote (2 lines)
> gnu/packages/cran.scm (r-ggstance): New variable.

Applied!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32569@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32569
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help