[PATCH] gnu: Add r-abctools.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • pimi
Owner
unassigned
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180829073917.14129-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/cran.scm (r-abctools): New variable.
---
gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ebc15e940..b6667789c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4993,3 +4993,28 @@ parameter inference via random forests. This machine learning tool named random
forests (RF) can conduct selection among the highly complex models covered by
ABC algorithms.")
(license license:gpl2+)))
+
+(define-public r-abctools
+ (package
+ (name "r-abctools")
+ (version "1.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abctools" version))
+ (sha256
+ (base32 "07s9dg10i8lsxl73b4n2hynca2fjgb0ykb0dz8c3zv6cgw3cyx97"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-abc" ,r-abc)
+ ("r-abind" ,r-abind)
+ ("r-hmisc" ,r-hmisc)
+ ("r-plyr" ,r-plyr)))
+ (home-page "https://github.com/dennisprangle/abctools/")
+ (synopsis "Tools for ABC analyses")
+ (description
+ "This @code{r-abctools} package provides tools for approximate Bayesian computation
+including summary statistic selection and assessing coverage. This includes
+recent dimension reduction algorithms to tune the choice of summary statistics,
+and coverage methods to tune the choice of threshold.")
+ (license license:gpl2+)))
--
2.17.1
Ludovic Courtès wrote 7 years ago
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32568-done@debbugs.gnu.org)
87worxiscy.fsf@gnu.org
pimi <madalinionel.patrascu@mdc-berlin.de> skribis:

Toggle quote (2 lines)
> gnu/packages/cran.scm (r-abctools): New variable.

Applied!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32568@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32568
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help