pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
;;gnu/packages/cran.scm (r-abcrf): New variable.
---
gnu/packages/cran.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (38 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d3a0c4672..ebc15e940 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4965,3 +4965,31 @@ and make comparisons between different methodologies straightforward.")
Poisson, and Gamma distribution and estimates the proportional paternity of the
second male (P2) based on the best fit distribution.")
(license license:gpl2)))
+
+(define-public r-abcrf
+ (package
+ (name "r-abcrf")
+ (version "1.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abcrf" version))
+ (sha256
+ (base32 "06vy3inikrr9hv36q4djhrgzi9zizdfnhz17wpra8kadmr7qj441"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-ranger" ,r-ranger)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ("r-readr" ,r-readr)
+ ("r-stringr" ,r-stringr)))
+ (home-page "https://cran.r-project.org/web/packages/abcrf/")
+ (synopsis "Approximate bayesian computation via random forests")
+ (description
+ "This package performs approximate bayesian computation (ABC) model choice and
+parameter inference via random forests. This machine learning tool named random
+forests (RF) can conduct selection among the highly complex models covered by
+ABC algorithms.")
+ (license license:gpl2+)))
--
2.17.1