[PATCH] ;;gnu: Add r-abcp2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • pimi
Owner
unassigned
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180829072434.11839-1-madalinionel.patrascu@mdc-berlin.de
;;gnu/packages/cran.scm (r-abcp2): New variable.
---
gnu/packages/cran.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index eb6bf9c38..d3a0c4672 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4944,3 +4944,24 @@ developers to generate user interfaces easy to maintain.")
models. The methods employed are applicable to virtually any predictive model
and make comparisons between different methodologies straightforward.")
(license license:gpl2+)))
+
+(define-public r-abcp2
+ (package
+ (name "r-abcp2")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ABCp2" version))
+ (sha256
+ (base32 "1s2skkxpzss7c29i8600psgrp0hl46jcrxqrmy2b4db8hc0kcnbx"))))
+ (properties `((upstream-name . "ABCp2")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-mass" ,r-mass)))
+ (home-page "https://cran.r-project.org/web/packages/ABCp2/")
+ (synopsis "Approximate Bayesian Computational Model for Estimating P2")
+ (description
+ "This package tests the goodness of fit of a distribution of offspring to the Normal,
+Poisson, and Gamma distribution and estimates the proportional paternity of the
+second male (P2) based on the best fit distribution.")
+ (license license:gpl2)))
--
2.17.1
Ludovic Courtès wrote 7 years ago
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32566-done@debbugs.gnu.org)
878t4dk73v.fsf@gnu.org
Hello,

pimi <madalinionel.patrascu@mdc-berlin.de> skribis:

Toggle quote (2 lines)
> ;;gnu/packages/cran.scm (r-abcp2): New variable.

I tweaked the commit log and committed, thank you!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32566@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32566
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help