[PATCH] gnu: python-trezor: Update to 0.10.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 7 years ago
(address . guix-patches@gnu.org)
87pny2ma8g.fsf@aikidev.net
* gnu/packages/finance.scm (python-trezor): Update to 0.10.2.
[arguments]: Replace check with tests that do not require hardware device.
[propagated-inputs]: Add python-click, python-libusb1, python-pyblake2 and
python-typing.
[native-inputs]: Add python-mock and python-pytest.
---
gnu/packages/finance.scm | 25 ++++++++++++++++++++-----
1 file changed, 20 insertions(+), 5 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 7aeaffcc5..28bfb28f4 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -664,23 +664,38 @@ Ledger Blue/Nano S.")
(define-public python-trezor
(package
(name "python-trezor")
- (version "0.7.16")
+ (version "0.10.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "trezor" version))
(sha256
(base32
- "055kii56wgwadl5z911s59ya2fnsqzk3n5i19s2hb9sv2by6knvb"))))
+ "138k6zsqqpb46k3rcpyslm9q7yq5i6k4myvr9n425jnkadf4vfjd"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Default tests run device-specific tests which fail, only run specific tests.
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (invoke "python" "-m" "pytest" "--pyarg" "trezorlib.tests.unit_tests")
+ (invoke "python" "-m" "pytest" "-m" "slow_cosi" "--pyarg" "trezorlib.tests.unit_tests")
+ )))))
(propagated-inputs
- `(("python-ecdsa" ,python-ecdsa)
+ `(("python-click" ,python-click)
+ ("python-ecdsa" ,python-ecdsa)
("python-hidapi" ,python-hidapi)
+ ("python-libusb1" ,python-libusb1)
("python-mnemonic" ,python-mnemonic)
("python-protobuf" ,python-protobuf)
- ("python-requests" ,python-requests)))
+ ("python-pyblake2" ,python-pyblake2)
+ ("python-requests" ,python-requests)
+ ("python-typing" ,python-typing)))
(native-inputs
- `(("python-pyqt" ,python-pyqt))) ; Tests
+ `(("python-mock" ,python-mock) ; Tests
+ ("python-pyqt" ,python-pyqt) ; Tests
+ ("python-pytest" ,python-pytest))) ; Tests
(home-page "https://github.com/trezor/python-trezor")
(synopsis "Python library for communicating with TREZOR Hardware Wallet")
(description "@code{trezor} is a Python library for communicating with
--
2.18.0
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCW4XDsAAKCRDcUY/If5cW
qsuzAP45arCcNsMXuyPgSFvqGcmHw9Qn3dD7O+BI5dncI6nfNwD/REWBs+2vlu5u
sj+B/5PEBGPxxBDYuo66cV91vgAsvAo=
=Ty6K
-----END PGP SIGNATURE-----

Leo Famulari wrote 7 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 32563-done@debbugs.gnu.org)
20180829185317.GA29322@jasmine.lan
On Tue, Aug 28, 2018 at 02:50:39PM -0700, Vagrant Cascadian wrote:
Toggle quote (6 lines)
> * gnu/packages/finance.scm (python-trezor): Update to 0.10.2.
> [arguments]: Replace check with tests that do not require hardware device.
> [propagated-inputs]: Add python-click, python-libusb1, python-pyblake2 and
> python-typing.
> [native-inputs]: Add python-mock and python-pytest.

Thanks! Pushed as b4c698c8c99952fef0c9aa8c53c36631d84b5ef7
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAluG65wACgkQJkb6MLrK
fwjKJRAAnFG92Mkyqp0vCKL+UhdVwd88et54zpBcoTM4qbKTrVldn4QWIIwFlNXT
TBowHGYR6J9jybnPuzEBQvHWvu0nr1CtBrL5Nc5obnORT4DbL04uO7eKywOFBuAe
J62N6djOVk1lvEGZdz6mP9q/KfmWJ3c9zLOP7EJBSLNNGLgYM0hf9wTb9+96CmtD
qUrxPbKcXPCiSEPS/CStu4QYr+1foUatp8pZIYrGLAWtzwLjQHlxpDzS97y1a4DV
b6J5lrV/IOJ2wfd6XQFrvDY8SfOoc8WAwUYw3UWng95NhqgXEXdKQdGT1ZmFD33b
aPQWKV7KSoiz3HCz7djI7859tF/JUT3qeGg9dy6QspKE+yG1ljWi8OO3rHGEZ0fZ
4vAR9aMcNz1ssNvsNnDZtnshOKfdDpKH0+PDLM6Sz7MtBTDfYrAHqzoiMdVSOJNy
+JWMAuiUGMEvdjM/jyAaTlynyZsIakNwOtvkxBD4SHkRgrHy6wMXe8ODKM1aZdfV
UeyxW2RsF6rmKqocRmTJuUVfHU/QtYpMTryga/uDZtriz2VblWl5dMwxmMBaAH+s
SRt+d4IjYXZZeIIdFWY7IeNsmnY4Z+pjMh5/L2JSKIZ1OWPdPLm6fO8rPnnH+2lp
MuSactRW2vGhlpaiy1CiGTbrqp+keFqnawyNUOY+fD9l61oB9zM=
=Nnf4
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32563@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32563
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help