pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
gnu/packages/bioinformatics.scm (gffcompare): New variable.
---
gnu/packages/bioinformatics.scm | 64 +++++++++++++++++++++++++++++++++
1 file changed, 64 insertions(+)
Toggle diff (74 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cb3c4bc1f..99f92ad66 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13458,3 +13458,67 @@ conversions, region filtering, FASTA sequence extraction and more.")
spliced (back-spliced) sequencing reads, indicative of circular RNA (circRNA)
in RNA-seq data.")
(license license:gpl3))))
+
+(define-public gffcompare
+ (let ((commit "be56ef4349ea3966c12c6397f85e49e047361c41")
+ (revision "1"))
+ (package
+ (name "gffcompare")
+ (version (git-version "0.10.15" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gpertea/gffcompare/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0cp5qpxdhw4mxpya5dld8wi3jk00zyklm6rcri426wydinrnfmkg"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'copy-gclib-source
+ (lambda* (#:key inputs #:allow-other-keys)
+ (mkdir "../gclib")
+ (copy-recursively
+ (assoc-ref inputs "gclib-source") "../gclib")
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (mkdir-p bin)
+ (install-file "gffcompare" bin)
+ #t))))))
+ (native-inputs
+ `(("gclib-source"
+ ,(let ((commit "54917d0849c1e83cfb057b5f712e5cb6a35d948f")
+ (revision "1")
+ (name "gclib")
+ (version (git-version "0.10.3" revision commit)))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gpertea/gclib/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0b51lc0b8syrv7186fd7n8f15rwnf264qgfmm2palrwks1px24mr")))))))
+ (home-page "https://github.com/gpertea/gffcompare/")
+ (synopsis "Tool for comparing or classifing transcripts of RNA-Seq")
+ (description
+ "@code{gffcompare} is a tool that can:
+@enumerate
+@item compare and evaluate the accuracy of RNA-Seq transcript assemblers
+(Cufflinks, Stringtie);
+@item collapse (merge) duplicate transcripts from multiple GTF/GFF3 files (e.g.
+resulted from assembly of different samples);
+@item classify transcripts from one or multiple GTF/GFF3 files as they relate to
+reference transcripts provided in a annotation file (also in GTF/GFF3 format).
+@end enumerate")
+ (license
+ (list
+ license:expat ;license for gffcompare
+ license:artistic2.0))))) ;license for gclib
--
2.17.1