[PATCH] gnu: Add gffcompare.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • pimi
Owner
unassigned
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180828202613.2051-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/bioinformatics.scm (gffcompare): New variable.
---
gnu/packages/bioinformatics.scm | 64 +++++++++++++++++++++++++++++++++
1 file changed, 64 insertions(+)

Toggle diff (74 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cb3c4bc1f..99f92ad66 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13458,3 +13458,67 @@ conversions, region filtering, FASTA sequence extraction and more.")
spliced (back-spliced) sequencing reads, indicative of circular RNA (circRNA)
in RNA-seq data.")
(license license:gpl3))))
+
+(define-public gffcompare
+ (let ((commit "be56ef4349ea3966c12c6397f85e49e047361c41")
+ (revision "1"))
+ (package
+ (name "gffcompare")
+ (version (git-version "0.10.15" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gpertea/gffcompare/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0cp5qpxdhw4mxpya5dld8wi3jk00zyklm6rcri426wydinrnfmkg"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'copy-gclib-source
+ (lambda* (#:key inputs #:allow-other-keys)
+ (mkdir "../gclib")
+ (copy-recursively
+ (assoc-ref inputs "gclib-source") "../gclib")
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (mkdir-p bin)
+ (install-file "gffcompare" bin)
+ #t))))))
+ (native-inputs
+ `(("gclib-source"
+ ,(let ((commit "54917d0849c1e83cfb057b5f712e5cb6a35d948f")
+ (revision "1")
+ (name "gclib")
+ (version (git-version "0.10.3" revision commit)))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gpertea/gclib/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0b51lc0b8syrv7186fd7n8f15rwnf264qgfmm2palrwks1px24mr")))))))
+ (home-page "https://github.com/gpertea/gffcompare/")
+ (synopsis "Tool for comparing or classifing transcripts of RNA-Seq")
+ (description
+ "@code{gffcompare} is a tool that can:
+@enumerate
+@item compare and evaluate the accuracy of RNA-Seq transcript assemblers
+(Cufflinks, Stringtie);
+@item collapse (merge) duplicate transcripts from multiple GTF/GFF3 files (e.g.
+resulted from assembly of different samples);
+@item classify transcripts from one or multiple GTF/GFF3 files as they relate to
+reference transcripts provided in a annotation file (also in GTF/GFF3 format).
+@end enumerate")
+ (license
+ (list
+ license:expat ;license for gffcompare
+ license:artistic2.0))))) ;license for gclib
--
2.17.1
Leo Famulari wrote 7 years ago
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32561-done@debbugs.gnu.org)
20180829181516.GB26984@jasmine.lan
On Tue, Aug 28, 2018 at 10:26:13PM +0200, pimi wrote:
Toggle quote (2 lines)
> gnu/packages/bioinformatics.scm (gffcompare): New variable.

Thanks!

Toggle quote (18 lines)
> + (arguments
> + `(#:tests? #f ; no check target
> + #:phases
> + (modify-phases %standard-phases
> + (delete 'configure)
> + (add-before 'build 'copy-gclib-source
> + (lambda* (#:key inputs #:allow-other-keys)
> + (mkdir "../gclib")
> + (copy-recursively
> + (assoc-ref inputs "gclib-source") "../gclib")
> + #t))
> + (replace 'install
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
> + (mkdir-p bin)
> + (install-file "gffcompare" bin)
> + #t))))))

I moved the #:phases block over to line up with #:tests?...

Toggle quote (4 lines)
> + (native-inputs
> + `(("gclib-source"
> + ,(let ((commit "54917d0849c1e83cfb057b5f712e5cb6a35d948f")

... and added a comment about this, and pushed as
4f9355c3606ecbe83dce78e6d01fa974d912bd4a
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAluG4rQACgkQJkb6MLrK
fwj/ew/+MyyiPpw1dZakR3zHYmnQwAPTq3EuqvCsI8uNTiErIi6Fs7HMkY7E1mxn
JtSLTCXWitIABlfYQJ6gs2fc8MELWG4I8JtT//dscWGWnmMa9Xn8D7XkmdXb3Mc5
lQUk+ONFtq4kMDNuITaIr1HWdTTAVjqdB2m/+BErKp/29dHQR3Sk+ABKyaVeHqWX
y36MQTDQsEIaxQyonMTxB3MVDfK7PXaix5o0brggpqlX9LLd/wlLYkNegvHq3Jfq
AQkU9N4y4UYnUUvWxbuBp/fppdcK9eUg0qoPyfpGfQRcewE2dI6l78nkt+BFtvnR
GJ0onhIbUA/AxaxlIRfpnv7UMnDep0dIQTQGswk63jTXmNO6lxgF5LSnM/uyhsLe
GE/5AVlqvUjoEwuBPs+OLOBVt7ejhMmXVGXGo7NS/esIaaxTgx89kbSImco21TUM
s7Cd7QxvmVCkJjqYglyiGcASnxJXFmBqfj2MXDvbXdSQs7cCIH7ZJZZBvnU+qHY0
toxHGg4G4P539EQUBoraOx4n18Ry2kkTsH9xqf+m+y9zLjXOZmxcVRGT9hxUoNA6
6yZ4Qil2yfkcx6K2/vikGXY6Oi06jwlJ4hEhyI8Z5yW+MOSl9bJWJ+vHwBzexas/
Gzr+NguaBop0ozVhEAuVjDVQGkcfA9dpfUT1AI0KdHBQVudoqXg=
=Y7VY
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32561@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32561
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help