[PATCH] gnu: Add emacs-git-annex.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kyle Meyer
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kyle Meyer
Severity
normal

Debbugs page

Kyle Meyer wrote 7 years ago
(address . guix-patches@gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20180825063745.16185-1-kyle@kyleam.com
* gnu/packages/emacs.scm (emacs-git-annex): New variable.
---
gnu/packages/emacs.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 2322581a3..65b285753 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -11643,3 +11643,30 @@ comments and Org files in the Magit status buffer. Activating an item jumps
to it in its file. By default, it uses keywords from @code{hl-todo}, minus a
few (like NOTE).")
(license license:gpl3))))
+
+(define-public emacs-git-annex
+ ;; Unreleased version has a fontification fix.
+ (let ((commit "ebdb44aef1883f1b2b8058e05d30fb9315b03707")
+ (revision "1"))
+ (package
+ (name "emacs-git-annex")
+ (version (string-append "1.1-" revision "." (string-take commit 8)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jwiegley/git-annex-el")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1mzv40gj7k10h7h5s43my8msgzjpj680qprqa9pp8nbyhl49v3wh"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/jwiegley/git-annex-el")
+ (synopsis "Emacs integration for git-annex")
+ (description "Enhances Dired and buffers visiting annex files with
+git-annex functionality. In Dired, the names of annex files are shortened by
+hiding the symbolic links and fontified based on whether content is present.
+Commands for performing some common operations (e.g., unlocking and adding
+files) are provided.")
+ (license license:gpl2+))))
--
2.18.0
Ludovic Courtès wrote 7 years ago
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 32527-done@debbugs.gnu.org)
87va7y6qma.fsf@gnu.org
Kyle Meyer <kyle@kyleam.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-git-annex): New variable.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32527@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32527
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help