[PATCH 2/2] gnu: python-pkgconfig: Enable tests.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Paul Garlick
Owner
unassigned
Submitted by
Paul Garlick
Severity
normal

Debbugs page

Paul Garlick wrote 7 years ago
(address . guix-patches@gnu.org)(name . Paul Garlick)(address . pgarlick@tourbillion-technology.com)
1534956087-21773-3-git-send-email-pgarlick@tourbillion-technology.com
* gnu/packages/python.scm (python-pkgconfig)[arguments]: Replace 'check'
phase.
---
gnu/packages/python.scm | 23 +++++++++++------------
1 file changed, 11 insertions(+), 12 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c0ad85c..3c46102 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8681,19 +8681,18 @@ CloudFront content delivery network.")
(inputs
`(("pkg-config" ,pkg-config)))
(arguments
- `(;; Tests fail with "ValueError: _type_ 'v' not supported" on Python 3,
- ;; and on Python 2 they need the dl module deprecated since Python 2.6.
- #:tests? #f
- ;; Hard-code the path to pkg-config.
- #:phases
+ `(#:phases
(modify-phases %standard-phases
- (add-before
- 'build 'patch
- (lambda _
- (substitute* "pkgconfig/pkgconfig.py"
- (("cmd = 'pkg-config")
- (string-append "cmd = '" (which "pkg-config"))))
- #t)))))
+ (add-before 'build 'patch
+ ;; Hard-code the path to pkg-config.
+ (lambda _
+ (substitute* "pkgconfig/pkgconfig.py"
+ (("cmd = 'pkg-config")
+ (string-append "cmd = '" (which "pkg-config"))))
+ #t))
+ (replace 'check
+ (lambda _
+ (invoke "nosetests" "test.py"))))))
(home-page "https://github.com/matze/pkgconfig")
(synopsis "Python interface for pkg-config")
(description "This module provides a Python interface to pkg-config. It
--
1.8.3.1
Leo Famulari wrote 7 years ago
Re: [bug#32497] [PATCH 0/2] *** python-pkgconfig ***
(name . Paul Garlick)(address . pgarlick@tourbillion-technology.com)(address . 32497-done@debbugs.gnu.org)(address . 32499-done@debbugs.gnu.org)(address . 32500-done@debbugs.gnu.org)(address . 32498-done@debbugs.gnu.org)
20180822191500.GB18201@jasmine.lan
On Wed, Aug 22, 2018 at 05:33:52PM +0100, Paul Garlick wrote:
Toggle quote (6 lines)
> *** The tests now pass with the updated version ***
>
> Paul Garlick (2):
> gnu: python-pkgconfig: Update to 1.3.1.
> gnu: python-pkgconfig: Enable tests.

Thanks! Pushed as 414f620fbbba353986b2ecdb6274e35a53950323
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlt9tjMACgkQJkb6MLrK
fwjrAg//cJWOqTqMxD2k9gWlVoOBlwXLxu07bWHvKdilJigfJRxZJULUkfZhtnlv
iJ2cnPn9wUEQY+p4zh4azBSIiwxufyaqmK12rFpAJwZY5pZldeLuCul//Fm+zTnX
pRmgE05io3RNYZUml20PLclS30jyz1LtQ+mUfp/Tb98CdB8cq/wM4eoTIVnlqHWg
KS4stYRt6sIAXLWTT78DQUbqFXdmokIrdfzrYSqLkYYJFS5kZpaXsArnmogE6gwd
GUnrDQxjQsW3bhL9TJS3M/CqoAiRr9Ra8vE48ivcQhxt+LsxfKAuCgTwn1VvW0Xy
Bc7XOOaSHf2Qu3q7kUjuydllWSad9qyyScO4Fs14AfVlZCMYQkiFBX6wd2kHvpTI
l+kqJ2ex9SEAXxunvpXurzVZkl2gh9xQXtmrGST+skprOH0lP9cjEtu9ManrNWUc
UIL0cmKF5NU/1NlhrG3fiEc3cYvYwfuM1EyqCMwTvna/6NVLHm1QIEg026fBKx57
swl7U2P3x5OC3IfCREN5nyQNAzjZF3pwIYkpOWIPai6w+hX94R65iC7U0jBuzt0M
jt78yFuItFxxHKqL1b9/ciavk1nCgv/otpGyAJdsH2WJMRVBTi6wO2eWjVUw0cto
Jq/jpGt2WtOOF4QlM0lSZtwwjELYhpiWz07DpgjIJ06/g5mtDhQ=
=oefI
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32500@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32500
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help