[PATCH] gnu: Add r-abcanalysis.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • pimi
Owner
unassigned
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180821114414.21031-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/bioinformatics.scm (r-abcanalysis): New variable.
---
gnu/packages/bioinformatics.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index dce8ab62f..e6b6bbaba 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2018 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -13406,3 +13407,27 @@ conversions, region filtering, FASTA sequence extraction and more.")
;; gffread is under Expat, but gclib is under Artistic 2.0
(license (list license:expat
license:artistic2.0)))))
+
+(define-public r-abcanalysis
+ (package
+ (name "r-abcanalysis")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ABCanalysis" version))
+ (sha256
+ (base32 "0wac1ksmnxa36v99ca4hv8k0rsh3igwpcllmlv9wf7i9kgqviqwi"))))
+ (properties `((upstream-name . "ABCanalysis")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-plotrix" ,r-plotrix)))
+ (home-page "https://www.uni-marburg.de/fb12/arbeitsgruppen/datenbionik/software-en")
+ (synopsis "Computed ABC Analysis")
+ (description
+ "Multivariate data sets often differ in several factors or derived statistical
+parameters, which have to be selected for a valid interpretation. Basing this
+selection on traditional statistical limits leads occasionally to the perception
+of losing information from a data set. This package provides tools to calculate
+these limits on the basis of the mathematical properties of the distribution of
+the analyzed items.")
+ (license license:gpl3)))
--
2.17.1
Leo Famulari wrote 7 years ago
Re: [bug#32489] [PATCH] gnu: Add r-miniui.
(name . MadalinIonel.Patrascu@mdc-berlin.de)(address . MadalinIonel.Patrascu@mdc-berlin.de)(address . 32492@debbugs.gnu.org)(address . 32491@debbugs.gnu.org)(name . 32489@debbugs.gnu.org)(address . 32489-done@debbugs.gnu.org)(address . 32493@debbugs.gnu.org)(address . 32490-done@debbugs.gnu.org)
20180823202936.GA25188@jasmine.lan
On Wed, Aug 22, 2018 at 07:55:59AM +0000, MadalinIonel.Patrascu@mdc-berlin.de wrote:
Toggle quote (7 lines)
> Hello Leo!
>
> Sorry about that!
> I am new on this thing.
> I can send directly to you all the patches.
> It is ok?

Thanks! I received your patches and pushed them as commit
16b0e8da48ef9398797a22e274d5fcb37e24e448.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlt/GTAACgkQJkb6MLrK
fwijCRAApoah6iTVP63ovQVVcamdDQpQp9pssLwlfKxlyPA6xO8uie63TAdhQzJd
DaGueCAKdHyBakqSqwI1MbPKdWBRXhhU2LJCW+upvQFDn4bDuS8lD7VeH9Wk+gqV
s9Rey/HlD65FING/UgmFJ6PwFF4zknGqPq/5mSgVFuFHVTtpB+7s0Oi8/DF77QWs
r2tdUlJtl+q3erh8aEJKe48E1hVjMs1JHS77eO6m6ImPSU1V/hm/H1pwHa83AsLH
D5bj+SqdSlMwFHsouw8ZCUMIZvjGNlEfOgo6ZhpQ0tbTp+vPDhDewEt7WNupca0g
XjXisiiBzpas7tZH9LCgnsjX/iB2AvGbmtWnCDAqLtW3SXuSc+OXK77W+pSy63kI
OKj72t9RkkGfuklH79NCaXFyllKe7DLK1d3TNuxNnPo/XhUEI0iYJ9YJKJgPGChl
fdeJbaM/VVXi7s5N7uKg9Zhp+ApK3r/1gu0C75F+BR8rdEMI3btJkDA6t3f+YDex
hxEdT0pl5hNP9AZiFilknpfWGdh8vq6t+epnAHWQv/iAFD2QWSIt6WSMfQXfH6wb
gTJU/02u7Bii3hzxYDL8vAZqGeUrDzjKZMgqDVMlX8AzjLjrT/SKB+FpHXTco1sG
j88oPOJrIo28IhGsedak2GfB7wnkCy8aVhXAHTrlkDqu9/j3Or8=
=JWkh
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32490@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32490
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help