pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
gnu/packages/bioinformatics.scm (r-abcanalysis): New variable.
---
gnu/packages/bioinformatics.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Toggle diff (42 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index dce8ab62f..e6b6bbaba 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2018 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -13406,3 +13407,27 @@ conversions, region filtering, FASTA sequence extraction and more.")
;; gffread is under Expat, but gclib is under Artistic 2.0
(license (list license:expat
license:artistic2.0)))))
+
+(define-public r-abcanalysis
+ (package
+ (name "r-abcanalysis")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ABCanalysis" version))
+ (sha256
+ (base32 "0wac1ksmnxa36v99ca4hv8k0rsh3igwpcllmlv9wf7i9kgqviqwi"))))
+ (properties `((upstream-name . "ABCanalysis")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-plotrix" ,r-plotrix)))
+ (home-page "https://www.uni-marburg.de/fb12/arbeitsgruppen/datenbionik/software-en")
+ (synopsis "Computed ABC Analysis")
+ (description
+ "Multivariate data sets often differ in several factors or derived statistical
+parameters, which have to be selected for a valid interpretation. Basing this
+selection on traditional statistical limits leads occasionally to the perception
+of losing information from a data set. This package provides tools to calculate
+these limits on the basis of the mathematical properties of the distribution of
+the analyzed items.")
+ (license license:gpl3)))
--
2.17.1