[PATCH] gnu: Add r-miniui.

  • Done
  • quality assurance status badge
Details
4 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Leo Famulari
  • Ludovic Courtès
  • pimi
Owner
unassigned
Submitted by
pimi
Severity
normal

Debbugs page

pimi wrote 7 years ago
(address . guix-patches@gnu.org)(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)
20180821100601.20349-1-madalinionel.patrascu@mdc-berlin.de
gnu/packages/web.scm (r-miniui): New variable.
---
gnu/packages/web.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3d9b1695b..aea75654b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2018 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6780,3 +6781,26 @@ compressed JSON header blocks.
provided by Guix. The list of packages is searchable and provides
instructions on how to use Guix in a shared HPC environment.")
(license l:agpl3+))))
+
+(define-public r-miniui
+ (package
+ (name "r-miniui")
+ (version "0.1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "miniUI" version))
+ (sha256
+ (base32
+ "1h5h2sc57h95d6bsgs95l26911g38hvjc1v50bc31xl9689l2as5"))))
+ (properties `((upstream-name . "miniUI")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-htmltools" ,r-htmltools)
+ ("r-shiny" ,r-shiny)))
+ (home-page "https://cran.r-project.org/web/packages/miniUI/")
+ (synopsis "Shiny UI widgets for small screens")
+ (description
+ "This package provides UI widget and layout functions for writing Shiny apps that
+work well on small screens.")
+ (license l:gpl3)))
--
2.17.1
Leo Famulari wrote 7 years ago
(name . pimi)(address . madalinionel.patrascu@mdc-berlin.de)(address . 32489@debbugs.gnu.org)
20180822020459.GA16402@jasmine.lan
On Tue, Aug 21, 2018 at 12:06:01PM +0200, pimi wrote:
Toggle quote (2 lines)
> gnu/packages/web.scm (r-miniui): New variable.

Thanks!

Your 5-part patch series for the R packages looks good to me and I am
ready to push it to our repo.

However, the emails you sent with git-send-email report an encoding of
'yes'.

I think that when git-send-email asked if you wanted to encode them as
UTF-8 you typed 'yes', and now git-am won't accept them. At that prompt,
it's enough to press ENTER without typing anything else.

Can you re-send them as UTF-8? Or, you could point me to a Git repo
where I can pull them from.

Thanks,
Leo
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlt8xMgACgkQJkb6MLrK
fwgWNg/+IVgm7DVd/NgbODcN/lkDL586+RmrR2pBDQStNrUNRZ3oZDr4OctOr0fQ
Aju5zJ9L7Z0LTfRETqYp1IkULaWXsIgq4szvIu72z3runEVGHKKxKHFH/eEjcPRX
pMaWbY5wGcNnxMKCn0GWfA0oZrjomUTlB2mgsbTTZZk8tFzPVVzb4GoMw89rsAB2
RU37FlrMaJdR517CDbP3zBViHja3MqfUQjUESZLZvvz4PBOh0fqg/aBemEkwYOXa
N8mh0D3GjllT+rWjHX21jg5XkPGV8t81oicq7qZzxijameDbMOstjtc72rd3/rv4
0GlRskVZNVvlzmZZ/XQCzMlpu9GGc2524WQ8uE/IL3KY6Hl+8eX8sOetceHDtSMj
MP/TdYpIBGAnFJ7M/BtB4GQU2NfmQoUAJppWIvFC1yKKEXxdJA3W9mGPmRI5lmAa
2SI0cyme4gjqGZZryE9RrBYDg+lo52rmpW1Dz8xMcP3SbB4KJOkqyp4SyC9Pv7p0
8Yf+HAQvsAzITYlYhlrmFB2A9RPF3JbFTuz8w5v9r88M8Ep8P6ayF54j9KPzR/he
mnxFBSr4t0zqDfaKLIYdMMy0Rc197Qx8sgh3zDHsaARUvUQfmRAWYl26VvWqzc7V
bdcLMV1rOoVIhF6qk6COyfk1fY/8eiBYc5aRCyaFTSo+d4dybv0=
=wmZT
-----END PGP SIGNATURE-----


MadalinIonel.Patrascu@mdc-berlin.de wrote 7 years ago
RE: [bug#32489] [PATCH] gnu: Add r-miniui.
(name . Leo Famulari)(address . leo@famulari.name)(name . 32489@debbugs.gnu.org)(address . 32489@debbugs.gnu.org)
918DDFCAA65E9447BD6F28DB666521DA97F6CD@DAGONE.mdc-berlin.net
Hello Leo!

Sorry about that!
I am new on this thing.
I can send directly to you all the patches.
It is ok?
________________________________________
From: Leo Famulari [leo@famulari.name]
Sent: Wednesday, August 22, 2018 04 :04
To: Patrascu, Madalin Ionel
Cc: 32489@debbugs.gnu.org
Subject: Re: [bug#32489] [PATCH] gnu: Add r-miniui.

On Tue, Aug 21, 2018 at 12:06:01PM +0200, pimi wrote:
Toggle quote (2 lines)
> gnu/packages/web.scm (r-miniui): New variable.

Thanks!

Your 5-part patch series for the R packages looks good to me and I am
ready to push it to our repo.

However, the emails you sent with git-send-email report an encoding of
'yes'.

I think that when git-send-email asked if you wanted to encode them as
UTF-8 you typed 'yes', and now git-am won't accept them. At that prompt,
it's enough to press ENTER without typing anything else.

Can you re-send them as UTF-8? Or, you could point me to a Git repo
where I can pull them from.

Thanks,
Leo
Ludovic Courtès wrote 7 years ago
Re: [bug#32489] [PATCH] gnu: Add r-miniui.
(name . MadalinIonel.Patrascu@mdc-berlin.de)(address . MadalinIonel.Patrascu@mdc-berlin.de)(name . 32489@debbugs.gnu.org)(address . 32489@debbugs.gnu.org)(name . Leo Famulari)(address . leo@famulari.name)
87tvnlm853.fsf@gnu.org
Hello,

"MadalinIonel.Patrascu@mdc-berlin.de"
<MadalinIonel.Patrascu@mdc-berlin.de> skribis:

Toggle quote (5 lines)
> Sorry about that!
> I am new on this thing.
> I can send directly to you all the patches.
> It is ok?

Yes, you can send the patches created by ‘git format-patch’ as an
attachment to your reply, if you want.

Thank you, and welcome!

Ludo’.
Leo Famulari wrote 7 years ago
(name . MadalinIonel.Patrascu@mdc-berlin.de)(address . MadalinIonel.Patrascu@mdc-berlin.de)(address . 32492@debbugs.gnu.org)(address . 32491@debbugs.gnu.org)(name . 32489@debbugs.gnu.org)(address . 32489-done@debbugs.gnu.org)(address . 32493@debbugs.gnu.org)(address . 32490-done@debbugs.gnu.org)
20180823202936.GA25188@jasmine.lan
On Wed, Aug 22, 2018 at 07:55:59AM +0000, MadalinIonel.Patrascu@mdc-berlin.de wrote:
Toggle quote (7 lines)
> Hello Leo!
>
> Sorry about that!
> I am new on this thing.
> I can send directly to you all the patches.
> It is ok?

Thanks! I received your patches and pushed them as commit
16b0e8da48ef9398797a22e274d5fcb37e24e448.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlt/GTAACgkQJkb6MLrK
fwijCRAApoah6iTVP63ovQVVcamdDQpQp9pssLwlfKxlyPA6xO8uie63TAdhQzJd
DaGueCAKdHyBakqSqwI1MbPKdWBRXhhU2LJCW+upvQFDn4bDuS8lD7VeH9Wk+gqV
s9Rey/HlD65FING/UgmFJ6PwFF4zknGqPq/5mSgVFuFHVTtpB+7s0Oi8/DF77QWs
r2tdUlJtl+q3erh8aEJKe48E1hVjMs1JHS77eO6m6ImPSU1V/hm/H1pwHa83AsLH
D5bj+SqdSlMwFHsouw8ZCUMIZvjGNlEfOgo6ZhpQ0tbTp+vPDhDewEt7WNupca0g
XjXisiiBzpas7tZH9LCgnsjX/iB2AvGbmtWnCDAqLtW3SXuSc+OXK77W+pSy63kI
OKj72t9RkkGfuklH79NCaXFyllKe7DLK1d3TNuxNnPo/XhUEI0iYJ9YJKJgPGChl
fdeJbaM/VVXi7s5N7uKg9Zhp+ApK3r/1gu0C75F+BR8rdEMI3btJkDA6t3f+YDex
hxEdT0pl5hNP9AZiFilknpfWGdh8vq6t+epnAHWQv/iAFD2QWSIt6WSMfQXfH6wb
gTJU/02u7Bii3hzxYDL8vAZqGeUrDzjKZMgqDVMlX8AzjLjrT/SKB+FpHXTco1sG
j88oPOJrIo28IhGsedak2GfB7wnkCy8aVhXAHTrlkDqu9/j3Or8=
=JWkh
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32489@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32489
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help