[PATCH 1/4] gnu: Add hashcat.

  • Done
  • quality assurance status badge
Details
2 participants
  • Pierre Neidhardt
  • Leo Famulari
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
P
P
Pierre Neidhardt wrote on 31 Jul 2018 12:14
(address . guix-patches@gnu.org)
20180731101435.27382-1-ambrevar@gmail.com
* gnu/packages/password-utils.scm (hashcat): New variable.
---
gnu/packages/password-utils.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 9ac30420b..91eb6d83f 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
;;; Copyright © 2018 Thomas Sigurdsen <tonton@riseup.net>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -61,6 +62,7 @@
#:use-module (gnu packages man)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages opencl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
@@ -697,3 +699,33 @@ rotating passwords on various web services. It makes it easier to rotate your
passwords, one at a time or in bulk, when security events or routine upkeep of
your online accounts makes it necessary.")
(license license:expat)))
+
+(define-public hashcat
+ (package
+ (name "hashcat")
+ (version "4.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hashcat.net/files/hashcat-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "170i2y32ykgzb1qf1wz3klwn31c09bviz4x3bnrwia65adqrj8xx"))))
+ (native-inputs
+ `(("opencl-headers" ,opencl-headers)))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;no tests
+ #:make-flags (list (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://hashcat.net/hashcat/")
+ (synopsis "Advanced password recovery utility")
+ (description "Hashcat is an advanced password recovery utility, supporting
+five unique modes of attack for over 200 highly-optimized hashing algorithms.
+Hashcat currently supports CPUs, GPUs, and other hardware accelerators on
+Linux, Windows, and macOS, and has facilities to help enable distributed
+password cracking.")
+ (license license:expat)))
--
2.18.0
P
P
Pierre Neidhardt wrote on 31 Jul 2018 12:17
[PATCH 2/4] gnu: Add hashcat-utils.
(address . 32332@debbugs.gnu.org)
20180731101723.28512-1-ambrevar@gmail.com
* gnu/packages/password-utils.scm (hashcat-utils): New variable.
---
gnu/packages/password-utils.scm | 52 +++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (69 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 91eb6d83f..4179792bb 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -63,6 +63,7 @@
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages opencl)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
@@ -729,3 +730,54 @@ Hashcat currently supports CPUs, GPUs, and other hardware accelerators on
Linux, Windows, and macOS, and has facilities to help enable distributed
password cracking.")
(license license:expat)))
+
+(define-public hashcat-utils
+ (package
+ (name "hashcat-utils")
+ (version "1.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/hashcat/hashcat-utils/releases/download/v"
+ version "/hashcat-utils-1.8.7z"))
+ (sha256
+ (base32
+ "1x80rngjz7gkhwplhw1iqr0wzb6hjkrjfld2kz9kmgp5dr9nys1p"))))
+ (native-inputs
+ `(("p7zip" ,p7zip)))
+ (inputs
+ `(("perl" ,perl)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no tests
+ #:make-flags (list "CC=gcc"
+ ;; Upstream bug(?): "make all" seems to remove the
+ ;; Perl scripts from the source.
+ "native")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda* (#:key source #:allow-other-keys)
+ (invoke "7z" "x" source)
+ (chdir (string-append "hashcat-utils-" ,version "/src"))
+ #t))
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (string-append (assoc-ref outputs "out") "/bin")))
+ (mkdir-p out)
+ (for-each (lambda (file)
+ (copy-file file (string-append out "/" (basename file ".bin"))))
+ (find-files "." "\\.bin$"))
+ (for-each (lambda (file)
+ (copy-file file (string-append out "/" (basename file ".pl"))))
+ (find-files "../bin" "\\.pl$"))
+ #t))))))
+ (home-page "https://github.com/hashcat/hashcat-utils/")
+ (synopsis "Small utilities that are useful in advanced password cracking")
+ (description "Hashcat-utils are a set of small utilities that are useful
+in advanced password cracking. They all are packed into multiple stand-alone
+binaries. All of these utils are designed to execute only one specific
+function. Since they all work with @code{STDIN} and @code{STDOUT} you can
+group them into chains.")
+ (license license:expat)))
--
2.18.0
P
P
Pierre Neidhardt wrote on 31 Jul 2018 12:17
[PATCH 4/4] gnu: Add hcxdumptool.
(address . 32332@debbugs.gnu.org)
20180731101723.28512-3-ambrevar@gmail.com
* gnu/packages/networking.scm (hcxdumptool): New variable.
---
gnu/packages/networking.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index c72c27137..7b4e8a896 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2013,3 +2013,32 @@ Features:
"This package contains a small set of tools to capture and convert
packets from wireless devices for use with hashcat or John the Ripper.")
(license license:expat))))
+
+(define-public hcxdumptool
+ (let* ((commit "f4799b5da82c5b030a6d99b02d1c1b9dc838ad36"))
+ (package
+ (name "hcxdumptool")
+ (version (git-version "0.0.0" "1" commit))
+ (home-page "https://github.com/ZerBea/hcxdumptool")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (sha256
+ (base32
+ "0qlsin0rws9sshn12faq4spmd0ffzssal36s71vhv6gkhhga7abl"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list "CC=gcc"
+ (string-append "INSTALLDIR=" (assoc-ref %outputs "out") "/bin"))
+ #:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (synopsis "Capture wlan traffic to hashcat and John the Ripper")
+ (description
+ "This package contains a small set of tools to capture and convert
+packets from wireless devices for use with hashcat or John the Ripper.")
+ (license license:expat))))
--
2.18.0
P
P
Pierre Neidhardt wrote on 31 Jul 2018 12:17
[PATCH 3/4] gnu: Add hcxtools.
(address . 32332@debbugs.gnu.org)
20180731101723.28512-2-ambrevar@gmail.com
* gnu/packages/networking.scm (hcxtools): New variable.
---
gnu/packages/networking.scm | 48 +++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 90967b9b1..c72c27137 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2018 Tonton <tonton@riseup.net>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Theodoros Foradis <theodoros@foradis.org>
+;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1965,3 +1966,50 @@ Features:
@item Destination IP blacklist
@end itemize")
(license license:asl2.0))))
+
+(define-public hcxtools
+ (let* ((commit "2ecfc9a06c2028c47522ea566ccd82b2c1f94647"))
+ (package
+ (name "hcxtools")
+ (version (git-version "0.0.0" "1" commit))
+ (home-page "https://github.com/ZerBea/hcxtools")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (sha256
+ (base32
+ "1hzwrpmxjxl674if0pp5iq06mdi24k7ni7bh1h20isp4s40201n3"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("curl" ,curl)
+ ("libpcap" ,libpcap)
+ ("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:make-flags (list "CC=gcc"
+ (string-append "INSTALLDIR=" (assoc-ref %outputs "out") "/bin"))
+ #:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'set-environment
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "C_INCLUDE_PATH"
+ (string-append (assoc-ref inputs "curl")
+ "/include:"
+ (assoc-ref inputs "libpcap")
+ "/include:"
+ (assoc-ref inputs "openssl")
+ "/include:"
+ (assoc-ref inputs "zlib")
+ "/include:"
+ (getenv "C_INCLUDE_PATH")))
+ #t)))))
+ (synopsis "Capture wlan traffic to hashcat and John the Ripper")
+ (description
+ "This package contains a small set of tools to capture and convert
+packets from wireless devices for use with hashcat or John the Ripper.")
+ (license license:expat))))
--
2.18.0
P
P
Pierre Neidhardt wrote on 31 Jul 2018 12:22
Re: bug#32332: Acknowledgement ([PATCH 1/4] gnu: Add hashcat.)
(address . 32332@debbugs.gnu.org)
877elbhfhu.fsf@gmail.com
I've packaged hashcat, hashcat-utils and hcxtools.

I don't have access to OpenCL-compatible hardware at the moment, so I
can't really test hashcat. Anyone?

Also I'm not so sure about hashcat-utils and hcxtools: the code quality
seems rather low at first glance.

hashcat-utils seems to be necessary, e.g. to convert pcap files to the
hccapx format used by hashcat.

aircrack-ng can used in stead of hcxtools. See

While the hashcat community recommends hcxtools, I am under the
impression that aircrack-ng is a much more polished tool suite.

What do you think?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAltgOE0ACgkQm9z0l6S7
zH+PmwgAi4NC9howvBB08MqqxgXA4t3uC3zDv5JPBVFOHtyhe9adU7w0EQx1h7dw
nKjPgqr3endNnPsD9TFPgl/s4Q1hMAR+B8WtRkMiVNzfzZqckhbWw+S4CLpONFNk
mY6yt/caG4KLqZLS5Xrm5L62GFgNPcvy7P1252O0elGgpIUgivyYEN6FaC7FCdnS
E3hyXdDjsSROQbZLLasLrm+Zu1KIiX+cLSyMbiILhr2lLhbFdvc59nv+l9EI3zGO
yU1TzomghpkJLdSs9CS6o+PSKNg1/cYms+EmKCpsJukiO/FuupVZBOM3ISSf/+50
qsJWrw5XZvH+Y1cwHmToIwpcVyQW/w==
=Kk9d
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 13 Aug 2018 16:59
Re: [bug#32332] Acknowledgement ([PATCH 1/4] gnu: Add hashcat.)
(name . Pierre Neidhardt)(address . ambrevar@gmail.com)(address . 32332@debbugs.gnu.org)
20180813145959.GB30613@jasmine.lan
On Tue, Jul 31, 2018 at 12:22:05PM +0200, Pierre Neidhardt wrote:
Toggle quote (19 lines)
> I've packaged hashcat, hashcat-utils and hcxtools.
>
> I don't have access to OpenCL-compatible hardware at the moment, so I
> can't really test hashcat. Anyone?
>
> Also I'm not so sure about hashcat-utils and hcxtools: the code quality
> seems rather low at first glance.
>
> hashcat-utils seems to be necessary, e.g. to convert pcap files to the
> hccapx format used by hashcat.
>
> aircrack-ng can used in stead of hcxtools. See
> https://hashcat.net/wiki/doku.php?id=cracking_wpawpa2.
>
> While the hashcat community recommends hcxtools, I am under the
> impression that aircrack-ng is a much more polished tool suite.
>
> What do you think?

I think it's up to your judgement. We package software with a wide
variety of quality. Unless there are known exploitable bugs in these
packages, I think we should go ahead and add the packages.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAltxnO8ACgkQJkb6MLrK
fwg52Q/+MXXjm6CjthPVFMa2Tl31heQxz9WDBD5VtpSdKQgZSYv978SerzvS6sbi
EQ5niOW+pXvp+/TcUnTV/2+PE+Cwdq1h9iU6GcPKVU3tPk8nu8b9QLWLJ6Y4OH2W
cao4myKLNqXgRogblGRlXIfasgtRpvpLFJBgyOx1A2evhsSqjQPc4WH5MTBTrdhk
f03A3bcwVZLZpowYfB4J9Xl3Z+nhpg/6ExjDyVoyNgi123uoaviEF7Eh2TlhCOUF
3E2iL3LUOpkZLao3qCHME0ED9stEirCj7IHzkrmPVsXzoVF1eBj1QUDRJhAT+cVS
Pdap+gn44ggfsIE1j/4nK9mgSvNDHcqKQ2vJMwC9XnKuWEQaC10HPVLFWBeJctin
TkrDkZFXLM8c4GVaGnd9zjwW43a5Pmt6FFiEUjl0di057NQprIBdaRR9eW9al2I3
9BB+8851BarulOrV5NCYhoOBd5i1NyEFjZdcwQOB4j0WRIJZ98CXFOworKpbFmp+
phJyqNf072ODtu1+tyGWrLW9wzC00JHFfS03KULvX1W3B7cqDbMaxYH+ndIUbi/8
PgMyhMonDHK4ZYPEynpf3LdXWAZyDzR/eoIHj3nF0+tY6jC4HNKxWr0BKr9Hgs3D
Qkyy48jQ2s+guEzaWLafis7mlabjDjxVacU9PpSBrleIRdSA+MM=
=PcWR
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 13 Aug 2018 17:01
Re: [bug#32332] [PATCH 1/4] gnu: Add hashcat.
(name . Pierre Neidhardt)(address . ambrevar@gmail.com)(address . 32332@debbugs.gnu.org)
20180813150135.GC30613@jasmine.lan
On Tue, Jul 31, 2018 at 12:14:35PM +0200, Pierre Neidhardt wrote:
Toggle quote (2 lines)
> * gnu/packages/password-utils.scm (hashcat): New variable.

Overall LGTM!

Toggle quote (7 lines)
> + (synopsis "Advanced password recovery utility")
> + (description "Hashcat is an advanced password recovery utility, supporting
> +five unique modes of attack for over 200 highly-optimized hashing algorithms.
> +Hashcat currently supports CPUs, GPUs, and other hardware accelerators on
> +Linux, Windows, and macOS, and has facilities to help enable distributed
> +password cracking.")

We can drop the word "advanced" here. The documentation on Synopses and
Descriptions specifically requests that we omit "marketing phrases".
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAltxnU8ACgkQJkb6MLrK
fwh0Bg//TZziEBH4fROz7NbSGt0sV7Vzxnoit3Syg4bFfvUbAPI2j7XZMMPacY4R
0ftGzvQvAaP4+bLEX4z4vegh4/UYqaNsvOPaRKyXWEzubANgyRXCaFj2ZuUswd7X
KMy7eC2gggFVBRzuqEw2NwKAcS+E7AEmK2iaDuQRBM6d2h2sATBmUPM5jAoraubL
AJXjnF5UBm9xT2auc2MMtXjEWbg/3xovZ8jmVcP0O+iQtB66tc6sgvTJTrmU6jkM
IgFZWhue6KDxYmC+JNoBNQgwhU+yVsPVZKpbMGY3uwz5B2ytFx48AAe0A6XQwybb
KZx2WqrOP9RJImRqYhgnTnm+qeQBpotcRJJ43MC7QVFls1Vc4vDY+K9pPY/nzaiQ
0wmRzdRVqDt/qXfH1GbGwyQEL14lgWfHvjxbKFzKtHvgNdCu8Xag+aGVD/HX3bps
LC+k+yGmAZTc6QkrjbvLxd1BJraFte+Wx7OIWU3W9Y/sQSC1AclKeYC1d7MwgKhF
2fbTTLgazJAeyvA/xlBVFCu4UkBcrY/6QXHP/VdgH8CfNROPiEk1j7HLYm+pZLQ9
63cYarozX2Kz6fibgYeh1LPjrOXrxx08U80TakbBDq3sMQAqzlHSgaJ5NCgeF/GA
DFHbEYfrQbT9k5swjQCM68EUadNvaHcBluLVjtrQAPZqSVtZCFA=
=Gor5
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 13 Aug 2018 17:02
Re: [bug#32332] [PATCH 4/4] gnu: Add hcxdumptool.
(name . Pierre Neidhardt)(address . ambrevar@gmail.com)(address . 32332@debbugs.gnu.org)
20180813150256.GD30613@jasmine.lan
On Tue, Jul 31, 2018 at 12:17:23PM +0200, Pierre Neidhardt wrote:
Toggle quote (7 lines)
> * gnu/packages/networking.scm (hcxdumptool): New variable.

> + (synopsis "Capture wlan traffic to hashcat and John the Ripper")
> + (description
> + "This package contains a small set of tools to capture and convert
> +packets from wireless devices for use with hashcat or John the Ripper.")

Is it correct that the packages in patches 3 and 4 have the same
descriptions?
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAltxnaAACgkQJkb6MLrK
fwis4Q/9FUuM20DIKBcjHimhwBwZsJZwkc7gUNbBLfoTrZp4s7MzXvZ7LBUClSXe
sgfMN3L7W4aTfcBh265f2OaXGhACz/3AMNQ6CfCAGwxuQDkR34vnaGDmmIykROzH
rSyK+Zi/hYGIssRES5ELmfsg6ig0iD91PWsqRUq3q3f/WFiJg90vuFpPPbYXQ0Ia
27ZAJg5LTqq8SH5FOnajG4WimRhrPtEzDNVzz4Dq8sgFwR4rOupf8Tr6nad7HHvD
bWqLFILWTibLh2h9GA6+OGOL/Qjr8ww1bjAU2vLbWV0kByah7GXM2cA630fNtYmz
Rnyt+KxLWfHXTYKjakXZ//EP6YEXrYYS3zNPUsZnAHsiq5tmHi55/jxR8IuNaPw2
JHNzHpYrHyk/3VhEuTBHLPdupq2s9yEyiVVJWUbh3yOf0uTnN0GufexH4Vi1ummA
xEdHwZlLH5gwP5yHqfYob5zWRW7LPeKo6nRbDMMtnepeRCkRC8c2kr6dQ4khdWPd
JbhSD2pMflIgYgjABUF3pb0OEk27bu/1HsCm8IYackWs1bImW6F3Z9Pg7HXufqfN
VoYSaQWa2viFQ6D6EkiWMc735wJRZDv/orHnSwCCoZ2X9mS0INVPa6DwhTwgk/e9
d0oLXPh1y1r4HLaDAZ6ngJYEMiukpM5utUxBW5gkZodTIKpNpw0=
=t6fS
-----END PGP SIGNATURE-----


P
P
Pierre Neidhardt wrote on 13 Aug 2018 17:07
(name . Leo Famulari)(address . leo@famulari.name)(address . 32332@debbugs.gnu.org)
87tvny2tlr.fsf@gmail.com
Nope :p Thanks for the catch.

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAltxnqAACgkQm9z0l6S7
zH/AaQf/TJ6nmrCd7xT5cFqtO/nVrJnBjj47jk/o5KzPpbiAem9suHUmjxW9Ievj
Ex+I368DHOyl1IuizmBxe+rDNGU0zRpK0n7iq8to14GTVMwfYCjDNfmTaukmcKwz
u8iGFtv2AwZVB7c1yogWE8zTZjzDze0MBMUOUmmUy50QHen7UpOghPI+hAmGY53/
qLzjGesOwIRnpm0BdLAT8pup7vn9isY/1S5Ktf6BuQdyVaWHLO80WCECvlIowge1
c+FNlyUCpY9zjXOgzgJzTX2bDlRCMrIBs4yNsxkMNlbXvKqWj3aIrLLpNGsudlI3
dsGag9QSEPAHXDBeMlDwg3yXvoj6Bw==
=A3SQ
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 14 Aug 2018 12:00
(name . Leo Famulari)(address . leo@famulari.name)(address . 32332@debbugs.gnu.org)
87va8duv1h.fsf@gmail.com
Merged.

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAltyqFoACgkQm9z0l6S7
zH+6awgAoR4c0zr5nne+49jnCeFZH0MLegq+4iTtHWOztEEdufMKihqGe3s1mfW5
VU6Uwt+MLGMbvxIdGZYIY9YLXHxF7VdHP8fzGapZ6IhTtqCODsyD+C6sqkk7B5eg
JR5Ca3KL9NjWLG1Pko3febrEiCWnkEBpRAdgn2/kTAEsNt9q58ZYxSwhrgB9gM6f
qD8ND7LYYIfhVY5hAE1lXWjgfa8sgu2HutcUklgvagfChiElldbGv4CM0XQjlUL9
SQ9wJJ7z+GtXC06+cvbrmIJRC6ljTdE/5TC9BiTfJw0A5/z4TFUdNYBZCxYMb+iL
kgrnBFwqoqF1ZuEUf0W+cX67a2AZKA==
=U3ji
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 14 Aug 2018 12:02
[PATCH 1/4] gnu: Add hashcat.
(address . 32332-done@debbugs.gnu.org)
87tvnxuuzi.fsf@gmail.com
Merged.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAltyqKEACgkQm9z0l6S7
zH+xQQf/a0TvDUfVmE6TqYelJ8nto8TmDxB9KgshPkPnFVCKYPi9Awszd2wAb2w8
jX9pkkuKiDAR0QuGLZJ+mS5MHoF9rBpXt0QQ1zsz6q8gtHeJsYd1JHpo+U8pw3iO
dtXDa+Kqw93z1xX4neCvUAIYMRqz7o0bWvD4HUx9iQ3iFeXOXnnZ9GqUbK5ahlxO
OaZ/QCt4k/cFeT8Jh221uJIh+H4Qy5jzxNpHUK2mfK1lp6bFwfJ0VvLcf7eYepYi
wfmzqWrVo3A2Z4CGYxrCAdfQktOHrstGKu9upJcjyfGvObMDyKnyFzBiiASs3gO0
0kPrzF/qJqTUKgN0pkbr9m8wClurCQ==
=mLUC
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32332@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32332
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch