Kei Kebreau wrote 7 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
* gnu/packages/graphics.scm (povray): New variable.
---
gnu/packages/graphics.scm | 57 +++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)
Toggle diff (70 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ad5ff8ed1..d3caba64d 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -456,6 +456,63 @@ virtual reality, scientific visualization and modeling.")
;; LGPL 2.1, but with 4 exceptions. This version is called OSGPL.
(license license:lgpl2.1)))
+(define-public povray
+ (package
+ (name "povray")
+ (version "3.7.0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/POV-Ray/povray/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1r2xaym48gmnh577h41ccs3i7dpg7aw0x838y4m4bz3j56yixlak"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete bundled libraries.
+ (delete-file-recursively "libraries")
+ #t))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (inputs
+ `(("boost" ,boost)
+ ("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ("libtiff" ,libtiff)
+ ("openexr" ,openexr)
+ ("sdl" ,sdl)
+ ("zlib" ,zlib)))
+ (arguments
+ '(#:configure-flags
+ (list "COMPILED_BY=Guix"
+ (string-append "--with-boost-libdir="
+ (assoc-ref %build-inputs "boost") "/lib")
+ "CXXFLAGS=-std=c++11")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'run-prebuild
+ (lambda _
+ (setenv "HOME" (getcwd))
+ (with-directory-excursion "unix"
+ (invoke "sh" "prebuild.sh"))
+ #t)))))
+ (synopsis "Tool for creating three-dimensional graphics")
+ (description
+ "@code{POV-Ray} is short for the Persistence of Vision Raytracer, a tool
+for producing high-quality computer graphics. @code{POV-Ray} creates
+three-dimensional, photo-realistic images using a rendering technique called
+ray-tracing. It reads in a text file containing information describing the
+objects and lighting in a scene and generates an image of that scene from the
+view point of a camera also described in the text file. Ray-tracing is not a
+fast process by any means, but it produces very high quality images with
+realistic reflections, shading, perspective and other effects.")
+ (home-page "http://www.povray.org/")
+ (license license:agpl3+)))
+
(define-public rapicorn
(package
(name "rapicorn")
--
2.18.0