[PATCH] gnu: Add povray.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Kei Kebreau
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 7 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20180730205358.25014-1-kkebreau@posteo.net
* gnu/packages/graphics.scm (povray): New variable.
---
gnu/packages/graphics.scm | 57 +++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ad5ff8ed1..d3caba64d 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -456,6 +456,63 @@ virtual reality, scientific visualization and modeling.")
;; LGPL 2.1, but with 4 exceptions. This version is called OSGPL.
(license license:lgpl2.1)))
+(define-public povray
+ (package
+ (name "povray")
+ (version "3.7.0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/POV-Ray/povray/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1r2xaym48gmnh577h41ccs3i7dpg7aw0x838y4m4bz3j56yixlak"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete bundled libraries.
+ (delete-file-recursively "libraries")
+ #t))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (inputs
+ `(("boost" ,boost)
+ ("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ("libtiff" ,libtiff)
+ ("openexr" ,openexr)
+ ("sdl" ,sdl)
+ ("zlib" ,zlib)))
+ (arguments
+ '(#:configure-flags
+ (list "COMPILED_BY=Guix"
+ (string-append "--with-boost-libdir="
+ (assoc-ref %build-inputs "boost") "/lib")
+ "CXXFLAGS=-std=c++11")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'run-prebuild
+ (lambda _
+ (setenv "HOME" (getcwd))
+ (with-directory-excursion "unix"
+ (invoke "sh" "prebuild.sh"))
+ #t)))))
+ (synopsis "Tool for creating three-dimensional graphics")
+ (description
+ "@code{POV-Ray} is short for the Persistence of Vision Raytracer, a tool
+for producing high-quality computer graphics. @code{POV-Ray} creates
+three-dimensional, photo-realistic images using a rendering technique called
+ray-tracing. It reads in a text file containing information describing the
+objects and lighting in a scene and generates an image of that scene from the
+view point of a camera also described in the text file. Ray-tracing is not a
+fast process by any means, but it produces very high quality images with
+realistic reflections, shading, perspective and other effects.")
+ (home-page "http://www.povray.org/")
+ (license license:agpl3+)))
+
(define-public rapicorn
(package
(name "rapicorn")
--
2.18.0
Kei Kebreau wrote 7 years ago
(address . 32321@debbugs.gnu.org)
8736w0rv1r.fsf@posteo.net
The attached patch disables CPU-specific optimization and fixes
detection of OpenEXR.
From fd4cae93f6c6eb4a8573ae02ad783ff39cd5279d Mon Sep 17 00:00:00 2001
From: Kei Kebreau <kkebreau@posteo.net>
Date: Mon, 30 Jul 2018 16:25:21 -0400
Subject: [PATCH] gnu: Add povray.

* gnu/packages/graphics.scm (povray): New variable.
---
gnu/packages/graphics.scm | 59 +++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (72 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ad5ff8ed1..585215956 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -456,6 +456,65 @@ virtual reality, scientific visualization and modeling.")
;; LGPL 2.1, but with 4 exceptions. This version is called OSGPL.
(license license:lgpl2.1)))
+(define-public povray
+ (package
+ (name "povray")
+ (version "3.7.0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/POV-Ray/povray/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1r2xaym48gmnh577h41ccs3i7dpg7aw0x838y4m4bz3j56yixlak"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete bundled libraries.
+ (delete-file-recursively "libraries")
+ #t))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("boost" ,boost)
+ ("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ("libtiff" ,libtiff)
+ ("openexr" ,openexr)
+ ("sdl" ,sdl)
+ ("zlib" ,zlib)))
+ (arguments
+ '(#:configure-flags
+ (list "COMPILED_BY=Guix"
+ (string-append "--with-boost-libdir="
+ (assoc-ref %build-inputs "boost") "/lib")
+ "CXXFLAGS=-std=c++11"
+ "--disable-optimiz-arch")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'run-prebuild
+ (lambda _
+ (setenv "HOME" (getcwd))
+ (with-directory-excursion "unix"
+ (invoke "sh" "prebuild.sh"))
+ #t)))))
+ (synopsis "Tool for creating three-dimensional graphics")
+ (description
+ "@code{POV-Ray} is short for the Persistence of Vision Raytracer, a tool
+for producing high-quality computer graphics. @code{POV-Ray} creates
+three-dimensional, photo-realistic images using a rendering technique called
+ray-tracing. It reads in a text file containing information describing the
+objects and lighting in a scene and generates an image of that scene from the
+view point of a camera also described in the text file. Ray-tracing is not a
+fast process by any means, but it produces very high quality images with
+realistic reflections, shading, perspective and other effects.")
+ (home-page "http://www.povray.org/")
+ (license license:agpl3+)))
+
(define-public rapicorn
(package
(name "rapicorn")
--
2.18.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAltfyxAACgkQ5qXuPBlG
eg2nRxAAvel/q74ascK75rRULEbxbElmg+o8jK+hGJZlSm/lLYDammRMT7ZjlqAE
gSmR6Pj79gBmSFzLqZ/nvTZ/R3/N6ZWiyh1MVOTJ0FmuB7ql9gtrNdoC96G+o4fT
4Amx121HBd8c8f+T69F4kUL6jGe7lf92eyDsGHcr7uor6Zr289cZZfKxcflnrV9k
TS2oblduCYW+y8dkhA9efJUNOn8L2ubluItwhOOUnTnl1l9LqOYVaB726sfv1lX2
s912ILz412E6rQJdmSZYZThmgoBjd5aPyFafSNPci9OvisHE72vvRq8hsneAAGin
INJD0M5vfYng/xoP3oHfz619JqJx5sCNgJdtc7Ul/CSYMbnKRiEBso1dpgeOrz3X
UBcolP494tVmyvqo1II6EPiJNMIJQghzLDGHRXtpna0y8M11wj8Fs27YFPftZFaG
MR2iqv3m4BFYq9BX8y4AnMJq0fKh89zrhqkGvi1ggTM1EucWaMeOAvTfWEI2V83h
MSeWNMlxoF28eMTGl/WYOieND0JLreu93AnA6Ip0YAejEtWujzBrTmKsJvd/Q0HR
ycvpfpBwa26xgKMg5p0DhqJlm3fFFxzcceIhybKXHxx6sU0e5PamDMH+z36BGXkN
cb5yUzdcmMyrA8w/J00wJgJV3dsxwSIPPzr1NU3ETVGvEL+HCuc=
=3HID
-----END PGP SIGNATURE-----

Efraim Flashner wrote 7 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 32321@debbugs.gnu.org)
20180802152501.GF13776@macbook41
On Mon, Jul 30, 2018 at 10:36:00PM -0400, Kei Kebreau wrote:

Toggle quote (7 lines)
> + (version "3.7.0.8")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/POV-Ray/povray/archive/v"
> + version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))

Don't use the unstable tarball, download it using git-fetch.

Toggle quote (3 lines)
> + (sha256
> + (base32
> + "1r2xaym48gmnh577h41ccs3i7dpg7aw0x838y4m4bz3j56yixlak"))
<snip>
Toggle quote (5 lines)
> + (string-append "--with-boost-libdir="
> + (assoc-ref %build-inputs "boost") "/lib")
> + "CXXFLAGS=-std=c++11"
> + "--disable-optimiz-arch")

I have to ask, is 'optimiz' spelled correctly?

Toggle quote (1 lines)
> + #:phases
<snip>

It built without any problems for me on aarch64



--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAltjIkkACgkQQarn3Mo9
g1F6og/+MXOapPqn6vWBOpwFCrejZR9ay1Vyb5Bdc392WFjzSmk/SN9bdyEYql5M
h0PdFwN8D8Kfi0/yu16vjHhSdBrZkTHR5OBpvnyfiZjE01fLk1a0K4Nu20MIsxnQ
qxy0VrJz7YbZI3f64JESYlcnBSClfCfQVyskRzP7bPOxzNcIkGgdCmijBqAX45Zj
DB0YjuWSczQY6kEyZ3+5rJyLQ759x4fwrnkJ+lj+PFKhPsX2ATzP/uBBjpb+Sdr8
sGftsJup7SvNKRtA6R86F6g5lPYiA2NTqFx367T3gVPa85G79WEuP323QePo5poM
HOmhQFzLkQll0As7ldGaiX+JqpWWqlo4LRmVUQDDddj1XJayFzYTWlOQkfnmymn/
pgommiELxxSd1axt/eXXETlJDQSMbgohF0nglazZAAuKfpG9f3316cpdErTh6l6n
9YZ9vMFqe0r3acdlRFD94JTMPVnSCTWBswIf30rCEn1hIbqkkZNmL9zUwDGRe11b
WsmpQIYG8NbPMS+KlMKV6sCkHi9c6/vI0g+FGsn7ZesuFjfgWZTcp6XGamK6yphL
G9s2PVkBy0o9XkUs+K3e2iieIjjFFA7Wd90Ot+9FbRJvjb4SxeleqZ29knAf8/Ct
g31z0VmC5crVPXNTqO4myr8+eb001heErD+eoPc3x6eCAj9VRiI=
=CLzT
-----END PGP SIGNATURE-----


Kei Kebreau wrote 7 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 32321@debbugs.gnu.org)
87r2jgd4pa.fsf@posteo.net
Efraim Flashner <efraim@flashner.co.il> writes:

Toggle quote (11 lines)
> On Mon, Jul 30, 2018 at 10:36:00PM -0400, Kei Kebreau wrote:
>
>> + (version "3.7.0.8")
>> + (source (origin
>> + (method url-fetch)
>> + (uri (string-append "https://github.com/POV-Ray/povray/archive/v"
>> + version ".tar.gz"))
>> + (file-name (string-append name "-" version ".tar.gz"))
>
> Don't use the unstable tarball, download it using git-fetch.

If I'm not misunderstanding POV-Ray's version numbering scheme, this is
a source code maintainance release with no changes in functionality.

Toggle quote (12 lines)
>
>> + (sha256
>> + (base32
>> + "1r2xaym48gmnh577h41ccs3i7dpg7aw0x838y4m4bz3j56yixlak"))
> <snip>
>> + (string-append "--with-boost-libdir="
>> + (assoc-ref %build-inputs "boost") "/lib")
>> + "CXXFLAGS=-std=c++11"
>> + "--disable-optimiz-arch")
>
> I have to ask, is 'optimiz' spelled correctly?

just grep in "unix/install.txt" and "unix/configure.ac" in the source
distribution).

Toggle quote (6 lines)
>
>> + #:phases
> <snip>
>
> It built without any problems for me on aarch64

Excellent, and thanks for reviewing!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAltjR/EACgkQ5qXuPBlG
eg3owQ/6AtFEL365b9T9LbutGnTqs4E9LR4OlCEB7gdD0MfHkdH1PS00b+Z3MBUQ
vmF3ltSJNbypJbB7RiGGuiE9PK6y5ipYJCpArlpmdhTo3VPfHl48gwIu1dkxriFJ
IptCSKkOSQm9kmlro842u9D/tdm3W9u0RV6Ma4vq8tO7jEZAEBC81c5jIkfphu4m
EBlTv4dJkzSzFSPvvfJPko50XD8vUWGBK5BxW1UlFIg3ldWNWdN3ZAPRv4E3nQUe
Oyy/vcft1edDkSrCQuL1K3stxUEajn00G6Onp2fFyXUQZAY9bPHii4Mhq/Vam9AT
Wzo91dmxB8aU4FZhfgCbOrkU2K08yU06o8p+h0UAJLJyZgAWZQmZWjvF1YbXeUib
hG1XbNDRb0ER/+ptW3Q+5X2/SBa+2tbw/gb42RJ8BPbXAplnWK2X3oanW4bc5kcG
fR0JoEpGM04WIxXlsWYSNSSPLeSeZFP3NvK9rW38tmd+eHjWC4qeGc2Yn0iSSh4H
kjLnCi6LkvPunCvCgaQGU9Q+c3rLx8QTNUUByxvp/FXMx5TgSSDGv7EeaKqYm5OG
zBl6XuxoV9+hbSw0VPlE61Ot1iwrHBkzGkwNBfPUIoBWLFZIKZiafEROCDr4rFsL
WH29164fvM72tX8bUk07wVVd4Yqpv0ozD0WpUCM0ui+QUH3ucWQ=
=lcVN
-----END PGP SIGNATURE-----

Kei Kebreau wrote 7 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 32321@debbugs.gnu.org)
87o9ekcj2s.fsf@posteo.net
Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (18 lines)
> Efraim Flashner <efraim@flashner.co.il> writes:
>
>> On Mon, Jul 30, 2018 at 10:36:00PM -0400, Kei Kebreau wrote:
>>
>>> + (version "3.7.0.8")
>>> + (source (origin
>>> + (method url-fetch)
>>> + (uri (string-append "https://github.com/POV-Ray/povray/archive/v"
>>> + version ".tar.gz"))
>>> + (file-name (string-append name "-" version ".tar.gz"))
>>
>> Don't use the unstable tarball, download it using git-fetch.
>
> If I'm not misunderstanding POV-Ray's version numbering scheme, this is
> a source code maintainance release with no changes in functionality.
> See "https://github.com/POV-Ray/povray/releases/tag/v3.7.0.8".
>

Never mind about the unstable tarball bit. After further research, about
GitHub's archive generation, I now see what you mean. Apparently many
other projects get hit with this bug as well. I'll switch to using
git-fetch and push this to master after some more testing. Thanks again!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAltjtWsACgkQ5qXuPBlG
eg1Q/Q//cP6/BzhnjPq1bOlkGnV7P9yv74Oc5ZoIM15zaM+qLsJE1KNthp2k5kRf
WbJF4W9a8fBTcQfv4crvPrW5t3UhP9s93muLeX5TuVyUHUpjANVQ2dl5N3A5gOpA
vf21t1kesGqPM/nL3ClnyUmAPZ0yLXC09gXfoD5SkKtB0rXoiofzBc/12bIyauMI
JwlZ49at5TxmkNuiVgKRv5hot5kWUY/3C9clUh2JFmi9OeUCr70ENNGaHHcRvMrV
zSf5/3/yx9DfphYeQLkBka0DNCwIlu+VAsN/63sPCGw3qhFe3OjNQVMjIQekTB89
VjmJWA+CYVmlhlyR4hf89FEWZ36ZYbo6lD6BC7K5DsubChoa5fQtj+/08JS9V6sQ
kGwmMRs/y28Ecm/9/SJsrPzJnAw7ZHbluHws+ymxvxwbu4wHpQMBJTyEHFLd9I40
Bp3jbs7LQEQefWcQ1C214Xwee540cyDUFhAYyrRH8DKFDfaS1Diz7CtnpRsAV63K
JOaE1wAR9Nf2Hkn6BIE0MYGGJIxMrOInBL6wkXzRFjcKdAqfD4OZpUpGtqs6Kvwq
hsODM7sfTwq2BS3RLuJV8j/8kSEVaWAC5sfdpJwIRFsOF23QTZ6paOJZH0hcNuEs
21k8rTD84CAQ15nFiFDXTWISiqtncbOOg2PGxkjXnXPzgXJUFeI=
=PYih
-----END PGP SIGNATURE-----

Kei Kebreau wrote 7 years ago
(address . 32321-done@debbugs.gnu.org)
87va8p1lik.fsf@posteo.net
Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (25 lines)
> Kei Kebreau <kkebreau@posteo.net> writes:
>
>> Efraim Flashner <efraim@flashner.co.il> writes:
>>
>>> On Mon, Jul 30, 2018 at 10:36:00PM -0400, Kei Kebreau wrote:
>>>
>>>> + (version "3.7.0.8")
>>>> + (source (origin
>>>> + (method url-fetch)
>>>> + (uri (string-append "https://github.com/POV-Ray/povray/archive/v"
>>>> + version ".tar.gz"))
>>>> + (file-name (string-append name "-" version ".tar.gz"))
>>>
>>> Don't use the unstable tarball, download it using git-fetch.
>>
>> If I'm not misunderstanding POV-Ray's version numbering scheme, this is
>> a source code maintainance release with no changes in functionality.
>> See "https://github.com/POV-Ray/povray/releases/tag/v3.7.0.8".
>>
>
> Never mind about the unstable tarball bit. After further research, about
> GitHub's archive generation, I now see what you mean. Apparently many
> other projects get hit with this bug as well. I'll switch to using
> git-fetch and push this to master after some more testing. Thanks again!

Pushed to master as 340ee00bb.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAltmfdMACgkQ5qXuPBlG
eg0Gng//bQ0SYfjMASNPGOFNjtsrY/d3h3Lvdxybk4UhBV5A9irijP8po/IYZaMP
C/nU2a7cdQbkqn65/M65F4fXRhGmI1nQH0aRmNxPU+ayN+Z0UTpQ5JtRg9nOh7yy
Gc2UOcwSZ8m/G8YwUzRd32v5UBkWdW2y+2BgS2wRVtrLrzceCSX/QwTfIqMHKXAX
3Y2Z8LVYYywPWL2gUhTOXmjre1N0ijVbpZp77fERRZGJ+NHyMj5dKaRN2cUyDcXK
p9CHIi0SnjNRWhvEBOaB+AU0x5kutUGg8sB9ap74SYjkdj+WCQ8m9FzrfUdlYOQg
hzEDLA0cBjxqG0Abdmtmf1EsRsnVfQArFj4V1bPmsc98sZkugVyFTIheqA06i6+r
mz7pgkcOwnbKsxgEO/H0Fp4EbLBZ3IhFXmaOLVB21v4oIZLImuEfbK07XkkyB9xH
/gPzK5EzqfRXubAoBp0eU44zO58pidK9NfVF3D1poPODejWrFfCE3smTlvctTBD5
yz+mdc2dA4I2daTOue0Mm/9wYAedpquwKflHjM3uZjN0QwgRpds47A2HpyQAXWin
TrSfiHfPOc+CyxsppSitl45vQv3xwduyL9mlPEqNCg7b6ufw21K5rn7hLk5V4g4i
hbyXVWU2fce+kkkWE1CSCBQsbqUAEyxjUHHpOz1pHbpedAms7KA=
=xPp4
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32321@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32321
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help