[PATCH] gnu: Add imapfilter.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jelle Licht
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jelle Licht
Severity
normal

Debbugs page

Jelle Licht wrote 7 years ago
(address . guix-patches@gnu.org)
877elg8xdg.fsf@fsfe.org
* gnu/packages/mail.scm (imapfilter): New variable.
---
gnu/packages/mail.scm | 44 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 3d7b0e463..fc02fa50e 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2554,3 +2554,47 @@ and binaries. It supports offline reading, scoring and killfiles, yEnc, NZB,
PGP handling, multiple servers, and secure connections.")
;; License of the docs: fdl-1.1; Others: gpl2.
(license (list fdl1.1+ gpl2))))
+
+(define-public imapfilter
+ (package
+ (name "imapfilter")
+ (version "2.6.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/lefcha/imapfilter/archive/"
+ "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1yslvwr3w5fnl06gfrp0lim8zdlasx3cvgd2fsqi0695xnb9bsms"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fix-include-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((pcre (assoc-ref inputs "pcre")))
+ (substitute* "src/Makefile"
+ (("INCDIRS =")
+ (string-append "INCDIRS ="
+ "-I" pcre "/include")))
+ #t))))))
+ (native-inputs
+ `(("lua" ,lua)
+ ("pcre" ,pcre)
+ ("openssl" ,openssl)))
+ (home-page "https://github.com/lefcha/imapfilter")
+ (synopsis "IMAP mail filtering utility")
+ (description "@code{IMAPFilter} is a mail filtering utility. It connects
+to remote mail servers using IMAP, sends searching queries to the server and
+processes mailboxes based on the results. It can be used to delete, copy,
+move, flag, etc. messages residing in mailboxes at the same or different mail
+servers. The 4rev1 and 4 versions of IMAP are supported.")
+ (license license:expat)))
--
2.18.0
Ludovic Courtès wrote 7 years ago
(name . Jelle Licht)(address . jlicht@fsfe.org)(address . 32294@debbugs.gnu.org)
87h8kif8gg.fsf@gnu.org
Hi,

Jelle Licht <jlicht@fsfe.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/mail.scm (imapfilter): New variable.

[...]

Toggle quote (4 lines)
> + (synopsis "IMAP mail filtering utility")
> + (description "@code{IMAPFilter} is a mail filtering utility. It connects

I think you can omit @code here (since “IMAPFilter” is a proper name and
not an identifier or command name), but otherwise LGTM. Thanks!

Ludo’.
Jelle Licht wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 32294-done@debbugs.gnu.org)
CAPsKtfJs9fL5SJ7RejdzN4pY1dk9MvY3o0+jjj_890szdd2rJw@mail.gmail.com
2018-07-29 16:00 GMT+02:00 Ludovic Courtès <ludo@gnu.org>:

Toggle quote (19 lines)
> Hi,
>
> Jelle Licht <jlicht@fsfe.org> skribis:
>
> > * gnu/packages/mail.scm (imapfilter): New variable.
>
> [...]
>
> > + (home-page "https://github.com/lefcha/imapfilter")
> > + (synopsis "IMAP mail filtering utility")
> > + (description "@code{IMAPFilter} is a mail filtering utility. It
> connects
>
> I think you can omit @code here (since “IMAPFilter” is a proper name and
> not an identifier or command name), but otherwise LGTM. Thanks!
>
> Ludo’.
>

done, and pushed as ae7c1c3704187405a1c4e7c039bf70df9327e6a6
Attachment: file
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32294@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32294
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help