Add chroma (a little video game)

  • Done
  • quality assurance status badge
Details
3 participants
  • Björn Höfling
  • Christopher Lemmer Webber
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Christopher Lemmer Webber
Severity
normal

Debbugs page

Christopher Lemmer Webber wrote 7 years ago
(address . bug-guix@gnu.org)
878t5x65hl.fsf@dustycloud.org
From 3ca38f3813eb7e6473673622de04b8fbb03d256d Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Thu, 26 Jul 2018 17:37:53 -0400
Subject: [PATCH] gnu: Add chroma.

* gnu/packages/games.scm (chroma): New variable.
---
gnu/packages/games.scm | 34 +++++++++++++++++++++++++++++++++-
1 file changed, 33 insertions(+), 1 deletion(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4af0b52e8..b19caacc7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
-;;; Copyright © 2015, 2017 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2015, 2017, 2018 Christopher Lemmer Webber <cwebber@dustycloud.org>
;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
@@ -3983,6 +3983,38 @@ laws of physics (Enigma’s special laws of physics, that is), controlling them
with the mouse isn’t always trivial.")
(license license:gpl2+)))
+(define-public chroma
+ (package
+ (name "chroma")
+ (version "1.15")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://level7.org.uk/chroma/download/chroma-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0nzm3j5wjazr1d6pkydqlc48sjf72hggq0hmx8mhq03114mmiir5"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests included
+ (inputs
+ `(("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf)))
+ ("freetype" ,freetype)
+ ("ncurses" ,ncurses)
+ ("fontconfig" ,fontconfig)
+ ("libxft" ,libxft)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://level7.org.uk/chroma/")
+ (synopsis "Abstract puzzle game")
+ (description "Chroma is an abstract puzzle game. A variety of colourful
+shapes are arranged in a series of increasingly complex patterns, forming
+ fiendish traps that must be disarmed and mysterious puzzles that must be
+ manipulated in order to give up their subtle secrets. Initially so
+ straightforward that anyone can pick it up and begin to play, yet gradually
+ becoming difficult enough to tax even the brightest of minds.")
+ (license license:gpl2+)))
+
(define-public fillets-ng
(package
(name "fillets-ng")
--
2.18.0
BTW I also updated my copyright line in the process. I should probably
do it in other files as well, since I've patched my name IRL as well.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEUQqGKOKndniPjHCcS8Alkl/49NMFAltaP7YACgkQS8Alkl/4
9NNmfQ//cFDcxOjlFiqUhPCrv4lpdIwAwkJ/pu2pVLEFAa9fvxnvRsR2l1G+xhIq
/vNruP8JtjYke4ly10D/nZkiumm/L++oomu5Tv2VoOsAzYt0riuBJrTz4XDvdPRc
n3obQfUlIRFn2qa2juizKRRzvngQ8zD4FufiuxrSLzVr1XXBDAJ4LpTQFhuYCl+o
8Fns7yUmme7JpMwXkXQ04TTDTQct2wn3lfYnOu0JqGLXert2jy2OrbrktL8FvzsP
BFX9DO2NZBpoE7Fn+aEoJiSOtEhFceGGqmAFQuNj1xbFA0uJ0+UHrIlTWSCcvkwC
O6rBzyHRtqryewDIkhGoWXiTcbfw2cZC9XocdM00EmBSeMdeBuG5B+ix9UfWtW8U
G8qgqev4FJEWNol8uODjhb/sUfL/lZVRBZckF50rtNcFL13t+sDIFW0rLRR8/vRs
b0QPcrooaMl5BZXMjzrpJZzgd4IQNI3tZfjf45jmDlNTMZadvLuqrRx908Ph/XhX
TgqchzCM2wi05KsjiER6J6ExMcK/sEJXF7MXkKPo0d5kKxsqiPcvblKjVFdH6AZd
H47rBaX1dXNFRTf8JTB5/t79oq2pmeNsiPAkMG0vFgDaI1C9ioaZ6a8/BG8lupkL
cbuNHJwknOLyf6xDrbamKGqg6X5IbqLCvr1I0YmomtXBr5Zi0rs=
=TlMx
-----END PGP SIGNATURE-----

Björn Höfling wrote 7 years ago
(name . Christopher Lemmer Webber)(address . cwebber@dustycloud.org)(address . 32283@debbugs.gnu.org)
20180728225737.3e6e9283@alma-ubu
On Thu, 26 Jul 2018 17:40:06 -0400
Christopher Lemmer Webber <cwebber@dustycloud.org> wrote:

Toggle quote (69 lines)
> From 3ca38f3813eb7e6473673622de04b8fbb03d256d Mon Sep 17 00:00:00 2001
> From: Christopher Lemmer Webber <cwebber@dustycloud.org>
> Date: Thu, 26 Jul 2018 17:37:53 -0400
> Subject: [PATCH] gnu: Add chroma.
>
> * gnu/packages/games.scm (chroma): New variable.
> ---
> gnu/packages/games.scm | 34 +++++++++++++++++++++++++++++++++-
> 1 file changed, 33 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 4af0b52e8..b19caacc7 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -10,7 +10,7 @@
> ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
> ;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
> ;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
> -;;; Copyright © 2015, 2017 Christopher Allan Webber
> <cwebber@dustycloud.org> +;;; Copyright © 2015, 2017, 2018
> Christopher Lemmer Webber <cwebber@dustycloud.org> ;;; Copyright ©
> 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net> ;;;
> Copyright © 2015, 2016, 2017 Alex Kost <alezost@gmail.com> ;;;
> Copyright © 2015 Paul van der Walt <paul@denknerd.org> @@ -3983,6
> +3983,38 @@ laws of physics (Enigma’s special laws of physics, that
> is), controlling them with the mouse isn’t always trivial.") (license
> license:gpl2+)))
> +(define-public chroma
> + (package
> + (name "chroma")
> + (version "1.15")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append
> "http://level7.org.uk/chroma/download/chroma-"
> + version ".tar.bz2"))
> + (sha256
> + (base32
> +
> "0nzm3j5wjazr1d6pkydqlc48sjf72hggq0hmx8mhq03114mmiir5"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:tests? #f)) ; no tests included
> + (inputs
> + `(("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer
> sdl-ttf)))
> + ("freetype" ,freetype)
> + ("ncurses" ,ncurses)
> + ("fontconfig" ,fontconfig)
> + ("libxft" ,libxft)))
> + (native-inputs
> + `(("pkg-config" ,pkg-config)))
> + (home-page "http://level7.org.uk/chroma/")
> + (synopsis "Abstract puzzle game")
> + (description "Chroma is an abstract puzzle game. A variety of
> colourful +shapes are arranged in a series of increasingly complex
> patterns, forming
> + fiendish traps that must be disarmed and mysterious puzzles that
> must be
> + manipulated in order to give up their subtle secrets. Initially so
> + straightforward that anyone can pick it up and begin to play, yet
> gradually
> + becoming difficult enough to tax even the brightest of minds.")
> + (license license:gpl2+)))
> +
> (define-public fillets-ng
> (package
> (name "fillets-ng")

LGTM.

The only "bug" here is you posted it to the bugs tracker, not the
patches-tracker.

Björn
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAltc2MIACgkQvyhstlk+X/1kWACgnSg+5dAVrBQibrEv9twbIbR/
bLUAn04IyouF53ViM6RuDESjckUy51g7
=x2pF
-----END PGP SIGNATURE-----


Ricardo Wurmus wrote 7 years ago
(name . Christopher Lemmer Webber)(address . cwebber@dustycloud.org)(address . 32283-done@debbugs.gnu.org)
87o9eqsd92.fsf@elephly.net
Christopher Lemmer Webber <cwebber@dustycloud.org> writes:

Toggle quote (8 lines)
> From 3ca38f3813eb7e6473673622de04b8fbb03d256d Mon Sep 17 00:00:00 2001
> From: Christopher Lemmer Webber <cwebber@dustycloud.org>
> Date: Thu, 26 Jul 2018 17:37:53 -0400
> Subject: [PATCH] gnu: Add chroma.
>
> * gnu/packages/games.scm (chroma): New variable.
> ---

Thank you. Pushed to the “master” branch with commit 10d531536.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32283@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32283
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help