[PATCH] gnu: Add openbabel.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 7 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20180714030406.28139-1-kkebreau@posteo.net
* gnu/packages/chemistry.scm (openbabel): New variable.
---
gnu/packages/chemistry.scm | 43 ++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 1a5086d62..a58f936ae 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -21,10 +21,15 @@
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix download)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages gv)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages xml)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python))
@@ -198,3 +203,41 @@ neutron scattering spectra, but also computes other quantities. The software
is currently not actively maintained and works only with Python 2 and
NumPy < 1.9.")
(license license:cecill)))
+
+(define-public openbabel
+ (package
+ (name "openbabel")
+ (version "2.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/" name "/" name "/"
+ version "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1z3d6xm70dpfikhwdnbzc66j2l49vq105ch041wivrfz5ic3ch90"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "-DOPENBABEL_USE_SYSTEM_INCHI=ON"
+ (string-append "-DINCHI_LIBRARY="
+ (assoc-ref %build-inputs "inchi")
+ "/lib/inchi/libinchi.so.1")
+ (string-append "-DINCHI_INCLUDE_DIR="
+ (assoc-ref %build-inputs "inchi") "/include/inchi"))
+ #:test-target "test"))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("eigen" ,eigen)
+ ("inchi" ,inchi)
+ ("libxml2" ,libxml2)
+ ("zlib" ,zlib)))
+ (home-page "http://openbabel.org/wiki/Main_Page")
+ (synopsis "Chemistry data manipulation toolbox")
+ (description
+ "Open Babel is a chemical toolbox designed to speak the many languages of
+chemical data. It's a collaborative project allowing anyone to search, convert,
+analyze, or store data from molecular modeling, chemistry, solid-state
+materials, biochemistry, or related areas.")
+ (license license:gpl2)))
--
2.18.0
Ludovic Courtès wrote 7 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 32151@debbugs.gnu.org)
87d0vlsdta.fsf@gnu.org
Hello Kei,

Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/chemistry.scm (openbabel): New variable.

LGTM!

Toggle quote (2 lines)
> + (license license:gpl2)))

Could you double-check whether it’s v2-only?

Thank you,
Ludo’.
Kei Kebreau wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 32151-done@debbugs.gnu.org)
87y3e9l5o9.fsf@posteo.net
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (13 lines)
> Hello Kei,
>
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> * gnu/packages/chemistry.scm (openbabel): New variable.
>
> LGTM!
>
>> + (license license:gpl2)))
>
> Could you double-check whether it’s v2-only?
>

I just checked, and it is v2-only.

Toggle quote (3 lines)
> Thank you,
> Ludo’.

Thanks for the review!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32151@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32151
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help