[PATCH] gnu: make-u-boot-package: Don't install "sunxi-spl-with-ecc.bin".

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180713135748.15120-1-dannym@scratchpost.org
* gnu/packages/bootloaders.scm (make-u-boot-package)[arguments]<#:phases>
[install]: Don't install "sunxi-spl-with-ecc.bin".
---
gnu/packages/bootloaders.scm | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 7599f4ac2..19d47e6e5 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -508,7 +508,19 @@ board-independent tools.")))
(let* ((out (assoc-ref outputs "out"))
(libexec (string-append out "/libexec"))
(uboot-files (append
- (find-files "." ".*\\.(bin|efi|img|spl|itb|dtb|rksd)$")
+ (filter
+ ;; Those would not be reproducible
+ ;; because of the randomness used
+ ;; to produce them.
+ ;; It's expected that the user will
+ ;; use u-boot-tools to generate them
+ ;; instead.
+ (lambda (name)
+ (not
+ (string-suffix?
+ "sunxi-spl-with-ecc.bin"
+ name)))
+ (find-files "." ".*\\.(bin|efi|img|spl|itb|dtb|rksd)$"))
(find-files "." "^(MLO|SPL)$"))))
(mkdir-p libexec)
(install-file ".config" libexec)
Ludovic Courtès wrote 7 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 32140@debbugs.gnu.org)
87lga9se2y.fsf@gnu.org
Hi Danny,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (26 lines)
> * gnu/packages/bootloaders.scm (make-u-boot-package)[arguments]<#:phases>
> [install]: Don't install "sunxi-spl-with-ecc.bin".
> ---
> gnu/packages/bootloaders.scm | 14 +++++++++++++-
> 1 file changed, 13 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
> index 7599f4ac2..19d47e6e5 100644
> --- a/gnu/packages/bootloaders.scm
> +++ b/gnu/packages/bootloaders.scm
> @@ -508,7 +508,19 @@ board-independent tools.")))
> (let* ((out (assoc-ref outputs "out"))
> (libexec (string-append out "/libexec"))
> (uboot-files (append
> - (find-files "." ".*\\.(bin|efi|img|spl|itb|dtb|rksd)$")
> + (filter
> + ;; Those would not be reproducible
> + ;; because of the randomness used
> + ;; to produce them.
> + ;; It's expected that the user will
> + ;; use u-boot-tools to generate them
> + ;; instead.
> + (lambda (name)
> + (not
> + (string-suffix?

Nitpick: you could write: (remove (lambda (string-suffix? …)) lst)
instead.

Otherwise LGTM, thanks!

Ludo’.
Danny Milosavljevic wrote 7 years ago
(no subject)
(address . control@debbugs.gnu.org)
20180726155502.490329a0@scratchpost.org
close 32140
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32140@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32140
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help