Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
* gnu/packages/bootloaders.scm (make-u-boot-package)[arguments]<#:phases>
[install]: Don't install "sunxi-spl-with-ecc.bin".
---
gnu/packages/bootloaders.scm | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)
Toggle diff (25 lines)
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 7599f4ac2..19d47e6e5 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -508,7 +508,19 @@ board-independent tools.")))
(let* ((out (assoc-ref outputs "out"))
(libexec (string-append out "/libexec"))
(uboot-files (append
- (find-files "." ".*\\.(bin|efi|img|spl|itb|dtb|rksd)$")
+ (filter
+ ;; Those would not be reproducible
+ ;; because of the randomness used
+ ;; to produce them.
+ ;; It's expected that the user will
+ ;; use u-boot-tools to generate them
+ ;; instead.
+ (lambda (name)
+ (not
+ (string-suffix?
+ "sunxi-spl-with-ecc.bin"
+ name)))
+ (find-files "." ".*\\.(bin|efi|img|spl|itb|dtb|rksd)$"))
(find-files "." "^(MLO|SPL)$"))))
(mkdir-p libexec)
(install-file ".config" libexec)