[PATCH] gnu: Add electron-cash.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 7 years ago
(address . guix-patches@gnu.org)
87d0vtjb7a.fsf@aikidev.net
* gnu/packages/finance.scm (electron-cash): New variable.
---
gnu/packages/finance.scm | 52 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 1d3e6a7a6..594c835d3 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -279,6 +279,58 @@ It's not clear at the moment whether one day it will be possible to
do so.")
(license license:agpl3+)))
+(define-public electron-cash
+ (package
+ (name "electron-cash")
+ (version "3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://electroncash.org/downloads/"
+ version
+ "/win-linux/ElectronCash-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1x487hyacdm1qhik1mhfimr4jwcwz7sgsbkh11awrb6j19sxdxym"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete the bundled dependencies.
+ (delete-file-recursively "packages")
+ #t))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-pyaes" ,python-pyaes)
+ ("python-pysocks" ,python-pysocks)
+ ("python-sip" ,python-sip)
+ ("python-pyqt" ,python-pyqt)
+ ("python-ecdsa" ,python-ecdsa)
+ ("python-pbkdf2" ,python-pbkdf2)
+ ("python-requests" ,python-requests)
+ ("python-qrcode" ,python-qrcode)
+ ("python-protobuf" ,python-protobuf)
+ ("python-dnspython" ,python-dnspython)
+ ("python-jsonrpclib-pelix" ,python-jsonrpclib-pelix)))
+ (arguments
+ `(#:tests? #f ;; package doesn't have any tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-home
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "setup.py"
+ (("~/.local/share")
+ (string-append (assoc-ref outputs "out") "/local/share"))))))))
+ (home-page "https://electroncash.org/")
+ (synopsis "Bitcoin Cash wallet")
+ (description
+ "Electroncash is a lightweight Bitcoin Cash client, based on a client-server
+protocol. It supports Simple Payment Verification (SPV) and deterministic key
+generation from a seed. Your secret keys are encrypted and are never sent to
+other machines/servers. Electroncash does not download the Bitcoin Cash blockchain.")
+ (license license:expat)))
+
(define-public electrum
(package
(name "electrum")
--
2.18.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcDardHbDotegGFCHt4uC1IFLkbYFAltG4YkACgkQt4uC1IFL
kbbz4A/8CzktGQCOV+uwwoPfY8kSuTYvcIo74xrqtrlnnrF4DDXtTVu+fJtx+zF5
eROT026VqOWZ0bJX6hPFqUnd9bJeosRQ8KzXTwHMeNHhMwPjJsuyFa4UT1JqXoS/
oHerGljfLps6NJ4weTVnR9LXVOXwVA+uRFMQB1iqOGRxkWfgN6mXBoxqksscR1sY
KASDFdSbJ5jv5QHOjxow6H9DoF+yb34XJTlD5sGjb9jvLn8seOK8JGcFVjAYTI7T
a5zmZ2DpYLIyLhP4AosrTlDMJF+Isr4b/GtTtmcv4YkWjUPPrZwjqkhd1OyEedgV
kpPrSrfTPrXBYVNmykelqlG8GXsloqXHgQyuRz6XiPpw6jgi1kwrqJr5qPJpIxrh
Wei4/tSNTTxAPo3Jdq7XIYr+9n3Zrf5SCcC3C4SlvCx0gnpJZtBdcCp8SUa+WQ0P
GwsxiE4bHmFCkTlLkkC/Awgr4Efyg0hdORqW0fAGck32Vkk1qLIcIczNyIN2mACz
GqtosU+8DZ0mEsBCck1CvocFYfptn1EhM3mT2gJszgWd2Ucj5MqcY2hKiFvfnxYh
Gu3eZafpLpYvpsfZnZ/Q8WFEEaeYpaNfWgnjFcwCgl1/Qr4ta32V+vWSnUcChuUf
vrJuYh4+hOo9sUIA8dzHR0tWpJF3GMasRKAtBATSwMjigTagNLU=
=813U
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 7 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 32130@debbugs.gnu.org)
87lgagqfh3.fsf@gnu.org
Hello,

Vagrant Cascadian <vagrant@debian.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/finance.scm (electron-cash): New variable.

[...]

Toggle quote (24 lines)
> + (build-system python-build-system)
> + (inputs
> + `(("python-pyaes" ,python-pyaes)
> + ("python-pysocks" ,python-pysocks)
> + ("python-sip" ,python-sip)
> + ("python-pyqt" ,python-pyqt)
> + ("python-ecdsa" ,python-ecdsa)
> + ("python-pbkdf2" ,python-pbkdf2)
> + ("python-requests" ,python-requests)
> + ("python-qrcode" ,python-qrcode)
> + ("python-protobuf" ,python-protobuf)
> + ("python-dnspython" ,python-dnspython)
> + ("python-jsonrpclib-pelix" ,python-jsonrpclib-pelix)))
> + (arguments
> + `(#:tests? #f ;; package doesn't have any tests
> + #:phases
> + (modify-phases %standard-phases
> + (add-before 'build 'patch-home
> + (lambda* (#:key outputs #:allow-other-keys)
> + (substitute* "setup.py"
> + (("~/.local/share")
> + (string-append (assoc-ref outputs "out") "/local/share"))))))))
> + (home-page "https://electroncash.org/")

This seems to be pretty much the same thing as ‘electrum’. Should we
define it as:

(package
(inherit electrum)
(name "electron-cash")
…)

?

Thanks,
Ludo’.
Vagrant Cascadian wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 32130@debbugs.gnu.org)
87tvp4hyc3.fsf@aikidev.net
On 2018-07-12, Ludovic Courtès wrote:
Toggle quote (38 lines)
> Vagrant Cascadian <vagrant@debian.org> skribis:
>
>> * gnu/packages/finance.scm (electron-cash): New variable.
>
> [...]
>
>> + (build-system python-build-system)
>> + (inputs
>> + `(("python-pyaes" ,python-pyaes)
>> + ("python-pysocks" ,python-pysocks)
>> + ("python-sip" ,python-sip)
>> + ("python-pyqt" ,python-pyqt)
>> + ("python-ecdsa" ,python-ecdsa)
>> + ("python-pbkdf2" ,python-pbkdf2)
>> + ("python-requests" ,python-requests)
>> + ("python-qrcode" ,python-qrcode)
>> + ("python-protobuf" ,python-protobuf)
>> + ("python-dnspython" ,python-dnspython)
>> + ("python-jsonrpclib-pelix" ,python-jsonrpclib-pelix)))
>> + (arguments
>> + `(#:tests? #f ;; package doesn't have any tests
>> + #:phases
>> + (modify-phases %standard-phases
>> + (add-before 'build 'patch-home
>> + (lambda* (#:key outputs #:allow-other-keys)
>> + (substitute* "setup.py"
>> + (("~/.local/share")
>> + (string-append (assoc-ref outputs "out") "/local/share"))))))))
>> + (home-page "https://electroncash.org/")
>
> This seems to be pretty much the same thing as ‘electrum’. Should we
> define it as:
>
> (package
> (inherit electrum)
> (name "electron-cash")
> …)

Yes, it is a fork of electrum. The release cycles are independent and
possibly the needed inputs may differ over time. But for now that will
probably work fine.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcDardHbDotegGFCHt4uC1IFLkbYFAltH2O0ACgkQt4uC1IFL
kbZHiw//W9cMXCmDHQLqrBCEHYKxaxRqJdCufLCVsv2ebdiogCPCqCl7JBw/Fj6a
YWORub2BM1dHsN/rXocrQuO49p/dwJ9Gwb8WrEx01t/MX+XgrhnaMWSZGwaP9EFY
c1GfeRoL/UwpM3OlEECNvSd9hSCb3kqdF1RNASiOHCWBX1xXiV4+IOZcts3CibWP
JMlJT10oYJUlrZAvEP2SKbjK9Ri+Flt/GAxxcne077smG8akgfvkUv1Ke0ALii3n
TZEJW8m1/C9I0gzJ08mqB3dG7+DLJwUIp3yL+zYA/Y7sc261OwoD/DrIOJcBKwPf
/fYiuGtS2dkfwWVZPi4LTYE9ODWWh3jHP0zMpBJIZlSzQOnzGTcJBuZ7fovE96uk
D+GFSu3q4SDZxgAtWR+19U2QOODCpN98O6f5xoQLZxU3KWhDJui2fYQC2+VaJQQ9
5X3LigIDrM8KG7YczQYwNeztewMadJ+X/+itN1PNUaqUX0vXWbZ6yEwN5kpBHRBb
jppVOVvWF0Smgg7sXpgGnoulpLdgHxPI7OM4qG1BB5GwWSoUGjw1BogDH1Hq5/Kv
QvoXAc7ka3K5nT+2/JFX1RxMmDtOj8IjgSm8l9EmASSqcTj27kEex0r5j8iqxpmP
1o23RZ3gkywCfzBvVPEkQ86LLc2MOp64F4cKR228aB1VbmHRio8=
=cXKH
-----END PGP SIGNATURE-----

Vagrant Cascadian wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
87tvp2hhjn.fsf@aikidev.net
On 2018-07-12, Ludovic Courtès wrote:
Toggle quote (3 lines)
> Vagrant Cascadian <vagrant@debian.org> skribis:
>
>> * gnu/packages/finance.scm (electron-cash): New variable.
...
Toggle quote (8 lines)
> This seems to be pretty much the same thing as ‘electrum’. Should we
> define it as:
>
> (package
> (inherit electrum)
> (name "electron-cash")
> …)

Updated patch attached inheriting from electrum.

live well,
vagrant
From 9e655d9cb2898b3ccdf2350b49ab75e6e542c297 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Fri, 13 Jul 2018 22:39:16 +0000
Subject: [PATCH] gnu: Add electron-cash.

* gnu/packages/finance.scm (electron-cash): New variable.
---
gnu/packages/finance.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 1d3e6a7a6..29bf3040e 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -329,6 +329,37 @@ generation from a seed. Your secret keys are encrypted and are never sent to
other machines/servers. Electrum does not download the Bitcoin blockchain.")
(license license:expat)))
+(define-public electron-cash
+ (package
+ (inherit electrum)
+ (name "electron-cash")
+ (version "3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://electroncash.org/downloads/"
+ version
+ "/win-linux/ElectronCash-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1x487hyacdm1qhik1mhfimr4jwcwz7sgsbkh11awrb6j19sxdxym"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete the bundled dependencies.
+ (delete-file-recursively "packages")
+ #t))))
+ (home-page "https://electroncash.org/")
+ (synopsis "Bitcoin Cash wallet")
+ (description
+ "Electroncash is a lightweight Bitcoin Cash client, based on a client-server
+protocol. It supports Simple Payment Verification (SPV) and deterministic key
+generation from a seed. Your secret keys are encrypted and are never sent to
+other machines/servers. Electroncash does not download the Bitcoin Cash blockchain.")
+ (license license:expat)))
+
(define-public monero
;; This package bundles easylogging++ and lmdb.
;; The bundled easylogging++ is modified, and the changes will not be upstreamed.
--
2.18.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcDardHbDotegGFCHt4uC1IFLkbYFAltJLfgACgkQt4uC1IFL
kbb/0g/+LRImsivBpTb5rf9s/rBgus2wBOWg1G8mrSTGOOYCXJgFYcKSQ2MwEl6j
quSLdn+Adkpkqe6EyL0Nz8dSh7av8XEnc+WyzbttRvx9xkfg8mCwPa+i8Umca60C
wFlV4wfFbyYhTDd1V9R5vkPBKlsy3iOpTzEmItYeUl85mBjfB9UTwWqYwfx0OHfA
XvVOPbvmd1dr9+JU7oNjMQHAPoD7VQ1qBUVHC6sNG9QsKc1Sh2Sdoh9P3Psd2mS6
1EIrgHEllPRtWGvbZ8+nW7buoTC1f7JIJkcKGgP0wfq99XsK/3EVaBUa9GjqY1j6
W0GZbWozoECr+h+0DlWOShCP8lPGelWALqrRohdxNKs8nDdjs+UFPMxcOMvrB/tM
+ST8JvMiGVj4GQw9R1ErYIt3c1IiVtB4qkyjErIyR90iMSpSHiMtfVcbMjB+2CCk
O6PoZmbYqvvh7LNGR7cvYzgpQOEqPkVlDyeE/rVG9tY1LQtT28KlkojL79N1fov5
cqMW4R4tcIimz4RtXWP3Xb01MyVw11h7nwQc6sTv5mVSyBWGtrSGtuetHBoL/jIO
pY5qUz574V1CxQpriJc9ir7XgyWpS3M0WdxfUgdgMFp9tWyD3znLtagsIlrMksbr
B6w2UZyfSbhuHb6vSiAFmSUh7Otk7ZnIa6V2j6V+wChCM12iK5M=
=N06F
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 7 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 32130-done@debbugs.gnu.org)
87in5fuwti.fsf@gnu.org
Vagrant Cascadian <vagrant@debian.org> skribis:

Toggle quote (7 lines)
> From 9e655d9cb2898b3ccdf2350b49ab75e6e542c297 Mon Sep 17 00:00:00 2001
> From: Vagrant Cascadian <vagrant@debian.org>
> Date: Fri, 13 Jul 2018 22:39:16 +0000
> Subject: [PATCH] gnu: Add electron-cash.
>
> * gnu/packages/finance.scm (electron-cash): New variable.

Applied, thanks!

Ludo'.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 32130@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 32130
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help