David Larsson wrote 7 years ago
gcc -m32 can't find stubs-32.h
(address . bug-guix@gnu.org)
I tried to run gcc to compile a simple c program which fails:
gcc -m32 -o m32test m32test.c
In file included from /home/user1/.guix-profile/include/features.h:388,
from /home/user1/.guix-profile/include/stdio.h:27,
from m32test.c:2:
/home/user1/.guix-profile/include/gnu/stubs.h:7:11: fatal error:
gnu/stubs-32.h: No such file or directory
# include <gnu/stubs-32.h>
^~~~~~~~~~~~~~~~
compilation terminated.
with -m64 it compiles correctly. In ~/.guix-profile/include/gnu/ I have
the files:
libc-version.h
lib-names-64.h
lib-names.h
stubs-64.h
stubs.h
Expected result is that it silently works.
--
Best Regards
David L