There's actually an error message[0]. Did it not show up in your
logs? I'd consider that a bug too.
If I had to guess I'd say that a GCC bump's to blame. Or maybe
Boost, though that seems unlikely.
Unfortunately, I also don't have the time to debug this now or
indeed the next month.
Kind regards,
T G-R
[0]:
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:
In function ‘void handle_gis_exception(const char*)’:
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:37:81:
error: expected unqualified-id before ‘&’ token
catch (const
boost::geometry::detail::self_get_turn_points::self_ip_exception
&)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:37:81:
error: expected ‘)’ before ‘&’ token
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:37:81:
error: expected ‘{’ before ‘&’ token
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:37:82:
error: expected primary-expression before ‘)’ token
catch (const
boost::geometry::detail::self_get_turn_points::self_ip_exception
&)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:42:3:
error: expected primary-expression before ‘catch’
catch (const boost::geometry::empty_input_exception &)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:46:3:
error: expected primary-expression before ‘catch’
catch (const boost::geometry::inconsistent_turns_exception &)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:50:3:
error: expected primary-expression before ‘catch’
catch (const boost::geometry::exception &)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:54:3:
error: expected primary-expression before ‘catch’
catch (const std::bad_alloc &e)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:58:3:
error: expected primary-expression before ‘catch’
catch (const std::domain_error &e)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:62:3:
error: expected primary-expression before ‘catch’
catch (const std::length_error &e)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:66:3:
error: expected primary-expression before ‘catch’
catch (const std::invalid_argument &e)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:70:3:
error: expected primary-expression before ‘catch’
catch (const std::out_of_range &e)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:74:3:
error: expected primary-expression before ‘catch’
catch (const std::overflow_error &e)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:78:3:
error: expected primary-expression before ‘catch’
catch (const std::range_error &e)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:82:3:
error: expected primary-expression before ‘catch’
catch (const std::underflow_error &e)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:86:3:
error: expected primary-expression before ‘catch’
catch (const std::logic_error &e)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:90:3:
error: expected primary-expression before ‘catch’
catch (const std::runtime_error &e)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:94:3:
error: expected primary-expression before ‘catch’
catch (const std::exception &e)
^
/tmp/guix-build-mysql-5.7.21.drv-0/mysql-5.7.21/sql/item_geofunc_internal.cc:98:3:
error: expected primary-expression before ‘catch’
catch (...)
^
make[2]: *** [sql/CMakeFiles/sql.dir/build.make:583:
sql/CMakeFiles/sql.dir/item_geofunc_internal.cc.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory
'/tmp/guix-build-mysql-5.7.21.drv-0/build'