[PATCH] gnu: Add python-pyblake2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 7 years ago
(address . guix-patches@gnu.org)
87o9g0ne4s.fsf@aikidev.net
Add new package definition for python-pyblake2, needed to upgrade
python-trezor to recent versions.

live well,
vagrant
From 4d44cd29429d876b69f532b38be563cb911b8125 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Sun, 24 Jun 2018 19:31:19 +0000
Subject: [PATCH] gnu: Add python-pyblake2.

* gnu/packages/libusb.scm (python-pyblake2): New variable.
---
gnu/packages/python.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 08894239c..bc4b7abcd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13369,6 +13369,25 @@ working with iterables.")
(description "Lexer and codec to work with LaTeX code in Python.")
(license license:expat)))
+(define-public python-pyblake2
+ (package
+ (name "python-pyblake2")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyblake2" version))
+ (sha256
+ (base32
+ "0gz9hgznv5zw4qjq43xa56y0yikimx30gffvibxzm0nv5sq7xk2w"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/dchest/pyblake2")
+ (synopsis
+ "BLAKE2 hash function extension module")
+ (description
+ "BLAKE2 hash function extension module")
+ (license license:cc0)))
+
(define-public python-pybtex
(package
(name "python-pybtex")
--
2.11.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcDardHbDotegGFCHt4uC1IFLkbYFAlsv+bQACgkQt4uC1IFL
kbZ8QxAAg7TN/Q1E5v99vCx9YOu6naxz/lGjl8JxQZBp62H315MkN+xMa4GA4KR/
2UFUIsICur97CQgdxz9HhDbze2N3wR88luFvvAv6ctBJujYWsied2wajKjSiAg+Y
xPHp7x50tEU6TKHNBpVDG3smNNDs7NcvlbLF8VHpo5mloRt7/Ymi35Chk+8jThJ+
RFrn8PH6hV1N4VlkseG3gwcLY+ib/50VVO+rRLuCOkgFhEFACbUs0cQ6tM3ZxGYS
vFG48kxkNyB6cRtDDc7VABBg1dbuvSl8yh1QMqu/sGcQ7oWdKlZNlAH/skDuURI7
bzqiSCJvCRibNQTWmGe/gKen6zXhgmHpOsILuCL+3+oqVwOzQn/jNcskpgZIsJz7
oUDiGA1ngkH8Z66RMlYAx9T2cRM0tw1gIzUqZxmeze/Dsc9/oYj6qq0JlJIesbfV
TJZYDCoY6+azCMepm+NHxYBF5meA9g65sCn/P275FJPHfxCx5E6hkfzfZe/dzYD8
8TKdU8U6ivCk2WSSF+mPZdmDkuZv2M9/jKPyLtHMPoczXO4kTfEqvK+E/SxX9ZsC
O2sc41NuEuqejAbY2MXihVgLCIZdrO5aCLf1AHaZF8ezI+rtsi8P+M71txbyk+l3
HhU7m2S+g7UGr4ozzGk5xPEqtspSmvACque/tkTDSpBg88GNY08=
=R4BV
-----END PGP SIGNATURE-----

Marius Bakke wrote 7 years ago
874lhqej9d.fsf@fastmail.com
Vagrant Cascadian <vagrant@debian.org> writes:

Toggle quote (3 lines)
> Add new package definition for python-pyblake2, needed to upgrade
> python-trezor to recent versions.

Thanks! Some comments:

[...]

Toggle quote (5 lines)
> * gnu/packages/libusb.scm (python-pyblake2): New variable.
> ---
> gnu/packages/python.scm | 19 +++++++++++++++++++
> 1 file changed, 19 insertions(+)

There is a mismatch between the commit message and the code here :-)
Though I think this is better suited in 'python-crypto.scm'. WDYT?

[...]

Toggle quote (4 lines)
> + (synopsis
> + "BLAKE2 hash function extension module")

Superfluous line break.

Toggle quote (3 lines)
> + (description
> + "BLAKE2 hash function extension module")

Can you try to expand on this a little?

Toggle quote (2 lines)
> + (license license:cc0)))

According to COPYING, this software is actually "octuple-licensed":

* Unlicense — http://unlicense.org/
* WTFPL Version 2 - http://www.wtfpl.net/
* Apache Public License 2.0 - https://www.apache.org/licenses/LICENSE-2.0

Can you add each of these, along with an explaning comment?

Thanks in advance!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlsxR/4ACgkQoqBt8qM6
VPoUrwf/W8B1v+32QgOLf9BTkqNFjB4Qn+e6VgiJTSx/YaFskybziFnpLtd8BoWc
fh10ua+uzN1n9/S5xYxgpx16jDjfe8wDRTWaQxC4WEXyDxLYO7B0J65AjE6PmhXI
eOMtI8ATeSfLO4pahEe5YhAHbaFRKXmf6EPQSOi+rNb2b9Ou/YmcNmtDh0L9e+DZ
fOsp3aIEJRAw6CXyH/6iA6zlDzr8Ebp0dfeo/i29D3Xciz0ZmeBnpa6YAppy/30o
AbudeUnp8JAYs3eHjoRCIvjF8JG8aeeKBYeR4oEts21Jj2zshBfmQMOsMIfycW+I
X9UQ3BRzvV8BH421SUpugwtNeH3d3Q==
=j4Pt
-----END PGP SIGNATURE-----

Vagrant Cascadian wrote 7 years ago
878t72o9r4.fsf@aikidev.net
On 2018-06-25, Marius Bakke wrote:
Toggle quote (16 lines)
> Vagrant Cascadian <vagrant@debian.org> writes:
>
>> Add new package definition for python-pyblake2, needed to upgrade
>> python-trezor to recent versions.
>
> Thanks! Some comments:
>
> [...]
>
>> * gnu/packages/libusb.scm (python-pyblake2): New variable.
>> ---
>> gnu/packages/python.scm | 19 +++++++++++++++++++
>> 1 file changed, 19 insertions(+)
>
> There is a mismatch between the commit message and the code here :-)

Oops! obvious cut-and-paste error here...


Toggle quote (2 lines)
> Though I think this is better suited in 'python-crypto.scm'. WDYT?

I'll happily defer to someone who knows their way around guix more. :)


Toggle quote (6 lines)
>> + (synopsis
>> + "BLAKE2 hash function extension module")
>
> Superfluous line break.

Will fix.


Toggle quote (5 lines)
>> + (description
>> + "BLAKE2 hash function extension module")
>
> Can you try to expand on this a little?

I can try, sure.


Toggle quote (15 lines)
>> + (license license:cc0)))
>
> According to COPYING, this software is actually "octuple-licensed":
>
> * CC0 Universal 1.0 - http://creativecommons.org/publicdomain/zero/1.0
> * Unlicense — http://unlicense.org/
> * WTFPL Version 2 - http://www.wtfpl.net/
> * Apache Public License 2.0 - https://www.apache.org/licenses/LICENSE-2.0
> * OpenSSL License - https://www.openssl.org/source/license.html
> * MIT License - https://opensource.org/licenses/MIT
> * The BSD 3-Clause License - https://opensource.org/licenses/BSD-3-Clause
> * ISC License - https://opensource.org/licenses/ISC
>
> Can you add each of these, along with an explaning comment?

And all of those are merely fallback licenses to the author's intention
of public domain... and in the files themselves (pyblake2module.c,
setup.py), they only reference:


But if it's more appropriate for guix to list all possible licenses,
sure. :)


live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcDardHbDotegGFCHt4uC1IFLkbYFAlsxWZ8ACgkQt4uC1IFL
kbarqA//ZJysmLR4nj5BR5LIyindMX38hkVauaKENj6E5BKYlGB7ZYhu+Q8uIjVI
cFTqQgVb8leryN219ZkOFRdiwUbOzKEOReZnMpT7cDtaSMkB0HZTqPjh8sAxYfnQ
JJ0JvOJxSNm3SfBeS6XrQPA8MrbWrrH+NJsNLRmcD2AK2Hp/vq91jnpAkgZToAgA
Eh++53bxo6CkQ2q0ZErMS2xQhyRAsBCdVGuGo6C0sdZ7ToW4yydLXAn5uWFotMLX
hq2+yO1vhedn+dF0Si+LP/+JneDZFKBO6TUPZcsdQgj1mgqFjrda0zPniNfFS6Z/
MvK+qWEK2jA0py37tCLjgRir3dDUnL9FhJKq7Aj3tLL8w3ogIKcT/RuRxNMldUSl
PzjnI/R5Pg98Dp49oa6jBqA/ZLwNGaHnaZQI+32l4v4WQOmoMU4PM7eCFFYzx/4j
0tyjgRn8fK7tWY+LCT8ThWSKVvBHIB4q++QsWUgNWh8K9JYWM0XjxUbLPzKoJiOa
fryrIPBeYRCeVk75rwxqK+9HXqyb+v+KE/hbqt87pNTSlO3RVE35WpOOUuBiSRiS
lh4ruvL+Ba1PaICk7M+NvB0MyLbR4hNW6gMRAMHNkrdDm5SG7/WKXcnMOqB5Z0Vt
HpvLeuCTDb2CfsRkaNC62lRUeT02mAXnUyrcpIOIgocz95NSmSA=
=+ca3
-----END PGP SIGNATURE-----

Marius Bakke wrote 7 years ago
87h8lqzhq0.fsf@fastmail.com
Vagrant Cascadian <vagrant@debian.org> writes:

Toggle quote (24 lines)
>>> + (license license:cc0)))
>>
>> According to COPYING, this software is actually "octuple-licensed":
>>
>> * CC0 Universal 1.0 - http://creativecommons.org/publicdomain/zero/1.0
>> * Unlicense — http://unlicense.org/
>> * WTFPL Version 2 - http://www.wtfpl.net/
>> * Apache Public License 2.0 - https://www.apache.org/licenses/LICENSE-2.0
>> * OpenSSL License - https://www.openssl.org/source/license.html
>> * MIT License - https://opensource.org/licenses/MIT
>> * The BSD 3-Clause License - https://opensource.org/licenses/BSD-3-Clause
>> * ISC License - https://opensource.org/licenses/ISC
>>
>> Can you add each of these, along with an explaning comment?
>
> And all of those are merely fallback licenses to the author's intention
> of public domain... and in the files themselves (pyblake2module.c,
> setup.py), they only reference:
>
> http://creativecommons.org/publicdomain/zero/1.0
>
> But if it's more appropriate for guix to list all possible licenses,
> sure. :)

Right. I missed the top comment of the COPYING file[0], which dedicates
the software to the public domain. But it also says that you are free
to choose any of the others at your discretion.

So I think CC0 is appropriate, but please add a comment explaning the
situation. Thanks!

-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlsxXIcACgkQoqBt8qM6
VPr5kQgAmFYgehcKWp1WW+dIkv7cFaNr3wIJrPFFSXm8tNVZ2SghYIpKF8Z+SU4b
/Jen9X7XP8w89jXV3tDLQeWLkrHMBRBcGsYy7HkXxxiwQZ6tV2XQdO6FyzLny0T5
PL8wHY5BSX0WEvl0rOPxIr6wRWbQRRz2PIvSRTrYU80O/mB1eqVQs/DcIecsVOGv
5JKGNKDlxw0NkHytxRVSLJWI26MPgIIlSab/lIJGODHfrQ7CLEpuCTfIDkq93w+C
4z2h13f7Nngoq8IOt/dyZ0FWfMu6OihACqz9Z3zzGs7+CkyfKgLuHYk0uzCPsQib
64gJ33wX1hmvUFb2ZW0h+kuibLseog==
=dOIt
-----END PGP SIGNATURE-----

Vagrant Cascadian wrote 7 years ago
876026nowz.fsf@aikidev.net
On 2018-06-25, Marius Bakke wrote:
Toggle quote (32 lines)
> Vagrant Cascadian <vagrant@debian.org> writes:
>>> According to COPYING, this software is actually "octuple-licensed":
>>>
>>> * CC0 Universal 1.0 - http://creativecommons.org/publicdomain/zero/1.0
>>> * Unlicense — http://unlicense.org/
>>> * WTFPL Version 2 - http://www.wtfpl.net/
>>> * Apache Public License 2.0 - https://www.apache.org/licenses/LICENSE-2.0
>>> * OpenSSL License - https://www.openssl.org/source/license.html
>>> * MIT License - https://opensource.org/licenses/MIT
>>> * The BSD 3-Clause License - https://opensource.org/licenses/BSD-3-Clause
>>> * ISC License - https://opensource.org/licenses/ISC
>>>
>>> Can you add each of these, along with an explaning comment?
>>
>> And all of those are merely fallback licenses to the author's intention
>> of public domain... and in the files themselves (pyblake2module.c,
>> setup.py), they only reference:
>>
>> http://creativecommons.org/publicdomain/zero/1.0
>>
>> But if it's more appropriate for guix to list all possible licenses,
>> sure. :)
>
> Right. I missed the top comment of the COPYING file[0], which dedicates
> the software to the public domain. But it also says that you are free
> to choose any of the others at your discretion.
>
> So I think CC0 is appropriate, but please add a comment explaning the
> situation. Thanks!
>
> [0] https://github.com/dchest/pyblake2/blob/master/COPYING

Updated patch:
- fixed commit message
- moved to python-crypto.scm
- removed needless linebreak
- updated description
- updated licensing to public-domain/cc0
- clarified additional licensing in comments

Hopefully that covers everything.


live well,
vagrant
From d6101ee18f130fb13aa75a0978cfc0da33e6b915 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Mon, 25 Jun 2018 21:32:06 -0700
Subject: [PATCH] gnu: Add python-pyblake2.

* gnu/packages/python-crypto.scm (python-pyblake2): New variable.
---
gnu/packages/python-crypto.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index e29eaea80..214671fd3 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -170,6 +170,34 @@ John the Ripper).")
;; the rest is under ISC.
(license (list license:isc license:bsd-3 license:bsd-4))))
+(define-public python-pyblake2
+ (package
+ (name "python-pyblake2")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyblake2" version))
+ (sha256
+ (base32
+ "0gz9hgznv5zw4qjq43xa56y0yikimx30gffvibxzm0nv5sq7xk2w"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/dchest/pyblake2")
+ (synopsis "BLAKE2 hash function extension module")
+ (description "Python BLAKE2 hash function extension module. BLAKE2 is
+a cryptographic hash function, which offers stronger security while being as
+fast as MD5 or SHA-1, and comes in two flavors: BLAKE2b, optimized for 64-bit
+platforms and produces digests of any size between 1 and 64 bytes, and
+BLAKE2s, optimized for 8- to 32-bit platforms and produces digests of any size
+between 1 and 32 bytes. BLAKE2 supports keyed mode (a faster and simpler
+replacement for HMAC), salted hashing, personalization, and tree hashing.
+Hash objects from this module follow the API of standard library's hashlib
+objects.")
+ ;; The COPYING file declares it as public domain, with the option to
+ ;; alternately use it under a variety of permissive licenses. cc0 is
+ ;; explicitly mentioned in setup.py and pyblake2module.c
+ (license (list license:public-domain license:cc0))))
+
(define-public python2-py-bcrypt
(package-with-python2 python-py-bcrypt))
--
2.11.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcDardHbDotegGFCHt4uC1IFLkbYFAlsxwxwACgkQt4uC1IFL
kbYaPQ//f7w5vK0xCiudjdDXRNsunKazsoT1Qp/uT2OdKoTATSKH7RtqjgVlfkdm
Wxe3wazhT770/YSYKXmIzGmERxGKinr9OP5xLJFke3LZ3dosdc+LLMqkcVAn1IT8
PmS2jI5w8zmmgRbU+17lk8GSLAp9EXaQQ9Nb1kcbHTkifSYgMAN17rq5+ntFr57m
8EMjvyGgXfMVpSV7N7cnehNvfEWValOGSqpEGtlW80pjdF5waBPVRpuACf9LYpWR
w/XCnK10llaJHhf5lVhXVXB7ERQqnjh/BMQ7LUvaB4XOiz2eXkPQCzAM/LT67I7h
Uw8XkWsPoD6c4otTWsHF1sx2wiiLtYECGs6gXOBZCA5S169gZoTQA0NCPRCqhPh9
XozflfHSvVG+PlZ2QLKtC0aqMyMbXmXiJSeX1a6nPMfFoERmGZYix83WEN/ajnR9
GXBPFk0cyJa2ycPdyzdwvfasI//ySDzY1/PCQeHciqZJCCzynVEWiWPNZNvtdAmH
viFL1PQUa5m5uAM4e3BfO1wOE5qIxlNVORP91vO2ltd1ZQ32NbBLRmFOjQ8MwBPq
1adS+NHOjP6foPgOLzyzcRfjfFRAmSEhQ1y6nilg4HxJRttI3aW4ZTqFpikru0dB
dCPdR3voyTVYsuOcX3uoSJJDB+1lstjfKN6+M1JB6WOIGWq4G9M=
=cl2S
-----END PGP SIGNATURE-----

Marius Bakke wrote 7 years ago
(address . 31957-done@debbugs.gnu.org)
878t71xlhu.fsf@fastmail.com
Vagrant Cascadian <vagrant@debian.org> writes:

Toggle quote (43 lines)
> On 2018-06-25, Marius Bakke wrote:
>> Vagrant Cascadian <vagrant@debian.org> writes:
>>>> According to COPYING, this software is actually "octuple-licensed":
>>>>
>>>> * CC0 Universal 1.0 - http://creativecommons.org/publicdomain/zero/1.0
>>>> * Unlicense — http://unlicense.org/
>>>> * WTFPL Version 2 - http://www.wtfpl.net/
>>>> * Apache Public License 2.0 - https://www.apache.org/licenses/LICENSE-2.0
>>>> * OpenSSL License - https://www.openssl.org/source/license.html
>>>> * MIT License - https://opensource.org/licenses/MIT
>>>> * The BSD 3-Clause License - https://opensource.org/licenses/BSD-3-Clause
>>>> * ISC License - https://opensource.org/licenses/ISC
>>>>
>>>> Can you add each of these, along with an explaning comment?
>>>
>>> And all of those are merely fallback licenses to the author's intention
>>> of public domain... and in the files themselves (pyblake2module.c,
>>> setup.py), they only reference:
>>>
>>> http://creativecommons.org/publicdomain/zero/1.0
>>>
>>> But if it's more appropriate for guix to list all possible licenses,
>>> sure. :)
>>
>> Right. I missed the top comment of the COPYING file[0], which dedicates
>> the software to the public domain. But it also says that you are free
>> to choose any of the others at your discretion.
>>
>> So I think CC0 is appropriate, but please add a comment explaning the
>> situation. Thanks!
>>
>> [0] https://github.com/dchest/pyblake2/blob/master/COPYING
>
> Updated patch:
> - fixed commit message
> - moved to python-crypto.scm
> - removed needless linebreak
> - updated description
> - updated licensing to public-domain/cc0
> - clarified additional licensing in comments
>
> Hopefully that covers everything.

Thank you!

I shortened the description a bit while adding @code{} notations where
appropriate, and also added a copyright statement for you. Hope that
was okay :-)

I also moved the package so it wasn't squeezed between the Python3 and
Python2 variants of python-py-bcrypt.

(...and closing the previous patch bug while at it...)

Pushed as e64088f0b521145286bfe3f028699e418baf4832!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlsyte0ACgkQoqBt8qM6
VPpVEgf/Tc8Y3b/0IaUsOQXr1UHT1AkLf4FrUrMi6eM4XFfSBtK7iHnfYNx2W2+3
Mes+AXqcwLbEygXlUmfniJooB+UKBqC9UiuSkTyQLf0iJ2ve03/rG95awV5On7cv
m9Ty3MdU6OejrrwvZe9vATXmErZaWA/18FMLDyBPNR+lFY8LyabI9nH0sAqXO/zz
DMgJYnPYHqaSsisT7SxD7q+GOevnhv+lNjmQYB+5wV583tvp/5A2WTwGLJYAK6TJ
GDdI8wL+Ko4IeV4czWRw8wqwi0jA+gNdfs9aTHQespqKQpssBGEWXis679qcuJdr
pOHpFX+J0pyatu3QNROVUNLLV0KgVA==
=p405
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 31958@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 31958
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help