[PATCH] gnu: Add python-libusb1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 7 years ago
(address . guix-patches@gnu.org)
87r2kwne89.fsf@aikidev.net
Add new package definition for python-libusb1, needed to upgrade
python-trezor to newer versions.

live well,
vagrant
From 282280cbaba47389f7a9c3e14eb8fe7834adbd39 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Sun, 24 Jun 2018 19:20:47 +0000
Subject: [PATCH] gnu: Add python-libusb1.

* gnu/packages/libusb.scm (python-libusb1): New variable.
---
gnu/packages/libusb.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index 62c936c19..9fa2d816a 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -214,6 +214,44 @@ with usb4java.")
implementing @code{javax.usb} (JSR-80).")
(license expat)))
+(define-public python-libusb1
+ (package
+ (name "python-libusb1")
+ (version "1.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "libusb1" version))
+ (sha256
+ (base32
+ "03b7xrz8vqg8w0za5r503jhcmbd1ls5610jcja1rqz833nf0v4wc"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:modules ((srfi srfi-1)
+ (srfi srfi-26)
+ (guix build utils)
+ (guix build python-build-system))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-libusb-reference
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "usb1/libusb1.py"
+ (("libusb_path = ctypes.util.find_library\\(base_name\\)")
+ (string-append
+ "libusb_path = \""
+ (find (negate symbolic-link?)
+ (find-files (assoc-ref inputs "libusb")
+ "^libusb.*\\.so\\..*"))
+ "\"")))
+ #t)))))
+ (inputs `(("libusb" ,libusb)))
+ (home-page
+ "http://github.com/vpelletier/python-libusb1")
+ (synopsis "Pure-python wrapper for libusb-1.0")
+ (description
+ "Pure-python wrapper for libusb-1.0")
+ (license lgpl2.1+)))
+
(define-public python-pyusb
(package
(name "python-pyusb")
--
2.11.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcDardHbDotegGFCHt4uC1IFLkbYFAlsv+TYACgkQt4uC1IFL
kbafaw//U9R0zZ1ermnDIVcoTSNREU7UOCDNFKnVqxbTOErmgaj64wZ4PuANORWo
+LGuH8QRQ/r5tysFiJeLEKoIRZ0TFnewEaTg/XOOb0nZ9IUI976/cjebT5BCs7da
UWYIE91hadu22f3GJiDiTQ3Inh2NTTEZj7zSUwfd+qDL2QWnAhKfeZL+9v77t+8m
yLHWwkG1i8xVnFQ4PwiQKaRnUs/Na43lJ8FCzlZledi0pZ3a7QYpp4aCd8msvvtM
rB5ioB7ljekA9mZmafcDby+Rs5WLYho6kseATxkcrZLwQ30/PY4730qWTm307Ia8
GbdckGNH7cDsQne6XAQQLJVSIFiaPK6BjJsvjZ1sWuhzkaxb3Ik6Glm1iiE8nokY
PmSoca/lXUeMvzAb3KiHVkzdOu2TC2d6Gh9Mf0TWnHeyIRhA5Xys7Qn36azmyq7D
cyRJK1f1lOX1WX9VrslGbIi8IWAE473/p89iDZ8fA2Pv7pFL9tsC9UIF2cHdN05j
EGuK52/EieClEadQ7D8ldTtqqpmi7ZixjxEKwl2EsbbWw0tM0eWv2rSJvPOpHD/4
ycQlt8EgWW2lSKCBUmXCITSW/gmi3ePMxsXbg80tjsle9lRVR6Tt9eTh9FDgK7UT
MOgsQtUUe9r3cGxSB2eHiKucK342FrxRVw/iE+7K1jfIHhlIYJ0=
=jYlL
-----END PGP SIGNATURE-----

Marius Bakke wrote 7 years ago
877emmejjg.fsf@fastmail.com
Vagrant Cascadian <vagrant@debian.org> writes:

Toggle quote (3 lines)
> Add new package definition for python-libusb1, needed to upgrade
> python-trezor to newer versions.

Thanks! I have some minor nitpicks:

[...]

Toggle quote (2 lines)
> * gnu/packages/libusb.scm (python-libusb1): New variable.

Can you also add yourself to the copyright header in this file?

[...]
Toggle quote (16 lines)
> +(define-public python-libusb1
> + (package
> + (name "python-libusb1")
> + (version "1.6.4")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "libusb1" version))
> + (sha256
> + (base32
> + "03b7xrz8vqg8w0za5r503jhcmbd1ls5610jcja1rqz833nf0v4wc"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:modules ((srfi srfi-1)
> + (srfi srfi-26)

Is srfi-26 actually used here?

Toggle quote (19 lines)
> + (guix build utils)
> + (guix build python-build-system))
> + #:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'fix-libusb-reference
> + (lambda* (#:key inputs #:allow-other-keys)
> + (substitute* "usb1/libusb1.py"
> + (("libusb_path = ctypes.util.find_library\\(base_name\\)")
> + (string-append
> + "libusb_path = \""
> + (find (negate symbolic-link?)
> + (find-files (assoc-ref inputs "libusb")
> + "^libusb.*\\.so\\..*"))
> + "\"")))
> + #t)))))
> + (inputs `(("libusb" ,libusb)))
> + (home-page
> + "http://github.com/vpelletier/python-libusb1")

This line break is unnecessary :-)

Toggle quote (4 lines)
> + (synopsis "Pure-python wrapper for libusb-1.0")
> + (description
> + "Pure-python wrapper for libusb-1.0")

This description is rather thin. Can you try to make it into one or
more full sentences?

Toggle quote (2 lines)
> + (license lgpl2.1+)))

I noticed the source contains GPL2 in COPYING, and LGPL2.1 as
"COPYING.LESSER". Can you make sure we don't install the former?

Can you send an updated patch? Thanks in advance!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlsxRpMACgkQoqBt8qM6
VPq26Af/d8rDUNL9Qti+/nr3NhdOe+07zOjyZXftfl/86wv+Jz7//A1nH0NXGRyG
DycWyhpJaIO6DoTHnuFrIbYvMU+5OGcz9scTg3Pk2WWgoGpYmiNT12dqVbNrd3Ks
KVoNbySmKv2xn3YHascEdYldlKbRxfUCWPebxiJVHo0wLuz73V7HK0bzxEjJaI/w
y4LyGPctv6w9B1p/f3Pj9EJtS4eEELTJwfD5oNFXA/4hZGpjtrFEjB2+F8ZDfpD4
lazy8ShUJgNbhAVxzQfxUJZHaExI9FMcd+LmcsdkilKhjTg5khrFsyVX77lsg/yB
oQPstSEHSfEUZJelDlwG+6BNSLmdhg==
=H7mK
-----END PGP SIGNATURE-----

Vagrant Cascadian wrote 7 years ago
87bmbyoadk.fsf@aikidev.net
On 2018-06-25, Marius Bakke wrote:
Toggle quote (13 lines)
> Vagrant Cascadian <vagrant@debian.org> writes:
>
>> Add new package definition for python-libusb1, needed to upgrade
>> python-trezor to newer versions.
>
> Thanks! I have some minor nitpicks:
>
> [...]
>
>> * gnu/packages/libusb.scm (python-libusb1): New variable.
>
> Can you also add yourself to the copyright header in this file?

Sure.


Toggle quote (18 lines)
>> +(define-public python-libusb1
>> + (package
>> + (name "python-libusb1")
>> + (version "1.6.4")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (pypi-uri "libusb1" version))
>> + (sha256
>> + (base32
>> + "03b7xrz8vqg8w0za5r503jhcmbd1ls5610jcja1rqz833nf0v4wc"))))
>> + (build-system python-build-system)
>> + (arguments
>> + `(#:modules ((srfi srfi-1)
>> + (srfi srfi-26)
>
> Is srfi-26 actually used here?

No idea, I admittedly cargo-culted this from python-pyusb...
fix-libusb-reference didn't work until I added the modules block, and I
didn't narrow-down which of the specific modules were actually needed.


Toggle quote (21 lines)
>> + (guix build utils)
>> + (guix build python-build-system))
>> + #:phases
>> + (modify-phases %standard-phases
>> + (add-after 'unpack 'fix-libusb-reference
>> + (lambda* (#:key inputs #:allow-other-keys)
>> + (substitute* "usb1/libusb1.py"
>> + (("libusb_path = ctypes.util.find_library\\(base_name\\)")
>> + (string-append
>> + "libusb_path = \""
>> + (find (negate symbolic-link?)
>> + (find-files (assoc-ref inputs "libusb")
>> + "^libusb.*\\.so\\..*"))
>> + "\"")))
>> + #t)))))
>> + (inputs `(("libusb" ,libusb)))
>> + (home-page
>> + "http://github.com/vpelletier/python-libusb1")
>
> This line break is unnecessary :-)

Ok.


Toggle quote (7 lines)
>> + (synopsis "Pure-python wrapper for libusb-1.0")
>> + (description
>> + "Pure-python wrapper for libusb-1.0")
>
> This description is rather thin. Can you try to make it into one or
> more full sentences?

Will try.


Toggle quote (5 lines)
>> + (license lgpl2.1+)))
>
> I noticed the source contains GPL2 in COPYING, and LGPL2.1 as
> "COPYING.LESSER". Can you make sure we don't install the former?

I was a bit confused by that, but looking at all the actual code, it
only appears to be LGPL2.1. So you're saying to explicitly remove
COPYING from the package?


Toggle quote (2 lines)
> Can you send an updated patch? Thanks in advance!

Sure. Thanks for the review!


live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcDardHbDotegGFCHt4uC1IFLkbYFAlsxVngACgkQt4uC1IFL
kbbt5Q/9G4wdQu9xesyDBZ9KvLT016t8TINt92Nh7i0YLQRAupF0pC09WEC/nOKC
g5ykUr6Ek1S2btwcIGoVd4H4HjB7BeFkP5gcBr9TWTouiSLNUr9RX1LbyifMaXrK
l8s+NKy5UoycohOKjLXX4m25VusPgAmyX3h7WQ8XQO0fxTz1xH1CMgT/peP7OuBy
MAiyNMlI/8U/bqdnKnfrw/7U7s/NaURMGXaVjwT0RNa0EB1/GvtyB+DMP3KAc+DA
5BIYnsoMfQGCq95rHbBGt7dt5VVq7lA2tbUSuVI3VwP3KDg0+Kfu5e/sMk4KnHy+
48LKdNsjH81ej8AGbFAU+e1M8gURQylSE8MvB/ycLS81Q3NgFeZiiuAy1VDu9f3t
NvmLrNyqR4Z6OgOSnWFnOTmtVlxpW1zA7kzc7BNCSzawXtTMzBsvQcbXv2nioY6u
GyBQKCdUcqommbqyR3+niQsFPPFNEThWYkqTYtiZHdMLiiY90eevcLysHrYzS5pw
o7UPh93uLzBQkCJcwcEh2xSGOUpSx66nd53VKsOuAMrzAmcjNmwtw0EP9XXkXF+q
LjX1U+QNIiGz/4cB2sZIIDkUym5ctMY7Zh/89nORcyMgu3wTK93z4XkdLvETQRlG
ze7JJtYKqU9/wU6feqGGfzWxod3A1uKkU+GPsw+u+RxUel/o4oA=
=idMX
-----END PGP SIGNATURE-----

Marius Bakke wrote 7 years ago
87efguzhg0.fsf@fastmail.com
Vagrant Cascadian <vagrant@debian.org> writes:

Toggle quote (9 lines)
>>> + (license lgpl2.1+)))
>>
>> I noticed the source contains GPL2 in COPYING, and LGPL2.1 as
>> "COPYING.LESSER". Can you make sure we don't install the former?
>
> I was a bit confused by that, but looking at all the actual code, it
> only appears to be LGPL2.1. So you're saying to explicitly remove
> COPYING from the package?

Yes, it seems COPYING is simply a leftover, so I'd prefer not to install
it somehow (e.g. by overriding the 'install-license-files' phase).
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlsxXe8ACgkQoqBt8qM6
VPrGewgAisNkiqdWI+vIBlOQ/8UWB/QRslFzNfkI5Rw0D7T3DSUnqyLJ34BvvVZq
8A5unxLiVWY0LUMcD21lTH2Ay1qKU4MxVNb1KlW4nnbSkM0ok5v7OcRhMYQBgKLQ
6PeCpkvNauBTh6/O+OBQPJm8QZnoKCWZDoTV4E24imgH6mfsWS8JCDCKAyK9lVav
2P2w65RfiiOwxQQj3hNbPUix4lUDKDsjqrihx7h4DsPdFrC3Tj3uncnUAZUEAIXD
peU5qqegfBWz1olHeMh1G74xMWjxTpl2+cQb6w+MZkw2TpeT4PaEW2UociZ1oxNL
z0TkX9XuRPxiAw99wi27AbjlyaG+aQ==
=F3gY
-----END PGP SIGNATURE-----

Vagrant Cascadian wrote 7 years ago
8736xanm8j.fsf@aikidev.net
On 2018-06-25, Marius Bakke wrote:
Toggle quote (6 lines)
> Vagrant Cascadian <vagrant@debian.org> writes:
>
>> Add new package definition for python-libusb1, needed to upgrade
>> python-trezor to newer versions.
>
> Thanks! I have some minor nitpicks:
...
Toggle quote (2 lines)
> Can you send an updated patch? Thanks in advance!

Updated patch attached:

- Add myself to copyright headers
- Drop unused srfi-26
- Remove needless line break
- Flesh out description a bit...
- Remove COPYING file, which didn't match the licensing of the files

The removal of COPYING was pretty much a shotgun-style approach, but I
couldn't figure out how to do a more surgical removal, and there weren't
any other COPYING files in the source.

The description could probably be further improved... but that's as far
as I got for now... :)


live well,
vagrant
From 088c81c4ca3a95bf51f04aec836aaedee8ab9ba8 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Tue, 26 Jun 2018 05:22:48 +0000
Subject: [PATCH] gnu: Add python-libusb1.

* gnu/packages/libusb.scm (python-libusb1): New variable.
---
gnu/packages/libusb.scm | 44 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index 62c936c19..39814bc90 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2016 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -214,6 +215,49 @@ with usb4java.")
implementing @code{javax.usb} (JSR-80).")
(license expat)))
+(define-public python-libusb1
+ (package
+ (name "python-libusb1")
+ (version "1.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "libusb1" version))
+ (sha256
+ (base32
+ "03b7xrz8vqg8w0za5r503jhcmbd1ls5610jcja1rqz833nf0v4wc"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:modules ((srfi srfi-1)
+ (guix build utils)
+ (guix build python-build-system))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install-license-files 'remove-incorrect-license
+ (lambda* (#:key out #:allow-other-keys)
+ ;; Was reliscensed to LGPL 2.1+, but old COPYING file still left
+ ;; in source. Remove it so it does not get installed.
+ (delete-file-recursively "COPYING")
+ #t))
+ (add-after 'unpack 'fix-libusb-reference
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "usb1/libusb1.py"
+ (("libusb_path = ctypes.util.find_library\\(base_name\\)")
+ (string-append
+ "libusb_path = \""
+ (find (negate symbolic-link?)
+ (find-files (assoc-ref inputs "libusb")
+ "^libusb.*\\.so\\..*"))
+ "\"")))
+ #t)))))
+ (inputs `(("libusb" ,libusb)))
+ (home-page "http://github.com/vpelletier/python-libusb1")
+ (synopsis "Pure-python wrapper for libusb-1.0")
+ (description "Libusb is a library that gives applications easy access to
+USB devices on various operating systems. This is a python wrapper for
+acessing libusb-1.0")
+ (license lgpl2.1+)))
+
(define-public python-pyusb
(package
(name "python-pyusb")
--
2.11.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcDardHbDotegGFCHt4uC1IFLkbYFAlsx0KwACgkQt4uC1IFL
kba6zQ/+PL1IBColD++X9UCgBmPJeohwee/lboY/junfjLmPrlDxdNiZ4v/UX+Cj
HpOXFJeYtW+32BZ+ImxolTQUSefIuapjr0XW6DIS4OCVF39IDL9+JmMLj5fsHp5/
Z2QV0Ve+YDSrtHD95qQbYfRWujO2A40QQnpbiUw1OLL4VgpcpWFOBxZX/+0x7tKY
v94nqB1WWVtrD8CgERE8C3M64ICHUaR2uMET4nWFbONg3gM74CwvEfFXIYHiaG4t
gVQWEFY1p7WV2Nqvec4Ql+dlOM6C6BiOG7ImH8pRlDv1hrd2jjYKxG+qMN7NVpXj
Nc5SWeUoBHNG9Q9GydsZ64Ka+Jd7R+NUZlRjNcxWSHIvD3YSek+XGsEyAIVw7/Mq
h998kwS2BbQ+UcdH39MoHOCBjjEgEsi66p2tlhSkTKcAhfdCEAKMrdbKo5TmkfoG
Uza22aTkxQOjUvTGqMaghdNIZxRGuT+Aq8Dh6H0quFJ8xFBBhCgcnK6ajssHO+cQ
01ebUJTJZFpO6prGZR4kkCvQGBjQBkKlLCHEGF30i0PpkUeo0Y6i84EYhhy1U+IM
Ur8jE1kpySTX87CkzEvZ87zn+v78+AXHbpjq0x/CvsN+QFx7m2QV2ar4nIF3M6D2
TuVo1FG03RAIiYFLxodb3ns1h+BmQyfIsebFg8l+QrwVOM7+rNA=
=RNHY
-----END PGP SIGNATURE-----

Marius Bakke wrote 7 years ago
87bmbxxm59.fsf@fastmail.com
Vagrant Cascadian <vagrant@debian.org> writes:

Toggle quote (25 lines)
> On 2018-06-25, Marius Bakke wrote:
>> Vagrant Cascadian <vagrant@debian.org> writes:
>>
>>> Add new package definition for python-libusb1, needed to upgrade
>>> python-trezor to newer versions.
>>
>> Thanks! I have some minor nitpicks:
> ...
>> Can you send an updated patch? Thanks in advance!
>
> Updated patch attached:
>
> - Add myself to copyright headers
> - Drop unused srfi-26
> - Remove needless line break
> - Flesh out description a bit...
> - Remove COPYING file, which didn't match the licensing of the files
>
> The removal of COPYING was pretty much a shotgun-style approach, but I
> couldn't figure out how to do a more surgical removal, and there weren't
> any other COPYING files in the source.
>
> The description could probably be further improved... but that's as far
> as I got for now... :)

Thanks! Applied with these cosmetic changes (mostly to please `guix lint`):
1 file changed, 5 insertions(+), 5 deletions(-)
gnu/packages/libusb.scm | 10 +++++-----

modified gnu/packages/libusb.scm
@@ -235,9 +235,9 @@ implementing @code{javax.usb} (JSR-80).")
(modify-phases %standard-phases
(add-before 'install-license-files 'remove-incorrect-license
(lambda* (#:key out #:allow-other-keys)
- ;; Was reliscensed to LGPL 2.1+, but old COPYING file still left
+ ;; Was relicensed to LGPL 2.1+, but old COPYING file still left
;; in source. Remove it so it does not get installed.
- (delete-file-recursively "COPYING")
+ (delete-file "COPYING")
#t))
(add-after 'unpack 'fix-libusb-reference
(lambda* (#:key inputs #:allow-other-keys)
@@ -251,11 +251,11 @@ implementing @code{javax.usb} (JSR-80).")
"\"")))
#t)))))
(inputs `(("libusb" ,libusb)))
(synopsis "Pure-python wrapper for libusb-1.0")
(description "Libusb is a library that gives applications easy access to
-USB devices on various operating systems. This is a python wrapper for
-acessing libusb-1.0")
+USB devices on various operating systems. This package provides a Python
+wrapper for accessing libusb-1.0.")
(license lgpl2.1+)))
(define-public python-pyusb

[back]
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlsysqIACgkQoqBt8qM6
VPpYzwf+IfdgY4onnQFMw64h3JhsvgNya2K6wCv76CopxTYmS0NqReFLQSFWbkH/
gFrwHEgAGWKpxmYvoWi6/syX20R8DlU2herHy3ALVFxMA42fT22/TsNu7+Yu7LfN
bKswhVMCCdHsLDFoFGfHjgoQSYBujTXnhWoI4/c8NgJgnpsf0g4bu0memlyL9ju7
HeWHfyw1AAigUYf4osMP5u4+sYu0J0lZ5VK47eqmdS0+KvBb8028g5IBm5ybg9lZ
5Ea3w5lduXK0wlCS60GDH5m/k4nZEjyGMG2Ytge3JboFCrp3q1unCige4/tU5e42
zo9P6H3UD5NT6h42IuXFrKnlaz/IUg==
=ptSR
-----END PGP SIGNATURE-----

Marius Bakke wrote 7 years ago
Re: [bug#31958] [PATCH] gnu: Add python-pyblake2.
(address . 31957-done@debbugs.gnu.org)
878t71xlhu.fsf@fastmail.com
Vagrant Cascadian <vagrant@debian.org> writes:

Toggle quote (43 lines)
> On 2018-06-25, Marius Bakke wrote:
>> Vagrant Cascadian <vagrant@debian.org> writes:
>>>> According to COPYING, this software is actually "octuple-licensed":
>>>>
>>>> * CC0 Universal 1.0 - http://creativecommons.org/publicdomain/zero/1.0
>>>> * Unlicense — http://unlicense.org/
>>>> * WTFPL Version 2 - http://www.wtfpl.net/
>>>> * Apache Public License 2.0 - https://www.apache.org/licenses/LICENSE-2.0
>>>> * OpenSSL License - https://www.openssl.org/source/license.html
>>>> * MIT License - https://opensource.org/licenses/MIT
>>>> * The BSD 3-Clause License - https://opensource.org/licenses/BSD-3-Clause
>>>> * ISC License - https://opensource.org/licenses/ISC
>>>>
>>>> Can you add each of these, along with an explaning comment?
>>>
>>> And all of those are merely fallback licenses to the author's intention
>>> of public domain... and in the files themselves (pyblake2module.c,
>>> setup.py), they only reference:
>>>
>>> http://creativecommons.org/publicdomain/zero/1.0
>>>
>>> But if it's more appropriate for guix to list all possible licenses,
>>> sure. :)
>>
>> Right. I missed the top comment of the COPYING file[0], which dedicates
>> the software to the public domain. But it also says that you are free
>> to choose any of the others at your discretion.
>>
>> So I think CC0 is appropriate, but please add a comment explaning the
>> situation. Thanks!
>>
>> [0] https://github.com/dchest/pyblake2/blob/master/COPYING
>
> Updated patch:
> - fixed commit message
> - moved to python-crypto.scm
> - removed needless linebreak
> - updated description
> - updated licensing to public-domain/cc0
> - clarified additional licensing in comments
>
> Hopefully that covers everything.

Thank you!

I shortened the description a bit while adding @code{} notations where
appropriate, and also added a copyright statement for you. Hope that
was okay :-)

I also moved the package so it wasn't squeezed between the Python3 and
Python2 variants of python-py-bcrypt.

(...and closing the previous patch bug while at it...)

Pushed as e64088f0b521145286bfe3f028699e418baf4832!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlsyte0ACgkQoqBt8qM6
VPpVEgf/Tc8Y3b/0IaUsOQXr1UHT1AkLf4FrUrMi6eM4XFfSBtK7iHnfYNx2W2+3
Mes+AXqcwLbEygXlUmfniJooB+UKBqC9UiuSkTyQLf0iJ2ve03/rG95awV5On7cv
m9Ty3MdU6OejrrwvZe9vATXmErZaWA/18FMLDyBPNR+lFY8LyabI9nH0sAqXO/zz
DMgJYnPYHqaSsisT7SxD7q+GOevnhv+lNjmQYB+5wV583tvp/5A2WTwGLJYAK6TJ
GDdI8wL+Ko4IeV4czWRw8wqwi0jA+gNdfs9aTHQespqKQpssBGEWXis679qcuJdr
pOHpFX+J0pyatu3QNROVUNLLV0KgVA==
=p405
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 31957@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 31957
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help