[PATCH] pack: Fix guix pack -f docker.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
20180622214637.23683-1-mail@cbaines.net
Without this change, running guix pack fails as (guix sets) is missing when
compiling (guix build store-copy).

* guix/scripts/pack.scm (docker-image): Move (guix build store-copy) to within
the source-module-closure call.
---
guix/scripts/pack.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/guix/scripts/pack.scm b/guix/scripts/pack.scm
index ed876b259..443d199be 100644
--- a/guix/scripts/pack.scm
+++ b/guix/scripts/pack.scm
@@ -364,9 +364,9 @@ the image."
(define build
;; Guile-JSON is required by (guix docker).
(with-extensions (list json)
- (with-imported-modules `(,@(source-module-closure '((guix docker))
+ (with-imported-modules `(,@(source-module-closure '((guix docker)
+ (guix build store-copy))
#:select? not-config?)
- (guix build store-copy)
((guix config) => ,config))
#~(begin
(use-modules (guix docker) (srfi srfi-19) (guix build store-copy))
--
2.17.1
Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 31942@debbugs.gnu.org)
87a7rlw4d8.fsf@gnu.org
Hi Chris!

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (6 lines)
> Without this change, running guix pack fails as (guix sets) is missing when
> compiling (guix build store-copy).
>
> * guix/scripts/pack.scm (docker-image): Move (guix build store-copy) to within
> the source-module-closure call.

Good catch, got for it!

Thanks,
Ludo’.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 31942-done@debbugs.gnu.org)
87zhzkr3oh.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (12 lines)
> Hi Chris!
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> Without this change, running guix pack fails as (guix sets) is missing when
>> compiling (guix build store-copy).
>>
>> * guix/scripts/pack.scm (docker-image): Move (guix build store-copy) to within
>> the source-module-closure call.
>
> Good catch, got for it!

Great, I've pushed this now.

Note that the squashfs format looks to be similarly broken, but not
quite as simple to fix.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlsvVZ5fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xc39RAAsh/Iof+cVUnIymAHaLYEqpjUgTWI9hx5+84yip+tEm9lCTwXh76Xms5P
8HgvgoQNna1+UEAXUhG8O4fgD+yUxd+ryJcewputKvvzetwqzR7lqpA6YvUkmHkR
cA/JxUIlTBVGqcs8iuy4AW0+K7C7smVKEzEWqmVkrIn65Dw6lcOzI7HsEMPoaX1N
ZPOih8+6LzjZFZ7tqdXXBkBS8HyZ6eOTqEzE66pecC021VB3nWVpQ0q7yyngDwyG
qOpKSXBG9pahojnBLc0sbuVbX6uF7Gp2EICpqDY26CObIozQp3z113h8vXPPdTA1
+QIMb3QAvQERAjQ5M1BG0CJ7W175MVqIDFYBUKMT4S62lhcFH8hIqa+MJUvUS+CB
Zo/qc1y67cmTgKIJDSUqfkgVToJKVIrgQ9ztNH3L3bkk79XXU0P7X3rvYyWdOtX/
dAlTmcLLJWCXengoT06d1fA96dio9HThELqZecRHQFImdx7d3FK3cPTfESm4LPkZ
cUPHcx6UYsDJb/S6gkDXWU03DpYA1rC9j9SMDfczm1MT3on/SSfXVSf0roZApCRR
nEbq/iAAg2EoPBu3ViXknJjkoGCUbFz5ggQ3NJ84m46msn3OtT1cdRuBMvelExRz
iEIFxx+vOw60wPdvxX/QDNo5QDJW+NsAMrnqCO7rxabYfDzUxeY=
=v1pU
-----END PGP SIGNATURE-----

Closed
Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 31942-done@debbugs.gnu.org)
87woumpmz6.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (19 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Hi Chris!
>>
>> Christopher Baines <mail@cbaines.net> skribis:
>>
>>> Without this change, running guix pack fails as (guix sets) is missing when
>>> compiling (guix build store-copy).
>>>
>>> * guix/scripts/pack.scm (docker-image): Move (guix build store-copy) to within
>>> the source-module-closure call.
>>
>> Good catch, got for it!
>
> Great, I've pushed this now.
>
> Note that the squashfs format looks to be similarly broken, but not
> quite as simple to fix.

Fixed in 66e9944e078cbb9e0d618377dd6df6e639640efa.

Thanks for the heads-up!

Ludo'.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 31942@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 31942
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help