Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
Without this change, running guix pack fails as (guix sets) is missing when
compiling (guix build store-copy).
* guix/scripts/pack.scm (docker-image): Move (guix build store-copy) to within
the source-module-closure call.
---
guix/scripts/pack.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (18 lines)
diff --git a/guix/scripts/pack.scm b/guix/scripts/pack.scm
index ed876b259..443d199be 100644
--- a/guix/scripts/pack.scm
+++ b/guix/scripts/pack.scm
@@ -364,9 +364,9 @@ the image."
(define build
;; Guile-JSON is required by (guix docker).
(with-extensions (list json)
- (with-imported-modules `(,@(source-module-closure '((guix docker))
+ (with-imported-modules `(,@(source-module-closure '((guix docker)
+ (guix build store-copy))
#:select? not-config?)
- (guix build store-copy)
((guix config) => ,config))
#~(begin
(use-modules (guix docker) (srfi srfi-19) (guix build store-copy))
--
2.17.1