[PATCH] gnu: Add dehydrated.

  • Done
  • quality assurance status badge
Details
2 participants
  • Clément Lassieur
  • Ludovic Courtès
Owner
unassigned
Submitted by
Clément Lassieur
Severity
normal
C
C
Clément Lassieur wrote on 15 Jun 2018 03:05
(address . guix-patches@gnu.org)
20180615010537.26942-1-clement@lassieur.org
* gnu/packages/tls.scm (dehydrated): New variable.
---
gnu/packages/tls.scm | 71 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 71 insertions(+)

Toggle diff (99 lines)
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index a934a5087..b54cd1526 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,10 +39,14 @@
#:use-module (guix build-system python)
#:use-module (guix build-system cmake)
#:use-module (guix build-system haskell)
+ #:use-module (guix build-system trivial)
#:use-module (gnu packages compression)
#:use-module (gnu packages)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages check)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages dns)
+ #:use-module (gnu packages gawk)
#:use-module (gnu packages guile)
#:use-module (gnu packages haskell)
#:use-module (gnu packages haskell-check)
@@ -873,3 +878,69 @@ implement the SSL3.0, TLS1.0, TLS1.1 and TLS1.2 protocol, and support RSA and
Ephemeral (Elliptic curve and regular) Diffie Hellman key exchanges, and many
extensions.")
(license license:bsd-3)))
+
+(define-public dehydrated
+ (package
+ (name "dehydrated")
+ (version "0.6.2")
+ (source (origin
+ (method url-fetch/tarbomb)
+ (uri (string-append
+ "https://github.com/lukas2511/dehydrated/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "03p80yj6bnzjc6dkp5hb9wpplmlrla8n5src71cnzw4rj53q8cqn"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((source (assoc-ref %build-inputs "source"))
+ (out (assoc-ref %outputs "out"))
+ (bin (string-append out "/bin"))
+ (bash (in-vicinity (assoc-ref %build-inputs "bash") "bin")))
+ (mkdir-p bin)
+ (with-directory-excursion bin
+ (copy-file
+ (in-vicinity source (string-append "/dehydrated-" ,version
+ "/dehydrated"))
+ (in-vicinity bin "dehydrated"))
+ (patch-shebang "dehydrated" (list bash))
+
+ ;; Do not try to write in the store.
+ (substitute* "dehydrated"
+ (("SCRIPTDIR=\"\\$.*\"") "SCRIPTDIR=~/.dehydrated"))
+
+ (setenv "PATH" bash)
+ (wrap-program "dehydrated"
+ `("PATH" ":" prefix
+ ,(map (lambda (dir)
+ (string-append dir "/bin"))
+ (map (lambda (input)
+ (assoc-ref %build-inputs input))
+ '("coreutils"
+ "curl"
+ "diffutils"
+ "gawk"
+ "grep"
+ "openssl"
+ "sed"))))))
+ #t))))
+ (inputs
+ `(("bash" ,bash)
+ ("coreutils" ,coreutils)
+ ("curl" ,curl)
+ ("diffutils" ,diffutils)
+ ("gawk" ,gawk)
+ ("grep" ,grep)
+ ("openssl" ,openssl)
+ ("sed" ,sed)))
+ (home-page "https://dehydrated.io/")
+ (synopsis "Let's Encrypt/ACME client implemented as a shell script")
+ (description "Dehydrated is a client for signing certificates with an
+ACME-server (currently only provided by Let's Encrypt) implemented as a
+relatively simple Bash script.")
+ (license license:expat)))
--
2.17.1
L
L
Ludovic Courtès wrote on 16 Jun 2018 18:10
(name . Clément Lassieur)(address . clement@lassieur.org)(address . 31839@debbugs.gnu.org)
87vaaiogpr.fsf@gnu.org
Salut Clément,

Clément Lassieur <clement@lassieur.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/tls.scm (dehydrated): New variable.

LGTM, thanks!

Ludo'.
C
C
Clément Lassieur wrote on 16 Jun 2018 20:47
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 31839-done@debbugs.gnu.org)
87tvq28t7e.fsf@lassieur.org
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (10 lines)
> Salut Clément,
>
> Clément Lassieur <clement@lassieur.org> skribis:
>
>> * gnu/packages/tls.scm (dehydrated): New variable.
>
> LGTM, thanks!
>
> Ludo'.

Pushed, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 31839@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 31839
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch