[PATCH 2/4] gnu: Add python-tldextract.

  • Done
  • quality assurance status badge
Details
One participant
  • Clément Lassieur
Owner
unassigned
Submitted by
Clément Lassieur
Severity
normal
C
C
Clément Lassieur wrote on 14 Jun 2018 01:25
(address . guix-patches@gnu.org)
20180613232551.3382-2-clement@lassieur.org
* gnu/packages/python.scm (python-tldextract, python2-tldextract): New
variables.
---
gnu/packages/python.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4b1ea91ae..21201cc8d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13658,3 +13658,36 @@ library to allow local filesystem access via file:// URLs.")
(define-public python2-requests-file
(package-with-python2 python-requests-file))
+
+(define-public python-tldextract
+ (package
+ (name "python-tldextract")
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "tldextract" version))
+ (sha256
+ (base32
+ "1d5s8v6kpsgazyahflhji1cfdcf89rv7l7z55v774bhzvcjp2y99"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-responses" ,python-responses)))
+ (propagated-inputs
+ `(("python-idna" ,python-idna)
+ ("python-requests" ,python-requests)
+ ("python-requests-file" ,python-requests-file)))
+ (home-page
+ "https://github.com/john-kurkowski/tldextract")
+ (synopsis
+ "Separate the TLD from the registered domain and subdomains of a URL")
+ (description
+ "TLDExtract accurately separates the TLD from the registered domain and
+subdomains of a URL, using the Public Suffix List. By default, this includes
+the public ICANN TLDs and their exceptions. It can optionally support the
+Public Suffix List's private domains as well.")
+ (license license:bsd-3)))
+
+(define-public python2-tldextract
+ (package-with-python2 python-tldextract))
--
2.17.1
C
C
Clément Lassieur wrote on 14 Jun 2018 08:24
control message for bug #31823
(address . control@debbugs.gnu.org)
87in6lvqab.fsf@lassieur.org
tags 31823 fixed
close 31823
?