[PATCH 4/4] gnu: Add python-dns-lexicon.

  • Done
  • quality assurance status badge
Details
One participant
  • Clément Lassieur
Owner
unassigned
Submitted by
Clément Lassieur
Severity
normal
C
C
Clément Lassieur wrote on 14 Jun 2018 01:25
(address . guix-patches@gnu.org)
20180613232551.3382-4-clement@lassieur.org
* gnu/packages/python.scm (python-dns-lexicon, python2-dns-lexicon): New
variables.
---
gnu/packages/python.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c09b00609..72e8d9292 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13716,3 +13716,36 @@ Public Suffix List's private domains as well.")
(define-public python2-pynamecheap
(package-with-python2 python-pynamecheap))
+
+(define-public python-dns-lexicon
+ (package
+ (name "python-dns-lexicon")
+ (version "2.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dns-lexicon" version))
+ (sha256
+ (base32
+ "0jdn3ns71bsybr7njgsqr9xlxsqh7zh6phn4ld0liazqdn2l5f6m"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;requires internet access
+ (propagated-inputs
+ `(("python-future" ,python-future)
+ ("python-pynamecheap" ,python-pynamecheap)
+ ("python-requests" ,python-requests)
+ ("python-tldextract" ,python-tldextract)
+ ("python-urllib3" ,python-urllib3)))
+ (home-page "https://github.com/AnalogJ/lexicon")
+ (synopsis
+ "Manipulate DNS records on various DNS providers")
+ (description
+ "Lexicon provides a way to manipulate DNS records on multiple DNS
+providers in a standardized way. It has a CLI but it can also be used as a
+Python library. It was designed to be used in automation, specifically with
+Let's Encrypt.")
+ (license license:expat)))
+
+(define-public python2-dns-lexicon
+ (package-with-python2 python-dns-lexicon))
--
2.17.1
C
C
Clément Lassieur wrote on 14 Jun 2018 08:24
control message for bug #31821
(address . control@debbugs.gnu.org)
87fu1pvqa0.fsf@lassieur.org
tags 31821 fixed
close 31821
?