Danny Milosavljevic wrote 7 years ago
Hi,
I tried to update gtk-doc to 1.27.
Unfortunately, a unit test (sanity.sh) fails because it expects a certain maximal number of status lines.
Because our texlive-union dynamically generates metafont stuff, it prints a LOT more status lines (metafont
outputs a lot).
Is it possible to silence metafont? Or to have it generate the fonts before the tests run? Or should
we just disable the test?
From 5baa1f738da0685b6d8f4aec5252f1bbf5201724 Mon Sep 17 00:00:00 2001
From: Danny Milosavljevic <dannym@scratchpost.org>
Date: Wed, 13 Jun 2018 22:06:11 +0200
Subject: [PATCH staging] gnu: gtk-doc: Update to 1.27.
Tags: patch
* gnu/packages/gtk.scm (gtk-doc)[source]: Update to 1.27.
[arguments]<#:phases>[patch-gtk-doc-scan]: New phase.
[propagated-inputs]: Add python-six.
---
gnu/packages/gtk.scm | 15 +++++++++++++--
1 file changed, 13 insertions(+), 2 deletions(-)
Toggle diff (45 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index f7196611d..dff6eac8c 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1411,7 +1411,7 @@ information.")
(define-public gtk-doc
(package
(name "gtk-doc")
- (version "1.25")
+ (version "1.27")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1419,12 +1419,21 @@ information.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0hpxcij9xx9ny3gs9p0iz4r8zslw8wqymbyababiyl7603a6x90y"))))
+ "0vwsdl61nvnmqswlz5j9m4hg7qirhazwcikcnqf9nx0c13vx6sz2"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-gtk-doc-scan
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "gtk-doc.xsl"
+ (("http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl")
+ (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl)
+ "/html/chunk.xsl")))
+ #t))
(add-before 'build 'set-HOME
(lambda _
;; FIXME: dblatex with texlive-union does not find the built
@@ -1465,6 +1474,8 @@ information.")
("docbook-xsl" ,docbook-xsl)
("source-highlight" ,source-highlight)
("glib" ,glib)))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
(home-page "http://www.gtk.org/gtk-doc/")
(synopsis "Documentation generator from C source code")
(description
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlshfVcACgkQ5xo1VCww
uqW6jQf/X4/nMku5sJzSIebFkTvO8r8jM0RAChhpO3EbcABMtbQQ0OKc0GmyWRTh
dT5KHur2deaxCpaCv9TLiUQ62oIvYtyoFA40nc+RzA+CWon23HXYHCZnh5mK2+XN
sRo/dyQgkHhCrCfn+l2SUJPapGtWqtDzgG43CV4K7U1SXI3bVoN5ecdtf1f384w6
NGEe3Hz11dqFydrO8z5dmDvb/d4ldwJDKW4VmOz54CLig8MjeAp0fhq0j/Uy2bda
NjPVLhBdQZBDR4LGkBYWrIPQEvQe/vyaHyznNiYf0uUlU64+P/4PkBw3L3ML6qlB
7u4UehZyRyfFZ2ekOLHA4zi4Yg+DDg==
=2/3o
-----END PGP SIGNATURE-----