[PATCH core-updates] gnu: gtk-doc: Update to 1.27.

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Marius Bakke
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 7 years ago
20180613222351.1ac2990f@scratchpost.org
Hi,

I tried to update gtk-doc to 1.27.

Unfortunately, a unit test (sanity.sh) fails because it expects a certain maximal number of status lines.

Because our texlive-union dynamically generates metafont stuff, it prints a LOT more status lines (metafont
outputs a lot).

Is it possible to silence metafont? Or to have it generate the fonts before the tests run? Or should
we just disable the test?
From 5baa1f738da0685b6d8f4aec5252f1bbf5201724 Mon Sep 17 00:00:00 2001
From: Danny Milosavljevic <dannym@scratchpost.org>
Date: Wed, 13 Jun 2018 22:06:11 +0200
Subject: [PATCH staging] gnu: gtk-doc: Update to 1.27.
Tags: patch

* gnu/packages/gtk.scm (gtk-doc)[source]: Update to 1.27.
[arguments]<#:phases>[patch-gtk-doc-scan]: New phase.
[propagated-inputs]: Add python-six.
---
gnu/packages/gtk.scm | 15 +++++++++++++--
1 file changed, 13 insertions(+), 2 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index f7196611d..dff6eac8c 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1411,7 +1411,7 @@ information.")
(define-public gtk-doc
(package
(name "gtk-doc")
- (version "1.25")
+ (version "1.27")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1419,12 +1419,21 @@ information.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0hpxcij9xx9ny3gs9p0iz4r8zslw8wqymbyababiyl7603a6x90y"))))
+ "0vwsdl61nvnmqswlz5j9m4hg7qirhazwcikcnqf9nx0c13vx6sz2"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-gtk-doc-scan
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "gtk-doc.xsl"
+ (("http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl")
+ (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl)
+ "/html/chunk.xsl")))
+ #t))
(add-before 'build 'set-HOME
(lambda _
;; FIXME: dblatex with texlive-union does not find the built
@@ -1465,6 +1474,8 @@ information.")
("docbook-xsl" ,docbook-xsl)
("source-highlight" ,source-highlight)
("glib" ,glib)))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
(home-page "http://www.gtk.org/gtk-doc/")
(synopsis "Documentation generator from C source code")
(description
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlshfVcACgkQ5xo1VCww
uqW6jQf/X4/nMku5sJzSIebFkTvO8r8jM0RAChhpO3EbcABMtbQQ0OKc0GmyWRTh
dT5KHur2deaxCpaCv9TLiUQ62oIvYtyoFA40nc+RzA+CWon23HXYHCZnh5mK2+XN
sRo/dyQgkHhCrCfn+l2SUJPapGtWqtDzgG43CV4K7U1SXI3bVoN5ecdtf1f384w6
NGEe3Hz11dqFydrO8z5dmDvb/d4ldwJDKW4VmOz54CLig8MjeAp0fhq0j/Uy2bda
NjPVLhBdQZBDR4LGkBYWrIPQEvQe/vyaHyznNiYf0uUlU64+P/4PkBw3L3ML6qlB
7u4UehZyRyfFZ2ekOLHA4zi4Yg+DDg==
=2/3o
-----END PGP SIGNATURE-----


Ricardo Wurmus wrote 7 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 31819@debbugs.gnu.org)
87h8m6bcyy.fsf@elephly.net
Hi Danny,

Toggle quote (6 lines)
> Because our texlive-union dynamically generates metafont stuff, it
> prints a LOT more status lines (metafont outputs a lot).
>
> Is it possible to silence metafont? Or to have it generate the fonts
> before the tests run? Or should we just disable the test?

The fact that it generates the fonts *again* is a problem I haven’t yet
been able to fix in texlive-union. This should not happen, because the
fonts should already be there after the specific texlive union package
has been built. The big texlive package did not have this behaviour.

This annoying behaviour also led me to add (setenv "HOME" …) expressions
to build phases in some packages after switching from “texlive” to
“texlive-union” or “texlive-tiny”, because that’s where the dynamically
generated fonts end up.

I don’t see how we can silence it in general.

--
Ricardo
Marius Bakke wrote 7 years ago
Re: [bug#31819] [PATCH core-updates] gnu: gtk-doc: Update to 1.27.
87r2l2n9v0.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (6 lines)
> Hi,
>
> I tried to update gtk-doc to 1.27.
>
> Unfortunately, a unit test (sanity.sh) fails because it expects a certain maximal number of status lines.

I think it's fine to disable the sanity test for now, with a comment
that it's really a bug in texlive-union (IIUC).

However: why is this labelled 'core-updates'? This is good for
'master', no?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlspD1MACgkQoqBt8qM6
VPrDRgf/bEdkkbQT4PVIy3Mg4QMJPTdzpjrypA5MAMw2+wueJfoZAFQhwv/eh3oP
JK6sMkan98dtOxdrBv1u0/AEev3oA4pV5hvN1GnQfcLqwYx3w8DS19xKyhNku3SF
OLhgn+eEHs3M3fXpMG2DsR50NCb8zhJnnFwgCf613ZBtHZCnaw0s0fh6nBSraVS4
/nqg2eqMcR0/uCp759dKqM/J7qHLL6ahJe3j6VX0GQ4JTwkEZsYEBeGovI6z/I/I
6r/8oeVZjvJlzpsBu+PyW4+jSjsnkU0YSRR3OwA1IycZFkK3jd6i+XSJuOW1igNw
uWATRt6Ez0bc3aZ9XakdZEKTBx0tbw==
=DdUD
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 7 years ago
(no subject)
(address . control@debbugs.gnu.org)
20180624035732.46d82bdc@scratchpost.org
close 31819
?
Your comment

This issue is archived.

To comment on this conversation send an email to 31819@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 31819
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help