[PATCH] gnu: debootstrap: Substitute chroot in 'patch-source' phase.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 7 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20180605202024.28154-1-kkebreau@posteo.net
* gnu/packages/debian.scm (debootstrap)[arguments]: In 'patch-source' phase,
substitute chroot in the debootstrap script file.
---
gnu/packages/debian.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index 01df30c55..5df575255 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -129,6 +129,7 @@ contains the archive keys used for that.")
(add-after 'unpack 'patch-source
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
+ (coreutils (assoc-ref inputs "coreutils"))
(wget (assoc-ref inputs "wget"))
(debian (assoc-ref inputs "debian-keyring"))
(ubuntu (assoc-ref inputs "ubuntu-keyring")))
@@ -141,6 +142,7 @@ contains the archive keys used for that.")
(substitute* "scripts/gutsy"
(("/usr") ubuntu))
(substitute* "debootstrap"
+ (("chroot ") (string-append coreutils "/bin/chroot "))
(("=/usr") (string-append "=" out)))
(substitute* "functions"
(("wget ") (string-append wget "/bin/wget ")))
@@ -154,7 +156,8 @@ contains the archive keys used for that.")
#:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
#:tests? #f)) ; no tests
(inputs
- `(("debian-keyring" ,debian-archive-keyring)
+ `(("coreutils" ,coreutils)
+ ("debian-keyring" ,debian-archive-keyring)
("ubuntu-keyring" ,ubuntu-keyring)
("wget" ,wget)))
;; The following are required for debootstrap to work correctly
--
2.17.1
Ludovic Courtès wrote 7 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 31729@debbugs.gnu.org)
87zi05jq0f.fsf@gnu.org
Hello Kei,

Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (3 lines)
> * gnu/packages/debian.scm (debootstrap)[arguments]: In 'patch-source' phase,
> substitute chroot in the debootstrap script file.

Please add “[inputs]: Add COREUTILS.” as well. Otherwise LGTM!

Thanks,
Ludo’.
Kei Kebreau wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 31729-done@debbugs.gnu.org)
8736xxgvse.fsf@posteo.net
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (12 lines)
> Hello Kei,
>
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> * gnu/packages/debian.scm (debootstrap)[arguments]: In 'patch-source' phase,
>> substitute chroot in the debootstrap script file.
>
> Please add “[inputs]: Add COREUTILS.” as well. Otherwise LGTM!
>
> Thanks,
> Ludo’.

Thanks for reviewing! Pushed to master with the suggested change.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlsanBEACgkQ5qXuPBlG
eg2Dkg/+IjgypXrPwEZXEW1si/wWpv4TLB2ik1eGlLWxlSDRy/WSvlF/jFOaY9ML
mAQCe3W+0o1PFdKCtIvMksH+d3ZVyK50IrR2pdnFMqfP95bFfePVIMTPHHCD4xpF
EJCuSf1GUvbtWIliLYPTHCynIkVfJm+k8d+03i6YBbcGVJUnwapZgN1fBA+rwi71
+jh/GZ5aeFsO6G92BAZhn1zTTNcc/zDrIlfxxtloTs5QDSY1s/wY67lkFLOcmU37
1mmapJ7vfsYNq3GDmfVSUZJ3TdE0UPCTVDlsZURRBVZx0kp4vAOKId99WS4PST0b
QzR0kJQm6b+W+V7PqAQ6NjY5hDJDIfnyUGoFIB3BZLSfKwTGf6GKr+arVdybfo3f
+2q0TDsXOnqFrX7o7AnWvri0W7MpMKIOD53HdltSxDPz1MZYdcsDHlYP0tjCWZyi
i0tqkkUjv75zs6S+f8o7D3StwoBZwTSMMYgguCR40tiRmobzs3NuViW9VtF1IazT
V+EHs0fUVUigkPGfWE8layhNl9htHkcFgoLId7uBE+nqqFv/tIxgqRKftMBJ/8Yk
rjAvPcPKo0/b0Gh5EeCfoPHLSdVmIfY1aTVbFrCyPf/akb31kPf1tvI6qWaaF51O
wbxwYPfytAPpsLLAisStCBaatTWqdr7b/SEe9UpJdqg3i56j8Sk=
=CAX0
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 31729@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 31729
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help