powertabeditor fails to build since qt upgrade

DoneSubmitted by Ricardo Wurmus.
Details
2 participants
  • Clément Lassieur
  • Ricardo Wurmus
Owner
unassigned
Severity
normal
R
R
Ricardo Wurmus wrote on 30 May 2018 08:39
(address . bug-guix@gnu.org)
876035r6iy.fsf@elephly.net
The powertabeditor package fails to build. Errors include these:
Toggle snippet (58 lines)/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp: In constructor ‘BendDialog::BendDialog(QWidget*)’:/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp:36:50: error: invalid use of incomplete type ‘class QButtonGroup’ myDurationButtonGroup = new QButtonGroup(this); ^In file included from /tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp:18:0:/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.h:24:7: note: forward declaration of ‘class QButtonGroup’ class QButtonGroup; ^/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp:37:26: error: invalid use of incomplete type ‘class QButtonGroup’ myDurationButtonGroup->addButton(ui->defaultDurationButton); ^In file included from /tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp:18:0:/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.h:24:7: note: forward declaration of ‘class QButtonGroup’ class QButtonGroup; ^/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp:38:26: error: invalid use of incomplete type ‘class QButtonGroup’ myDurationButtonGroup->addButton(ui->customDurationButton); ^In file included from /tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp:18:0:/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.h:24:7: note: forward declaration of ‘class QButtonGroup’ class QButtonGroup; ^/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp: In member function ‘void BendDialog::handleBendTypeChanged()’:/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp:95:45: error: invalid use of incomplete type ‘class QButtonGroup’ for (auto button : myDurationButtonGroup->buttons()) ^In file included from /tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp:18:0:/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.h:24:7: note: forward declaration of ‘class QButtonGroup’ class QButtonGroup; ^/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp:103:53: error: invalid use of incomplete type ‘class QButtonGroup’ for (auto button : myDurationButtonGroup->buttons()) ^In file included from /tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp:18:0:/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.h:24:7: note: forward declaration of ‘class QButtonGroup’ class QButtonGroup; ^/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp:115:53: error: invalid use of incomplete type ‘class QButtonGroup’ for (auto button : myDurationButtonGroup->buttons()) ^In file included from /tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp:18:0:/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.h:24:7: note: forward declaration of ‘class QButtonGroup’ class QButtonGroup; ^/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp:122:53: error: invalid use of incomplete type ‘class QButtonGroup’ for (auto button : myDurationButtonGroup->buttons()) ^In file included from /tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.cpp:18:0:/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/powertabeditor-2.0.0-alpha10/source/dialogs/benddialog.h:24:7: note: forward declaration of ‘class QButtonGroup’ class QButtonGroup; ^make[2]: *** [source/dialogs/CMakeFiles/ptedialogs.dir/build.make:330: source/dialogs/CMakeFiles/ptedialogs.dir/benddialog.cpp.o] Error 1make[2]: Leaving directory '/tmp/guix-build-powertabeditor-2.0.0-alpha10.drv-0/build'make[1]: *** [CMakeFiles/Makefile2:371: source/dialogs/CMakeFiles/ptedialogs.dir/all] Error 2make[1]: *** Waiting for unfinished jobs....

-- Ricardo
C
C
Clément Lassieur wrote on 31 May 2018 11:16
control message for bug #31659
(address . control@debbugs.gnu.org)
87sh68jics.fsf@lassieur.org
tags 31659 easy
R
R
Ricardo Wurmus wrote on 31 May 2018 11:59
bug#31659: powertabeditor fails to build since qt upgrade
(address . 31659-done@debbugs.gnu.org)
87efhsp2my.fsf@elephly.net
Fixed with commit 1e341fa50849094fd5c685b6dfb2ee328a2ae44e.
-- Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send email to 31659@debbugs.gnu.org