[FIXME] services: Add fingerprint identification service.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180530174415.26018-1-dannym@scratchpost.org
* gnu/services/fingerprint.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
* doc/guix.texi (Miscellaneous Services): Document it.
---
doc/guix.texi | 15 +++++++++++++++
gnu/local.mk | 1 +
gnu/services/fingerprint.scm | 41 +++++++++++++++++++++++++++++++++++++++++
3 files changed, 57 insertions(+)
create mode 100644 gnu/services/fingerprint.scm

Toggle diff (85 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 09749b15e..95abd0b81 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -19777,6 +19777,21 @@ The port to bind the server to.
@node Miscellaneous Services
@subsubsection Miscellaneous Services
+@cindex fingerprint
+@subsubheading Fingerprint Service
+
+The @code{(gnu services fingerprint)} module provides a DBus service to
+read and identify fingerprints via a fingerprint sensor.
+
+@defvr {Scheme Variable} fprintd-service-type
+The service type for @command{fprintd}, which provides the fingerprint
+reading capability.
+
+@example
+(service fprintd-service-type)
+@end example
+@end defvr
+
@cindex sysctl
@subsubheading System Control Service
diff --git a/gnu/local.mk b/gnu/local.mk
index 7734586f0..42797bcb0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -470,6 +470,7 @@ GNU_SYSTEM_MODULES = \
%D%/services/desktop.scm \
%D%/services/dict.scm \
%D%/services/dns.scm \
+ %D%/services/fingerprint.scm \
%D%/services/games.scm \
%D%/services/kerberos.scm \
%D%/services/lirc.scm \
diff --git a/gnu/services/fingerprint.scm b/gnu/services/fingerprint.scm
new file mode 100644
index 000000000..1ab2b0300
--- /dev/null
+++ b/gnu/services/fingerprint.scm
@@ -0,0 +1,41 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu services fingerprint)
+ #:use-module (gnu services)
+ #:use-module (gnu services dbus)
+ #:use-module (gnu packages freedesktop)
+ #:use-module (guix gexp)
+ #:use-module (guix records)
+ #:export (fprintd-configuration
+ fprintd-configuration?
+ fprintd-service-type))
+
+(define-record-type* <fprintd-configuration>
+ fprintd-configuration make-fprintd-configuration
+ fprintd-configuration?
+ (ntp fprintd-configuration-fprintd
+ (default fprintd)))
+
+(define fprintd-service-type
+ (service-type (name 'fprintd)
+ (extensions
+ (list (service-extension dbus-root-service-type
+ list)))
+ (description
+ "Run fprintd, a fingerprint management daemon.")))
Ludovic Courtès wrote 7 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 31657@debbugs.gnu.org)
877emqy4zj.fsf@gnu.org
Hi Danny,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (4 lines)
> * gnu/services/fingerprint.scm: New file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
> * doc/guix.texi (Miscellaneous Services): Document it.

Why “FIXME” in the subject? :-) Overall it LGTM.

The only question is whether it’s enough to have it activated by DBus,
or whether we should have a Shepherd service to make sure it’s started
when the system boots. Thoughts?

Also, perhaps we should call the module “authentication.scm”?

Thanks,
Ludo’.
Danny Milosavljevic wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 31657-done@debbugs.gnu.org)
20180623001808.6087498b@scratchpost.org
Hi Ludo,

On Fri, 22 Jun 2018 21:51:28 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (4 lines)
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
> Why “FIXME” in the subject? :-) Overall it LGTM.

A default I forgot to fix.

Toggle quote (4 lines)
> The only question is whether it’s enough to have it activated by DBus,
> or whether we should have a Shepherd service to make sure it’s started
> when the system boots. Thoughts?

Oh, I haven't done the system integration yet. It's just providing
enough for fprintd programs to actually work (dbus activation will
be enough for those).

Toggle quote (2 lines)
> Also, perhaps we should call the module “authentication.scm”?

Ok!

Pushed as 7f93bbd5aadf0427190769fba8f478c29e37b4f4.

Let's open a new bug for the system integration later.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlstdaAACgkQ5xo1VCww
uqV0nAf8CIlSLZ7snOFJKmPJM2w0Bhq+H5bG+DP35EvY9PBX9nizLqcIPmMMtExL
LyKgtPJxSjN15YxtoVamMahWLmTa6YbJnHv8KJf5Otmutcf4lFAyUyhtxKlNSRLN
5+OWjwgWPvBojJO+9ZxxiU2Q3hBvZzUqtwBndpys0muZj+ImBY9tAzko2n4kbfZF
y9eQPX/MeFPBKtijsIkShW1gbW1x1v+x44ucLxlj2yBjD3/IOeeeaaSOljxH3cg1
tpluA4Irj+kqEkAtm3w8twhvisZ67T31N0Zdjth79obEOE4Pbw2SiNhmyWZjvQb5
HajL+mFqDH0Hz5ESv6oaF4Zz+cT5uw==
=hyJN
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 31657@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 31657
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help