[PATCH] gnu: Add emacs-zotxt.

  • Done
  • quality assurance status badge
Details
2 participants
  • Konrad Hinsen
  • Ludovic Courtès
Owner
unassigned
Submitted by
Konrad Hinsen
Severity
normal
K
K
Konrad Hinsen wrote on 28 May 2018 13:07
(address . guix-patches@gnu.org)
m1muwk2g36.fsf@fastmail.net
* gnu/packages/emacs.scm (emacs-zotxt): New variable.
---
gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index fc7f52a32..0fb466b64 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10548,3 +10548,29 @@ well as take screenshots and lock your screen. The package depends on the
availability of shell commands to do the hard work for us. These commands can
be changed by customizing the appropriate variables.")
(license license:gpl3+)))
+
+(define-public emacs-zotxt
+ (package
+ (name "emacs-zotxt")
+ (version "20180518")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/egh/zotxt-emacs/archive/"
+ "23a4a9f74a658222027d53a9a83cd4bcc583ca8b"
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1qlibaciqgsva6fc7vv9krssjq00bi880396jk7llbi3c52q9n1y"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-deferred" ,emacs-deferred)
+ ("emacs-request" ,emacs-request)))
+ (home-page "https://github.com/egh/zotxt-emacs")
+ (synopsis
+ "Tools to integrate emacs with Zotero via the zotxt plugin")
+ (description "This package provides two integration features between Emacs and
+Zotero: Insertion of links to Zotero items into an org-mode file, and citations
+of Zotero items in pandoc markdown files.")
+ (license license:gpl3+)))
--
2.17.0
L
L
Ludovic Courtès wrote on 31 May 2018 18:06
(name . Konrad Hinsen)(address . konrad.hinsen@fastmail.net)(address . 31619-done@debbugs.gnu.org)
871sdrn71s.fsf@gnu.org
Konrad Hinsen <konrad.hinsen@fastmail.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-zotxt): New variable.

Applied with the changes below, thanks!

Ludo’.
Toggle diff (33 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index d2fa5eb22..90b7fb2ca 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10575,3 +10575,28 @@ be changed by customizing the appropriate variables.")
"Synchronize between events in Org-mode files and a CalDAV calendar.
This code is still alpha.")
(license license:gpl3+)))
+
+(define-public emacs-zotxt
+ (package
+ (name "emacs-zotxt")
+ (version "20180518")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/egh/zotxt-emacs/archive/"
+ "23a4a9f74a658222027d53a9a83cd4bcc583ca8b"
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1qlibaciqgsva6fc7vv9krssjq00bi880396jk7llbi3c52q9n1y"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-deferred" ,emacs-deferred)
+ ("emacs-request" ,emacs-request)))
+ (home-page "https://github.com/egh/zotxt-emacs")
+ (synopsis "Integrate Emacs with Zotero")
+ (description "This package provides two integration features between Emacs
+and the Zotero research assistant: Insertion of links to Zotero items into an
+Org-mode file, and citations of Zotero items in Pandoc Markdown files.")
+ (license license:gpl3+)))
Closed
?