[PATCH 20/20] gnu: Add Add emacs-wgrep-helm.

  • Done
  • quality assurance status badge
Details
2 participants
  • Pierre Neidhardt
  • Ludovic Courtès
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
P
P
Pierre Neidhardt wrote on 22 May 2018 16:21
(address . guix-patches@gnu.org)
20180522142130.8249-1-ambrevar@gmail.com
* gnu/packages/emacs.scm (emacs-wgrep-helm): New variable.
---
gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7f502022f..ed3ab8e2b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -11065,3 +11065,29 @@ e.g. the package dependencies it requires. See function
@code{package-lint-buffer}. Checks will currently be enabled only if a
\"Package-Requires:\" or \"Package-Version:\" header is present in the file. ")
(license license:gpl3+)))
+
+(define-public emacs-wgrep-helm
+ (package
+ (name "emacs-wgrep-helm")
+ (version "20170510.1539")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://melpa.org/packages/wgrep-helm-"
+ version
+ ".el"))
+ (sha256
+ (base32
+ "0yaf976nvidwrkmflhrg2arhnrz7kn4fk2dk68082dk26ra74a0n"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-wgrep" ,emacs-wgrep)))
+ (home-page
+ "https://github.com/mhayashi1120/Emacs-wgrep/raw/master/wgrep-helm.el")
+ (synopsis
+ "Writable helm-grep-mode buffer and apply the changes to files")
+ (description
+ "@code{wgrep-helm} allows you to edit a @code{helm-grep-mode} buffer and
+apply those changes to the file buffer.")
+ (license license:gpl3+)))
--
2.17.0
L
L
Ludovic Courtès wrote on 12 Jun 2018 21:46
control message for bug #31553
(address . control@debbugs.gnu.org)
87po0vokiq.fsf@gnu.org
tags 31553 fixed
close 31553
?