Building a clean guix master checkout is impossible

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 7 years ago
(address . bug-guix@gnu.org)
20180521104509.31fe3241@scratchpost.org
Building a clean master checkout of guix is impossible right now.

I'm trying to build guix master de136f3ee7878dea139e751b7e4ca04c2542c91d
from guix master e5504f2ba0bd00a7306aada51981328b746b5f7d.

I get a lot of error messages related to unbound variables.
For good measure, I've deleted ~/.cache/guile now - but that didn't improve
matters.

guix/scripts/pack.scm

LOAD guix/scripts/pack.scm
Backtrace:
In ice-9/boot-9.scm:
142:2 19 (dynamic-wind _ _ #<procedure 1407540 at ice-9/eval.scm?>)
142:2 18 (dynamic-wind _ _ #<procedure 1409dc0 at ice-9/eval.scm?>)
In ice-9/eval.scm:
619:8 17 (_ #(#(#<directory (guix build compile) 15408c0> #<?> ?)))
619:8 16 (_ #(#(#(#(#(#(#(#<directory (guix b?> ?)) ?) ?) ?) ?) ?))
In ice-9/boot-9.scm:
152:2 15 (with-fluid* _ _ _)
2788:17 14 (resolve-interface (guix scripts pack) #:select _ #:hide ?)
2714:10 13 (_ (guix scripts pack) _ _ #:ensure _)
2982:16 12 (try-module-autoload _ _)
2312:4 11 (save-module-excursion #<procedure 6e7a030 at ice-9/boo?>)
3002:22 10 (_)
In unknown file:
9 (primitive-load-path "guix/scripts/pack" #<procedure 25?>)
In ice-9/eval.scm:
626:19 8 (_ #<directory (guix scripts pack) 7313780>)
173:39 7 (_ #<directory (guix scripts pack) 7313780>)
202:51 6 (_ #<directory (guix scripts pack) 7313780>)
202:35 5 (_ #<directory (guix scripts pack) 7313780>)
155:9 4 (_ #<directory (guix scripts pack) 7313780>)
202:35 3 (_ #<directory (guix scripts pack) 7313780>)
159:9 2 (_ #<directory (guix scripts pack) 7313780>)
223:20 1 (proc #<directory (guix scripts pack) 7313780>)
In unknown file:
0 (%resolve-variable (7 . gzip) #<directory (guix scripts?>)

ERROR: In procedure %resolve-variable:
error: gzip: unbound variable


So I deleted the references from the file.

Then I get:

gnu/packages/commencement.scm

Backtrace:
In ice-9/boot-9.scm:
222:29 19 (map1 _)
222:29 18 (map1 _)
222:29 17 (map1 _)
222:29 16 (map1 (((guix scripts graph)) ((guix monads)) ((# #)) ?))
222:29 15 (map1 (((guix monads)) ((guix gnupg)) ((gnu #)) (# ?) ?))
222:29 14 (map1 (((guix gnupg)) ((gnu packages)) ((gnu # #) # ?) ?))
222:29 13 (map1 (((gnu packages)) ((gnu packages #) #:select #) ?))
222:17 12 (map1 (((gnu packages commencement) #:select (#)) (#) ?))
2788:17 11 (resolve-interface (gnu packages commencement) #:select ?)
2714:10 10 (_ (gnu packages commencement) _ _ #:ensure _)
2982:16 9 (try-module-autoload _ _)
2312:4 8 (save-module-excursion #<procedure 78c4330 at ice-9/boo?>)
3002:22 7 (_)
In unknown file:
6 (primitive-load-path "gnu/packages/commencement" #<proc?>)
In ice-9/eval.scm:
626:19 5 (_ #<directory (gnu packages commencement) 72d8c80>)
155:9 4 (_ #<directory (gnu packages commencement) 72d8c80>)
173:55 3 (_ #(#(#(#(#<directory (gnu packages commen?> ?) ?) ?) ?))
159:9 2 (_ #(#(#(#(#<directory (gnu packages commen?> ?) ?) ?) ?))
223:20 1 (proc #(#(#(#(#<directory (gnu packages com?> ?) ?) ?) ?))
In unknown file:
0 (%resolve-variable (7 . gnu-make) #<directory (gnu pack?>)

ERROR: In procedure %resolve-variable:
error: gnu-make: unbound variable
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlsChxUACgkQ5xo1VCww
uqUOOgf/e5gmmsacTaltCldRG6moILUOtfjvChNfeto0XZJBxPM0QaBCWzEBhIzf
LzTuKzNxYPVLUkInsZUCgnp9GlOpXzIb3VrxShS5FHyllnHCSYy8+d7bqf//06LI
YgVOWb7C77LyccKjlqQbMBaJWuBKfON9eviUKTLyHdfjuQa+xFNO11LsqFhpZ0n5
7ZAR0QRY60ZJfgOsd7UqRySj/ZCWcYgaP/G981PmZ0Hprgea48o72M8agFkDI2cN
vWFvPE83ttP325wNrKHWT1cClLGkskrrfwH8K6CzumEQgD3BrP/GUzllJnmbaoNu
CmR8PaaIhhgH8PViFkXbZCFTPObctQ==
=EeLl
-----END PGP SIGNATURE-----


Danny Milosavljevic wrote 7 years ago
(address . 31543-done@debbugs.gnu.org)
20180521113451.3baeb5c6@scratchpost.org
My bad, I had one tiny local change. Sorry.

This was caused by me changing gnu/packages/libreoffice.scm libreoffice to use
glib-or-gtk-build-system without adding #:use-module (guix build-system glib-or-gtk).

The error message could be better :P

And it is indeed better if it built all the other stuff before.

To get the bad error message:

(1) Change gnu/packages/libreoffice.scm libreoffice to use glib-or-gtk-build-system
(2) Invoke "make clean"
(3) Invoke "make"
(4) Witness error message about "gzip".
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlsCkrsACgkQ5xo1VCww
uqXEKwf+Nc/rWkaQimDuYFHkWXzHZQLRRfQgme3OnwwaGRD7suVlvOGjgl2LQfts
SoTWESxo2R11p+f0Ys9XCfnO+esb6+5wuRkMKEDFLe18T5JMTQSV6vlhdd9Anm/Q
Dr2cA841mBaZyLQPCZrn9vexCBPZFWedtQRHlMEnGad9FjkBKpE9EdfswKLkUIUz
K41QVEfwQTwADJbugAeVZNpA9lkhpRwWVyUJPy084ZqK126iCYFL81lE6TqsaeWP
tgPZxiwVWWDd5BnHj2XE/pPyGWBi5y8R/54PcrGt3HpwqKlWGKzMmkeVAtHxYKqh
YkmW+4TLS8oMIhlz++s0095tOnW1tw==
=AQSr
-----END PGP SIGNATURE-----


Closed
Ludovic Courtès wrote 7 years ago
(address . 31543@debbugs.gnu.org)(address . dannym@scratchpost.org)
87fu2izh3j.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (2 lines)
> My bad, I had one tiny local change. Sorry.

Cool, better this way. :-)

Toggle quote (5 lines)
> This was caused by me changing gnu/packages/libreoffice.scm libreoffice to use
> glib-or-gtk-build-system without adding #:use-module (guix build-system glib-or-gtk).
>
> The error message could be better :P

Yeah. :-/

Ludo'.
?
Your comment

This issue is archived.

To comment on this conversation send an email to 31543@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 31543
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help