[PATCH 1/1] system: Add u-boot-pine64-plus installer.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 7 years ago
(address . guix-patches@gnu.org)
87sh6qszbq.fsf@aikidev.net
system: Add u-boot-pine64-plus installer.

* gnu/bootloader/u-boot.scm (u-boot-pine64-plus-bootloader):
New exported variable.
* gnu/system/install.scm (pine64-plus-installation-os):
New exported variable.
---
gnu/bootloader/u-boot.scm | 20 ++++++++++++++++++++
gnu/system/install.scm | 6 ++++++
2 files changed, 26 insertions(+)

Toggle diff (75 lines)
diff --git a/gnu/bootloader/u-boot.scm b/gnu/bootloader/u-boot.scm
index bc8f98f32..ea0f67b3c 100644
--- a/gnu/bootloader/u-boot.scm
+++ b/gnu/bootloader/u-boot.scm
@@ -36,6 +36,7 @@
u-boot-mx6cuboxi-bootloader
u-boot-nintendo-nes-classic-edition-bootloader
u-boot-novena-bootloader
+ u-boot-pine64-plus-bootloader
u-boot-wandboard-bootloader))
(define install-u-boot
@@ -65,6 +66,15 @@
(write-file-on-device u-boot (stat:size (stat u-boot))
device (* 8 1024)))))
+(define install-allwinner64-u-boot
+ #~(lambda (bootloader device mount-point)
+ (let ((spl (string-append bootloader "/libexec/spl/sunxi-spl.bin"))
+ (u-boot (string-append bootloader "/libexec/u-boot.itb")))
+ (write-file-on-device spl (stat:size (stat spl))
+ device (* 8 1024))
+ (write-file-on-device u-boot (stat:size (stat u-boot))
+ device (* 40 1024)))))
+
(define install-imx-u-boot
#~(lambda (bootloader device mount-point)
(let ((spl (string-append bootloader "/libexec/SPL"))
@@ -98,6 +108,11 @@
(inherit u-boot-bootloader)
(installer install-allwinner-u-boot)))
+(define u-boot-allwinner64-bootloader
+ (bootloader
+ (inherit u-boot-bootloader)
+ (installer install-allwinner64-u-boot)))
+
(define u-boot-imx-bootloader
(bootloader
(inherit u-boot-bootloader)
@@ -142,3 +157,8 @@
(bootloader
(inherit u-boot-imx-bootloader)
(package u-boot-novena)))
+
+(define u-boot-pine64-plus-bootloader
+ (bootloader
+ (inherit u-boot-allwinner64-bootloader)
+ (package u-boot-pine64-plus)))
diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index a2917e485..3efff915a 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -52,6 +52,7 @@
mx6cuboxi-installation-os
nintendo-nes-classic-edition-installation-os
novena-installation-os
+ pine64-plus-installation-os
wandboard-installation-os))
;;; Commentary:
@@ -447,6 +448,11 @@ The bootloader BOOTLOADER is installed to BOOTLOADER-TARGET."
"/dev/mmcblk0" ; SD card (solder it yourself)
"ttyS0"))
+(define pine64-plus-installation-os
+ (embedded-installation-os u-boot-pine64-plus-bootloader
+ "/dev/mmcblk0" ; SD card storage
+ "ttyS0"))
+
(define wandboard-installation-os
(embedded-installation-os u-boot-wandboard-bootloader
"/dev/mmcblk0" ; SD card storage
--
2.11.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcDardHbDotegGFCHt4uC1IFLkbYFAlr9/ykACgkQt4uC1IFL
kbbOOA//X0aowhkKtnM02YIjA+2C+ACr1UyJHy4FGJgcaoG4WLmoZ2TkYaIwBrx2
sXfJzyW7l53j3MTvbjr2Du35iYrJIqq5SNfHwlUrr4bjU0NXjZ+NTsRA7iV4Yc2u
KFcGG+dQrz7FlUoA1QHfFL3GBPcHV8Yq6loRhgdyn8Pnt0SqyckD8oeZ7LfdreG+
N0IRZiDjfCg9YAGFNocByJmvMzeRZZalfeKXR5zldzS+lT/hEFL2jsBrS1UKiBWV
xU6HZhzlpb1FH/7etWDfVIdaTjKakLXa84I0x9qMzaOKpd8fR1GGcLX9DP7dHxng
cOlJUJXhKtKaoqI7U0+mL44t+9HCLQnesmjpHKF0YUtfYLKmLq2eYwHl+BzozI7t
N/Cxd9by1IHxM37h0E5F3eDl4yE1Wq06XpBjsLxH5HLTVGlhkf9uG2SmHJ5rzD/Y
0dZCAkJXm6kJKHK0RG5mUBwSXeU8+bK3QcOygAawmvRP8dqUiE55jV0fVKL3FDHm
LquvhPTmi7CAkpKoyb04YNy+MFctD8YPwbpO/Xceenb2Cl1lBNtZNKKaavI5tt18
w8Tj4ab2kDYMxfDiZd2Og03BKKS3qBBcEXDWCyPtFvWHShP1wGlj+Hnlty5v8Ul8
fCU57Tv8FuF8otYk9dxDQF99CEFLpfKNkdnDnUF2kHcR5yRGylA=
=aChC
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 7 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 31486-done@debbugs.gnu.org)
20180518202249.4a4c2572@scratchpost.org
Applied to guix master as 9f7d66656646fac3746c52216ad6061c9c0adc27. Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlr/GfkACgkQ5xo1VCww
uqXwlwf/eP6amOhXis1r4EPk8lmQ85vpdH8iE0hHRuu4kRsuWcnmCcQuTme5Kygd
LH+913/UiypZUKccuIZjbueZFYtW1VIk0jKC7mD9i0Qv2/mKnbzEigEJ3ZmYnxfV
slsLreFGiBYtVujddlhtf7oPbrliNACJoVkey1sJZrEddzNIhBinn/EmS5gBce5Y
N4Nv6oBbCGwWjdSmPjwJXXWXQeWsTsn/QbAlXaDapf2uIXUTljxxCuc88tf3pOWg
ynlL8R9ggyHY13mU6odueTt32jFt2T0gXyb+CYQ7QobnVaJ5NEezzUOHja5FGiXM
pTUCp+fxRYuzltSOseWV6+arVPHIEA==
=IpZ9
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 31486@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 31486
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help