bootloader: extlinux: Fix menu support with u-boot.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 7 years ago
(address . guix-patches@gnu.org)
87wow9vokm.fsf@aikidev.net
The following patch adds a title to the menu used with extlinux
configuration files. Without this, u-boot does not present a menu and
simply selects the first option to boot. It also just looks nicer.

live well,
vagrant
From 96133cefceb6ef41a788daa30abf2f8c8d0aaa62 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Fri, 11 May 2018 14:48:20 -0700
Subject: [PATCH] bootloader: extlinux: Fix menu support with u-boot.

* gnu/bootloader/extlinux.scm (extlinux-configuration-file): Set MENU TITLE in
generated extlinux.conf.
---
gnu/bootloader/extlinux.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/bootloader/extlinux.scm b/gnu/bootloader/extlinux.scm
index f7820a37a..8b7a95a6f 100644
--- a/gnu/bootloader/extlinux.scm
+++ b/gnu/bootloader/extlinux.scm
@@ -64,6 +64,7 @@ corresponding to old generations of the system."
(format port "# This file was generated from your GuixSD configuration. Any changes
# will be lost upon reconfiguration.
UI menu.c32
+MENU TITLE GuixSD Boot Options
PROMPT ~a
TIMEOUT ~a~%"
(if (> timeout 0) 1 0)
--
2.11.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcDardHbDotegGFCHt4uC1IFLkbYFAlr2EtkACgkQt4uC1IFL
kbbXQQ/+Ngsw5BZQGROS88vZlVHBqOdqGpZlsAnOP/o23OXyxLrbuwTslsrc8xY3
cb0qdWHCfpZevHP77VWakle0g3/j9BiO49veAPcMNLgwd6mysi1jciPmAcV/DbSN
QAIi+lLMPRTgBtb3EArSHVdvi4mSbNhRQ68oop3j5oYcDRnUNSz05GU8ge96PXXP
vHlcY1tRvyc12TQS4sg5+iNY+6Hy6OJ0VC1g0YW4HbtXq3s2A/Fo+te+8UVWwzA0
rZPWEwuvsDkD5Szo+Njob92810cKLOGtEbbJV7n+3Hcn8GdWy8QAtvmBaTrCIhXv
Wx1Y5LbBeiBlsOR+NMBVRW9WbNqBwmgIlDv0tsRpQHzhrWAxNbYXCf1Z4FvkYlLF
4on5oX4bkpmZdwfYaIXY46O/R81IgZ6CwL9TkPjTDgwAEqxohy7VjEaaYoZM2vL9
3648f1CehNgTCDadnvzx59QYX454TR6LrgpKv1TxjMLhoBwuab7ovaZ94Gfp94bn
i/FVQR/8+Mj/oCQ0oTZuIEXFVqJ8mzPV86/bTkDnRAz0JD8b0hYhmW+wP32+5uU9
2sZgO+/HsE/hjbGV4X1INuo9BwV1TZ5WAt1Lf853CTDjNHg69n3LnveHCcnEOUJa
Xw9cgRxHs1cUHPaRR3wv3nffobzd+FJViQUPzfBiRYv6X3VM2DM=
=OmHl
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 7 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 31425-done@debbugs.gnu.org)
20180512093849.5fbf1bd9@scratchpost.org
Pushed to master as afca98ff01e036594778ab687f472ef5d759f653.

Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlr2mgkACgkQ5xo1VCww
uqXT5QgAljdqKdo9PNhpyzYeb3ux6doXh8ucwbWIKEIqGq8wns8LN6RqGS4v/KN0
281asnVyhAZ9hLeDJxlZCOLXYMjZ3vVefC7Jv/Sb8QukCsuf9OVy5aznfKJpV3qc
bMZT16oXDMVUuyXuXkWM8UlQfhER5j7kp4spbZFYCoKjBMwTIBK8Dwv3jdqPGTYo
L2pIo+ZzVnhlK5RVGyHhGIyYA+FHOHDbMlgKmgFCZrlj3IXSJ31WOUYpr/XFCdiL
hzVVxe1RiwirroI0eYzC+KrH0iTbdFDZpn0w4Ja/i1mgmYwEizFu8F42zoZ6tOL0
qujam9gM3wd4GUawJRtOIGoktlTxSw==
=ovvH
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 31425@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 31425
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help