Vagrant Cascadian wrote 7 years ago
(address . bug-guix@gnu.org)
I've been unable to use my gnuk usb smartcard token with gnupg on
GuixSD, and it appears this is because scdaemon is built without libusb
support:
$ gpg --card-status
gpg: selecting openpgp failed: No such device
gpg: OpenPGP card not available: No such device
Attached is a patch that gets scdaemon working for me and a gnuk...
Unfortunately, enabling libusb causes one of the tets to hang
indefinitely:
PASS: tests/openpgp/decrypt-session-key.scm
Checking unwrapping the encryption.
> encsig-2-keys-3 encsig-2-keys-4 <
PASS: tests/openpgp/decrypt-unwrap-verify.scm
Checking signing with the default hash algorithm
>
So far, I've only been able to get it to work by disabling the
tests... so it's obviously not a good idea to enable without further
troubleshooting.
Another option might be to use pcsc-lite and ccid, but I had even less
luck getting that to work.
live well,
vagrant
Toggle diff (38 lines)
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index f397482ab..0e9e72784 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -39,6 +39,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages crypto)
#:use-module (gnu packages emacs)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages openldap)
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
@@ -232,6 +233,7 @@ compatible to GNU Pth.")
("libgcrypt" ,libgcrypt)
("libgpg-error" ,libgpg-error)
("libksba" ,libksba)
+ ("libusb" ,libusb)
("npth" ,npth)
("openldap" ,openldap)
("pcsc-lite" ,pcsc-lite)
@@ -246,12 +248,17 @@ compatible to GNU Pth.")
"--enable-all-tests")
#:phases
(modify-phases %standard-phases
+ ;; (delete 'check)
(add-before 'configure 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "scd/scdaemon.c"
(("\"(libpcsclite\\.so[^\"]*)\"" _ name)
(string-append "\"" (assoc-ref inputs "pcsc-lite")
"/lib/" name "\"")))
+ (substitute* "configure"
+ (("/usr/include/libusb-1.0")
+ (string-append (assoc-ref inputs "libusb")
+ "/include/libusb-1.0")))
#t))
(add-after 'build 'patch-scheme-tests
(lambda _
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCgAdFiEEcDardHbDotegGFCHt4uC1IFLkbYFAlro6jAACgkQt4uC1IFL
kbYVgQ/+JinOMHnfeUUUIy3nyjMsikXQ6FpcM9oM4aOL4OsemP6RENrZA4Pg7pUF
bWCfxI6F6rkYasaUjRY7uqfnrhhRi+UOCUSVWnGZ5uO6ohw4MlofQdon1pbDAf9T
Sqt+z3yaoHPHdAjTaYL1LVQYx0vK1+eB1Dd3fWBDSLioedZMFZqlPO0WH4PwcG3W
Bm2m1XCHFM+xPwYYdb7JutZIctkYy2EDwFohN5NmTsTJtyqiUBGSz/tdY2mOiE3e
cB0nPCo8rAHW7/VP7UtMhdA40Q3MtbqUDXbEhneE6aFNn1k/3eyYDGD+rxwb9htc
Azab1+MGPHNiV7sABlWL4a7JEyVrlV7YRGfpzwAzY02YelUSxBqYv/lDPCGS84hk
nQHq28gU1n+PU1uwxTJyuF3DxXkpHyP6bU4K/dOeWArnbc7J1RyeSU+9F6HzYp9X
VWp6yGR8oATCnRjtUUnXP9sPcI6VnJ4Z60zO+kRcqMCbsqWKIKD5vx2eV4XD2JyW
SjYoILqEIumqcAMrPa3CkkQUR0s4FYx4Y5p+DoPNqHwasa+YEnKW6zBH69u5hypY
RpO3eJ2tFNCXJIvqTim9+2kVpqaXsLppWshDXSGZnnBLcKlVNGJ48TVrhYySFWNe
z0i2bFqKe/Ohh5VIccphN64DjrFYcl27Cct6Cl0Smjm7+8LmekY=
=flRI
-----END PGP SIGNATURE-----