(address . guix-patches@gnu.org)
Hi Guix,
This patch adds MAT, the Metadata Anonymisation Toolkit from Boum. I've
successfully used its CLI tool to purge metadata from JPEG image files;
I verified using exiftool that it works for this purpose. However, not
all of its features work (see the TODO for details), and more
importantly, the website says people shouldn't use it. For these
reasons, I'm not sure if we should add it, so I'd like to ask for your
opinion.
The author state on their website:
Current status
The MAT maintenance and development is currently on hold, mostly for
health reasons. I might go back to it at some point in the future.
The current version might have bugs, and doesn't work on Python3: Please
avoid using it.
However, packages exist for some distributions. For example, here's a
MAT package for Debian:
And like I said, the CLI tool does seem to work.
Should we refrain from adding this package simply because the author is
not maintaining it any more? I'm inclined to say "no", but one also has
to consider whether it is a a good idea to encourage people to use an
unmaintained tool for protecting their privacy/anonymity. I'm not sure.
In addition, I notice that the license is GPL 2, but it seems the author
did not specify whether "any later version" can be used. Therefore, I
have listed this as gpl2, instead of gpl2+.
What do you think?
--
Chris
From c30a26364fdf919deb9bc6bd907b75de58a17a7b Mon Sep 17 00:00:00 2001
From: Chris Marusich <cmmarusich@gmail.com>
Date: Sat, 28 Apr 2018 14:03:47 -0700
Subject: [PATCH] gnu: Add mat.
* gnu/packages/photo.scm (mat): New variable.
---
gnu/packages/photo.scm | 52 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)
Toggle diff (76 lines)
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 2c0c2313f..a6380cc63 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -26,6 +26,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
+ #:use-module (guix build-system python)
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -52,6 +53,7 @@
#:use-module (gnu packages llvm)
#:use-module (gnu packages man)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages music)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
@@ -521,3 +523,53 @@ workflow by facilitating the handling of large numbers of images. Most raw
formats are supported, including Pentax Pixel Shift, Canon Dual-Pixel, and those
from Foveon and X-Trans sensors.")
(license license:gpl3+)))
+
+;; TODO: Add inputs for PDF support (e.g., Poppler, python-pdfrw).
+;; TODO: Add inputs for GUI support (e.g., gi).
+;; TODO: Fix some hard-coded paths. For example, get_datafile_path embeds
+;; paths like "/usr/local/share/mat", which we should probably rewrite so that
+;; they point to mat's output directory in the store. This specific example
+;; causes "mat --list" to fail with an exception.
+(define-public python2-mat
+ (package
+ (name "python2-mat")
+ (version "0.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://mat.boum.org/files/mat-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1faiiq7cjspafjjf4kmm7bbn8m506qgcijbizpgdvlaaapdyg0h7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:use-setuptools? #f))
+ (propagated-inputs
+ `(("python2-pycairo" ,python2-pycairo)
+ ("python2-mutagen" ,python2-mutagen)
+ ("perl-image-exiftool" ,perl-image-exiftool)))
+ (native-inputs
+ `(("python2-distutils-extra" ,python2-distutils-extra)
+ ("intltool" ,intltool)))
+ (synopsis "Anonymize/remove metadata from files")
+ (description
+ "MAT (Metadata Anonymisation Toolkit) is a toolbox composed of a GUI
+application, a CLI application and a library, to anonymize/remove metadata
+from files. It supports the following file formats:
+
+@itemize @bullet
+@item Portable Network Graphics (.png)
+@item Joint Photographic Experts Group (.jpg, .jpeg, etc.)
+@item Tagged Image File Format (.tif, tiff, etc.)
+@item Open Documents (.odt, .odx, .ods, etc.)
+@item Office OpenXml (.docx, .pptx, .xlsx, etc.)
+@item Portable Document Fileformat (.pdf)
+@item Tape Archives (.tar, .tar.bz2, etc.)
+@item Moving Picture Experts Group (MPEG) (.mp3, .mp2, .mp1, etc.)
+@item Ogg Vorbis (.ogg, etc.)
+@item Free Lossless Audio Codec (.flac)
+@item Torrent (.torrent)
+@end itemize")
+ (home-page "https://mat.boum.org")
+ (license license:gpl2)))
--
2.17.0
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCAAdFiEEy/WXVcvn5+/vGD+x3UCaFdgiRp0FAlrk6cUACgkQ3UCaFdgi
Rp0lfg//b0adAXOEapCB73mMutQNTgdSHZ/Mbume4pJPA1DOdL8t4S8u5aGA2WQP
LtI8M0A6tkmQ6BSo2/0+6OTT+MCHxSB5mYsIOzUfpzW+kJz7aspP8OqvCoFHQjfs
1BWSUYLein9Ah/GlY5krDTEAGdpaqVzQP3ue/6oNRU8H1ehGoG+0y/ibDYV2Kexb
nGv/B3vnBPkW7c/9Ni5tZC187sulgKl4Y23tCysFP1yGHvBFV85S7vYB/1xh8W8T
G7BPpPwTRGGmUj5nkxQq/Xkv375JBeFLDb6LKyZnW7TKNb2GWVbSXK2YSmWvc7yd
yqTE7fOMC/NXL7sjkSHLHE+VxQspUb4qSrlQqRkSNf5Md6VRHrDJe4e/mK6cA2s2
8Fts4scmylSJdgRn/8BmEKws3sTZSTU1iH7pH/s66usfjkv/RAWZm7nZv6GijcFx
w3bAJElt4i6y+CC//lsGVJrF7mFJGJ0MCynDBg45hK9hLTilW8QrwNl1etH8j5F1
8sMV3a7JZok6kfHL0HUBXxhNNkE4o3NccK7QxID0Xnl0P0l50ObCjcI9QA4TyZsX
CuYQrij0Un3vWzCwZxzojpK9QwN/y7HlbxjaQV6V1CtW7zMBmuVVLxFG5xyhRKsH
vZHP3joaQvJQ/SpjHh3dkAD+eLXR3RkA/s6fI2zB+g7P1rj8bjI=
=oMOX
-----END PGP SIGNATURE-----