[PATCH] gnu: Add Ranger.

  • Done
  • quality assurance status badge
Details
2 participants
  • Eric Bavier
  • Ludovic Courtès
Owner
unassigned
Submitted by
Eric Bavier
Severity
normal

Debbugs page

Eric Bavier wrote 7 years ago
(address . guix-patches@gnu.org)
1758300649.33991901.1524614953172.JavaMail.zimbra@centurylink.net
Hello Guix,

I think this package works, but I'm not much of a ranger user, so if
someone would like to give it a test, that would be appreciated.

Also, suggestions for a better module location are appreciated. :)

--
`~Eric


From 03abb95c7e551ea45d0742bf72cb78e5f0ce210e Mon Sep 17 00:00:00 2001
From: Eric Bavier <ericbavier@centurylink.net>
Date: Tue, 24 Apr 2018 18:44:38 -0500
Subject: [PATCH] gnu: Add Ranger.
To: guix-patches@gnu.org

From: Eric Bavier <bavier@member.fsf.org>

* gnu/packages/disk.scm (ranger): New variable.
---
gnu/packages/disk.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 595000bf8..a36273a01 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
+;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,6 +36,7 @@
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages base)
+ #:use-module (gnu packages check)
#:use-module (gnu packages databases)
#:use-module (gnu packages docbook)
#:use-module (gnu packages gettext)
@@ -502,3 +504,32 @@ your data as it changes, without having to
re-checksum unchanged data.
Duperemove can also take input from the @command{fdupes} program.")
(license license:gpl2)))
+
+(define-public ranger
+ (package
+ (name "ranger")
+ (version "1.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ranger.github.io/"
+ "ranger-" version ".tar.gz"))
+ (sha256
+ (base32
+
"1lnzkrxcnlwnyi3z0v8ybyp8d5rm26qm35rr68kbs2lbs06inha0"))))
+ (build-system python-build-system)
+ (native-inputs ;for tests
+ `(("python-pytest" ,python-pytest)
+ ("python-pylint" ,python-pylint)
+ ("python-flake8" ,python-flake8)
+ ("which" ,which)))
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _ (invoke "make" "test"))))))
+ (home-page "https://ranger.github.io/")
+ (synopsis "Console file manager")
+ (description "@code{ranger} is a console file manager with VI key
+bindings. It provides a minimalistic and nice curses interface with a
view on +the directory hierarchy. It ships with @code{rifle}, a file
launcher that is +good at automatically finding out which program to
use for what file type.")
+ (license license:gpl3)))
--
2.17.0
Ludovic Courtès wrote 7 years ago
(name . Eric Bavier)(address . ericbavier@centurylink.net)(address . 31252@debbugs.gnu.org)
87po2nngbw.fsf@gnu.org
Eric Bavier <ericbavier@centurylink.net> skribis:

Toggle quote (10 lines)
> From 03abb95c7e551ea45d0742bf72cb78e5f0ce210e Mon Sep 17 00:00:00 2001
> From: Eric Bavier <ericbavier@centurylink.net>
> Date: Tue, 24 Apr 2018 18:44:38 -0500
> Subject: [PATCH] gnu: Add Ranger.
> To: guix-patches@gnu.org
>
> From: Eric Bavier <bavier@member.fsf.org>
>
> * gnu/packages/disk.scm (ranger): New variable.

[...]

Toggle quote (13 lines)
> +(define-public ranger
> + (package
> + (name "ranger")
> + (version "1.9.1")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://ranger.github.io/"
> + "ranger-" version ".tar.gz"))
> + (sha256
> + (base32
> +
> "1lnzkrxcnlwnyi3z0v8ybyp8d5rm26qm35rr68kbs2lbs06inha0"))))

Patch was mangled. :-)

Toggle quote (11 lines)
> + (build-system python-build-system)
> + (native-inputs ;for tests
> + `(("python-pytest" ,python-pytest)
> + ("python-pylint" ,python-pylint)
> + ("python-flake8" ,python-flake8)
> + ("which" ,which)))
> + (arguments
> + '(#:phases (modify-phases %standard-phases
> + (replace 'check
> + (lambda _ (invoke "make" "test"))))))

You can use #:test-target "test" instead.

Toggle quote (4 lines)
> + (synopsis "Console file manager")
> + (description "@code{ranger} is a console file manager with VI key

Nitpick: “Ranger” (or “ranger”?) and “Vi”.

I haven’t tried using it, but otherwise LGTM. Thanks!

Ludo’.
Eric Bavier wrote 7 years ago
(address . 31252-done@debbugs.gnu.org)
20180426211113.025b02cb@centurylink.net
On Wed, 25 Apr 2018 23:09:39 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (17 lines)
> Eric Bavier <ericbavier@centurylink.net> skribis:
>
> > + (arguments
> > + '(#:phases (modify-phases %standard-phases
> > + (replace 'check
> > + (lambda _ (invoke "make" "test"))))))
>
> You can use #:test-target "test" instead.
>
> > + (home-page "https://ranger.github.io/")
> > + (synopsis "Console file manager")
> > + (description "@code{ranger} is a console file manager with VI key
>
> Nitpick: “Ranger” (or “ranger”?) and “Vi”.
>
> I haven’t tried using it, but otherwise LGTM. Thanks!

Thanks for the review.

Pushed in 834b0b9a5ca7ebd2cd3c1b2fe8dcb99e5e2f0841 and
adfc742c420f34ecf925ea00d49204f9863bce33 (forgot to apply fixes before pushing ... oops).

`~Eric
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlrihsEACgkQ/XPKxxnT
JWYrpBAAhiL6ANcpHhC9nRCp4LIdB3IVF2p/hpCABRexJO5BNEFbaR+AYI1a1Hvg
xFPjysW9FwjePhZCE+MRhmP1L6hTssBSnRZuLWLxnDt9hM4jHzhDzeYawLYwWjZc
kZQnJ0J31xxFzIR5/FEyS4pLcDJOfFRYg5Os2Oa0a21ZvT2qhdDAV+bJrKS88fyE
ldiZafCC2KCaR4HvhU0yjST651b6nfc5jTsIo4tMBecBVRwZm0WRsDgRZjEzQG29
8/wGfDQu0npe2eKs+W+MXeNRuypv2mooIiZtNWwdgZ2Oblnif44CyE/w9hsHKJrJ
+ndlAYfXNLOWAZjcL0hxk62RqfRBeGHygKoDw3YuDOQ+IVwqxUUsoqwAfCKtBJwu
O8Cla4YWW7/8MXmqJOtVEzuK3I4YMB5yKXCdjYvk/SoeZPWNzHpQPWSE92ScFE2u
Sz+Yd5JI2hFHCqqg+orQ+0CWWlKBQyDaY9aU7t03VGOKK6xiVa1cM7b+mC4QL2EG
Wz9YfEp5eOaPqdaY2DZigtt7ZsNbYc5YMTj2DY95nPQUGb/v8W4/4dfLdz+k+G2+
2Az51LqIXj79dcCB0BH1BUzXkkgWKcqHKf9/DIw5JnXPLlDSFAinjk9MUQjl2UMd
j1zUA2ZvSJug0JXnklSCoe+hwI58UGYFM7qx6Q2QPnWZ5+01VFY=
=bCkd
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 31252@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 31252
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help