[PATCH] gnu: Add guile-curl.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Roel Janssen
Owner
unassigned
Submitted by
Roel Janssen
Severity
normal
R
R
Roel Janssen wrote on 16 Apr 2018 16:58
(name . guix-patches)(address . guix-patches@gnu.org)
87sh7v19mq.fsf@gnu.org
Dear Guix,

I'd like to add guile-curl with the attached patch.

Kind regards,
Roel Janssen
From fc9ea6f787e63d6d2405318ed8df4d965867e539 Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Mon, 16 Apr 2018 16:55:40 +0200
Subject: [PATCH] gnu: Add guile-curl.

* gnu/packages/curl.scm (guile-curl): New variable.
---
gnu/packages/curl.scm | 51 +++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (75 lines)
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index fbf177d9d..216d47cb7 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,6 +37,7 @@
#:use-module (gnu packages golang)
#:use-module (gnu packages groff)
#:use-module (gnu packages gsasl)
+ #:use-module (gnu packages guile)
#:use-module (gnu packages libidn)
#:use-module (gnu packages openldap)
#:use-module (gnu packages perl)
@@ -193,3 +195,52 @@ mechanisms particularly within the HTTP(S) realm are to be expected. kurly does
not offer a replacement for libcurl.")
(home-page "https://github.com/davidjpeacock/kurly")
(license license:asl2.0)))
+
+(define-public guile-curl
+ (package
+ (name "guile-curl")
+ (version "0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.lonelycactus.com/tarball/guile-curl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1846rxgc0ylh8768lr79irc7nwjichzb7qb7lzs2k42m0i53sc46"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags (list (string-append
+ "--with-guilesitedir="
+ (assoc-ref %outputs "out")
+ "/share/guile/site/2.2")
+ (string-append
+ "-with-guileextensiondir="
+ (assoc-ref %outputs "out")
+ "/lib/guile/2.2/extensions"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'patch-extension-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (curl.scm (string-append
+ out "/share/guile/site/2.2/curl.scm"))
+ (curl.go (string-append
+ out "/lib/guile/2.2/site-ccache/curl.go"))
+ (ext (string-append out "/lib/guile/2.2/"
+ "extensions/libguile-curl")))
+ (substitute* curl.scm (("libguile-curl") ext))
+ ;; The build system does not actually compile the Scheme module.
+ ;; So we can compile it and put it in the right place in one go.
+ (system* "guild" "compile" curl.scm "-o" curl.go))
+ #t)))))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("curl" ,curl)
+ ("guile" ,guile-2.2)))
+ (home-page "http://www.lonelycactus.com/guile-curl.html")
+ (synopsis "Curl bindings for Guile")
+ (description "@code{guile-curl} is a project that has procedures that allow
+Guile to do client-side URL transfers, like requesting documents from HTTP or
+FTP servers. It is based on the curl library.")
+ (license license:gpl3+)))
--
2.16.3
L
L
Ludovic Courtès wrote on 18 Apr 2018 22:53
(name . Roel Janssen)(address . roel@gnu.org)(address . 31181@debbugs.gnu.org)
87tvs8tex0.fsf@gnu.org
Roel Janssen <roel@gnu.org> skribis:

Toggle quote (7 lines)
> From fc9ea6f787e63d6d2405318ed8df4d965867e539 Mon Sep 17 00:00:00 2001
> From: Roel Janssen <roel@gnu.org>
> Date: Mon, 16 Apr 2018 16:55:40 +0200
> Subject: [PATCH] gnu: Add guile-curl.
>
> * gnu/packages/curl.scm (guile-curl): New variable.

LGTM, thanks, Roel!

Ludo’.
R
R
Roel Janssen wrote on 18 Apr 2018 23:03
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 31181@debbugs.gnu.org)
87wox4fcr0.fsf@gnu.org
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (11 lines)
> Roel Janssen <roel@gnu.org> skribis:
>
>> From fc9ea6f787e63d6d2405318ed8df4d965867e539 Mon Sep 17 00:00:00 2001
>> From: Roel Janssen <roel@gnu.org>
>> Date: Mon, 16 Apr 2018 16:55:40 +0200
>> Subject: [PATCH] gnu: Add guile-curl.
>>
>> * gnu/packages/curl.scm (guile-curl): New variable.
>
> LGTM, thanks, Roel!

Pushed in 5e3010a2a.

Thanks!

Kind regards,
Roel Janssen
R
R
Roel Janssen wrote on 18 Apr 2018 23:12
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 31181-done@debbugs.gnu.org)
87vacofcck.fsf@gnu.org
Roel Janssen <roel@gnu.org> writes:

Toggle quote (16 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Roel Janssen <roel@gnu.org> skribis:
>>
>>> From fc9ea6f787e63d6d2405318ed8df4d965867e539 Mon Sep 17 00:00:00 2001
>>> From: Roel Janssen <roel@gnu.org>
>>> Date: Mon, 16 Apr 2018 16:55:40 +0200
>>> Subject: [PATCH] gnu: Add guile-curl.
>>>
>>> * gnu/packages/curl.scm (guile-curl): New variable.
>>
>> LGTM, thanks, Roel!
>
> Pushed in 5e3010a2a.
>

And marked as done.

Kind regards,
Roel Janssen
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 31181@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 31181
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch