(address . guix-patches@gnu.org)(name . Tomáš ?ech)(address . sleep_walker@gnu.org)
* gnu/packages/syncthing.scm (go-golang-org-x-crypto-ssh-terminal): New
variable.
---
gnu/packages/syncthing.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
Toggle diff (59 lines)
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 4c607600d..a6cff9759 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Petter <petter@mykolab.ch>
;;; Copyright © 2016, 2017, 2018 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018 Tomáš ?ech <sleep_walker@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1200,6 +1201,44 @@ Tiny Encryption Algorithm (XTEA) block cipher.")
(home-page "https://go.googlesource.com/crypto/")
(license bsd-3))))
+(define-public go-golang-org-x-crypto-ssh-terminal
+ (let ((commit "95a4943f35d008beabde8c11e5075a1b714e6419")
+ (revision "1"))
+ (package
+ (name "go-golang-org-x-crypto-ssh-terminal")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/crypto")
+ (commit commit)))
+ (file-name (string-append "go.googlesource.com-crypto-"
+ version "-checkout"))
+ (sha256
+ (base32
+ "0bkm0jx9mxmi1liabb9c04kf765n7d0062zdp3zmvzyamsq00lcx"))))
+ (build-system go-build-system)
+ (inputs
+ `(("go-golang-org-x-sys-unix" ,go-golang-org-x-sys-unix)))
+ (arguments
+ `(#:import-path "golang.org/x/crypto/ssh/terminal"
+ #:unpack-path "golang.org/x/crypto"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (map (lambda (file)
+ (make-file-writable file))
+ (find-files
+ (string-append (assoc-ref outputs "out")
+ "/src/golang.org/x/crypto/ed25519/testdata")
+ ".*\\.gz$"))
+ #t)))))
+ (synopsis "TBD")
+ (description "TBD")
+ (home-page "https://go.googlesource.com/crypto/")
+ (license bsd-3))))
+
(define* (go-golang-org-x-net-union #:optional
(packages (list go-golang-org-x-net-ipv4
go-golang-org-x-net-bpf
--
2.16.3