[PATCH] gnu: Add go-golang-org-x-crypto-ssh-terminal.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Ludovic Courtès
  • Tomáš ?ech
Owner
unassigned
Submitted by
Tomáš ?ech
Severity
normal
T
T
Tomáš ?ech wrote on 16 Apr 2018 11:11
(address . guix-patches@gnu.org)(name . Tomáš ?ech)(address . sleep_walker@gnu.org)
20180416091120.15800-1-sleep_walker@gnu.org
* gnu/packages/syncthing.scm (go-golang-org-x-crypto-ssh-terminal): New
variable.
---
gnu/packages/syncthing.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 4c607600d..a6cff9759 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Petter <petter@mykolab.ch>
;;; Copyright © 2016, 2017, 2018 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018 Tomáš ?ech <sleep_walker@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1200,6 +1201,44 @@ Tiny Encryption Algorithm (XTEA) block cipher.")
(home-page "https://go.googlesource.com/crypto/")
(license bsd-3))))
+(define-public go-golang-org-x-crypto-ssh-terminal
+ (let ((commit "95a4943f35d008beabde8c11e5075a1b714e6419")
+ (revision "1"))
+ (package
+ (name "go-golang-org-x-crypto-ssh-terminal")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/crypto")
+ (commit commit)))
+ (file-name (string-append "go.googlesource.com-crypto-"
+ version "-checkout"))
+ (sha256
+ (base32
+ "0bkm0jx9mxmi1liabb9c04kf765n7d0062zdp3zmvzyamsq00lcx"))))
+ (build-system go-build-system)
+ (inputs
+ `(("go-golang-org-x-sys-unix" ,go-golang-org-x-sys-unix)))
+ (arguments
+ `(#:import-path "golang.org/x/crypto/ssh/terminal"
+ #:unpack-path "golang.org/x/crypto"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (map (lambda (file)
+ (make-file-writable file))
+ (find-files
+ (string-append (assoc-ref outputs "out")
+ "/src/golang.org/x/crypto/ed25519/testdata")
+ ".*\\.gz$"))
+ #t)))))
+ (synopsis "TBD")
+ (description "TBD")
+ (home-page "https://go.googlesource.com/crypto/")
+ (license bsd-3))))
+
(define* (go-golang-org-x-net-union #:optional
(packages (list go-golang-org-x-net-ipv4
go-golang-org-x-net-bpf
--
2.16.3
L
L
Leo Famulari wrote on 17 Apr 2018 21:52
(name . Tomáš ?ech)(address . sleep_walker@gnu.org)(address . 31174@debbugs.gnu.org)
20180417195214.GA22258@jasmine.lan
On Mon, Apr 16, 2018 at 11:11:20AM +0200, Tomáš ?ech wrote:
Toggle quote (3 lines)
> * gnu/packages/syncthing.scm (go-golang-org-x-crypto-ssh-terminal): New
> variable.

Thanks!

In general, LGTM.

Did you put this in the Syncthing module because that's where the
rest of the Go 'x' libraries live? If so, I'd rather move the full 'x'
suite to (gnu packages golang), since they are not specific to Syncthing
and are used by nearly every Go application. I can handle this move.

Toggle quote (3 lines)
> + (synopsis "TBD")
> + (description "TBD")

This is the last missing bit :)
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlrWUGsACgkQJkb6MLrK
fwh7uhAApci6704sekU45kCXDnaeO5ogg9kZgoXq3ezumJtXr8U+LeZlVDkaZ3vO
c1qm6TsYPN23Eml5Joug8x6aj6y0moDHI6WD+f0S/VgDRnybUm1LcuUPx2WvtbI3
PkY9HDmSx0UlhnhCqHMG/G8Vg4RcB6j5pHN7lvNJ9AxDOiPIaNfhq0znPJted3iT
riyo8LIEj5VnuaiBhptRn6EYiOIvhismVZew6qJGEKNqfwuBX1h2qymF9DgFck33
IP1Vhq594H0dqjORe83J+AIwwQmx0bC05p0iWIpySvxk1HOzTC09OgjrgZ/G8942
YVmjR+UeQOCO8+CNXCzbHE2C1Pst4WH3WwunLykyrN0KUE+SIVvGDAzCKapOerHu
Te/kdLdb+CU5k84Wob061fMqSr7uR9oPGKgSAY54PhNfwjyb9+YClDCoVL8DgNDy
me4AaNdSQwimIiLq4YFmioRnVFIcCiYg0z8IB/dhb/NQdAiM7QjQFMH631daCJd8
wngNiUidArusUrbeZxRkmvguybmiOP1j4n7CHXQ2tdPL/gU8me/uLzFMEV1mheyX
llXvwnYhknGQRqSwBoU8Oxjp0LzkReuQbqJBgpQMosIUkEDxC92obE7GioZL6UkH
FUlMiQ7k10DEsjDw0txZ8ua+sFaRcMWDKu8hneCGQoatDdlGDik=
=8h9t
-----END PGP SIGNATURE-----


T
T
Tomáš ?ech wrote on 17 Apr 2018 22:07
(name . Leo Famulari)(address . leo@famulari.name)(address . 31174@debbugs.gnu.org)
20180417200759.bni372jceliqavhu@doom
On Tue, Apr 17, 2018 at 03:52:14PM -0400, Leo Famulari wrote:
Toggle quote (13 lines)
>On Mon, Apr 16, 2018 at 11:11:20AM +0200, Tomáš ?ech wrote:
>> * gnu/packages/syncthing.scm (go-golang-org-x-crypto-ssh-terminal): New
>> variable.
>
>Thanks!
>
>In general, LGTM.
>
>Did you put this in the Syncthing module because that's where the
>rest of the Go 'x' libraries live? If so, I'd rather move the full 'x'
>suite to (gnu packages golang), since they are not specific to Syncthing
>and are used by nearly every Go application. I can handle this move.

Yes, my motivation was to keep all related packages together.

Moving go-golang* packages to (gnu packages golang) sounds right. I
will put it this to the same spot and let you do the rearrangement if
you don't mind.

Toggle quote (6 lines)
>
>> + (synopsis "TBD")
>> + (description "TBD")
>
>This is the last missing bit :)

Ooops, sorry!

S_W
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEDOrssfr9jDQthC2PSiPjT6AzQ20FAlrWVB8ACgkQSiPjT6Az
Q23Q8Q//XTzuP/+LQhruf6yv9ZHLtcROToJEgg4mKdEia8zece1Nald4mbA590EP
u1YxK/Gl8kJ9qWp94S9n9XTpxkKPtRJBTDlts/IeMAEJ1m4CRJMHVBHNqicrgTf/
jPNA/ee4KPXfHAnugrw6Cfc3NIZBrCedmkOjTdoHt8+tcdK7VqME0y06VRp8HwKo
lNt417ZUsajhsE9htuysXOCymJB0r92pR3IzIvk+Y3isF0ky5CxSqcwf7LE8gkVg
CpRT1ZSGyoeczXm1d5PGRXohqbckYI5aq3rguLIl64/AvwPxtCoNc0k6q6KneOO+
avDebvA8ztgxvAB7DN4cdgLrnqc+1q67nC/k3kwrxsgcabYjTPwmrPHLj2LLun9z
lVosy6dh3nXyqDQMCk3t33E5Wye249vqKOnQNILRYCjQXAVoZzmFQ6dCjYZ2hHAn
nc9TZjJ2KGrvmQOCiw1K8CTG+hmlSe5OWPU/hzQ5QxkPshJMcDOaFLwf3iyxfBjr
iz8+ELSl3JV+TbIFmDKJLJatOCkhQ7HV4yInlRysxQSspAdmLiPUlLmnfULJQzDF
OmarAcBZiFG02AdwTvtApp29AjemiLKvKliBspUGRS/EyOBEJ1lyYljQ8bNA2t52
mInPWQ8TnXazFx6aPa9ObOUxnI9HxMT4h2dV1MRwkFh3PtRslNs=
=YD5g
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 17 Apr 2018 23:50
(name . Tomáš ?ech)(address . sleep_walker@gnu.org)(address . 31174@debbugs.gnu.org)
20180417215001.GA26334@jasmine.lan
On Tue, Apr 17, 2018 at 10:07:59PM +0200, Tomáš ?ech wrote:
Toggle quote (20 lines)
> On Tue, Apr 17, 2018 at 03:52:14PM -0400, Leo Famulari wrote:
> > On Mon, Apr 16, 2018 at 11:11:20AM +0200, Tomáš ?ech wrote:
> > > * gnu/packages/syncthing.scm (go-golang-org-x-crypto-ssh-terminal): New
> > > variable.
> >
> > Thanks!
> >
> > In general, LGTM.
> >
> > Did you put this in the Syncthing module because that's where the
> > rest of the Go 'x' libraries live? If so, I'd rather move the full 'x'
> > suite to (gnu packages golang), since they are not specific to Syncthing
> > and are used by nearly every Go application. I can handle this move.
>
> Yes, my motivation was to keep all related packages together.
>
> Moving go-golang* packages to (gnu packages golang) sounds right. I
> will put it this to the same spot and let you do the rearrangement if
> you don't mind.

Okay! Moved in 269d0858c6c01145b07be8ebb170e448894b112a

Toggle quote (7 lines)
> > > + (synopsis "TBD")
> > > + (description "TBD")
> >
> > This is the last missing bit :)
>
> Ooops, sorry!

Can you fill these out and send an updated patch?
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlrWbAkACgkQJkb6MLrK
fwjtzQ/+OdeG54s3eYOZf4WG1C+pwXaZIYP1nI3eWKZYNOGX6frmb5hFCkS2bHqn
QqKB0IX9qLbqIyyuI4VlaFKZqcRPoCMQ1DUOj7tkYb+cDXeEeG7RsFGhjvu41nnz
cnjyHyoEsBDIf7RFPMlfZVVmO1Wx+0xCDXsOfU5jz2y3ozSom0rF61eJPoinudXG
iHKZw410+es8KrnNEVIpcWWLehy+BXWOxIOjL3BZ9dDXxh86pxAVjc4rM4OcrAcR
jodiTx74PY4F8t6dJI2f6LSVHDUmZs62LqKf4GHpRezkyxD3AN3Gk7HgFgK/W33t
YlkhNm9yn8Tt15/XMiB3j2dYREmMrtmW2EQ5IFoBhBEeoDjWSWs9aS91PBe7zJCQ
PqbkDmmebKXPTDaUXVxXDWMX6maZGx3w0hDeb86CNHM9WtEzOHAjgf76d7z/V9Vg
EAW9F3E0L/zDBPAlciSa5s6Dnd/+MHRArKbVnMAi6cncib6+4QZCAnmIYj8b7nhT
HfwXxzzTY1ZawfiamfliUVOlISNy8QPywacfhCpE3/AHUlwkMPqsVc4fI8FWINU5
hjl09kGGVdaTvZL+czdA5aVQWwFWZ23nFE4b3yYXeRtz0auB2975CDduJWQh22Fq
+1e2FJawHEA7vhoQiMIw1hVi1zOqECUfKAIKomq354giGpCJTJ0=
=xZzH
-----END PGP SIGNATURE-----


T
T
Tomáš ?ech wrote on 19 Apr 2018 10:05
[PATCH] gnu: Add go-golang-org-x-crypto-ssh-terminal.
(name . Leo Famulari)(address . leo@famulari.name)
20180419080555.14367-1-sleep_walker@gnu.org
* gnu/packages/golang.scm (go-golang-org-x-crypto-ssh-terminal): New variable.
---
gnu/packages/golang.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e2fbd54a5..485aa02c4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
+;;; Copyright © 2018 Tomáš ?ech <sleep_walker@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1257,3 +1258,43 @@ functions for normalizing Unicode strings.")
limiting in Go.")
(home-page "https://godoc.org/golang.org/x/time/rate")
(license license:bsd-3))))
+
+(define-public go-golang-org-x-crypto-ssh-terminal
+ (let ((commit "95a4943f35d008beabde8c11e5075a1b714e6419")
+ (revision "1"))
+ (package
+ (name "go-golang-org-x-crypto-ssh-terminal")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/crypto")
+ (commit commit)))
+ (file-name (string-append "go.googlesource.com-crypto-"
+ version "-checkout"))
+ (sha256
+ (base32
+ "0bkm0jx9mxmi1liabb9c04kf765n7d0062zdp3zmvzyamsq00lcx"))))
+ (build-system go-build-system)
+ (inputs
+ `(("go-golang-org-x-sys-unix" ,go-golang-org-x-sys-unix)))
+ (arguments
+ `(#:import-path "golang.org/x/crypto/ssh/terminal"
+ #:unpack-path "golang.org/x/crypto"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (map (lambda (file)
+ (make-file-writable file))
+ (find-files
+ (string-append (assoc-ref outputs "out")
+ "/src/golang.org/x/crypto/ed25519/testdata")
+ ".*\\.gz$"))
+ #t)))))
+ (synopsis "Terminal functions for Go")
+ (description "This package provides @{terminal}, which implements
+support functions for dealing with terminals, as commonly found on UNIX
+systems.")
+ (home-page "https://go.googlesource.com/crypto/")
+ (license license:bsd-3))))
--
2.17.0
L
L
Leo Famulari wrote on 19 Apr 2018 16:40
(name . Tomáš ?ech)(address . sleep_walker@gnu.org)(address . 31174@debbugs.gnu.org)
20180419144054.GC8699@jasmine.lan
On Thu, Apr 19, 2018 at 10:05:55AM +0200, Tomáš ?ech wrote:
Toggle quote (2 lines)
> * gnu/packages/golang.scm (go-golang-org-x-crypto-ssh-terminal): New variable.

LGTM, thanks!

Also, please don't hesitate to suggest changes to the go-build-system.
The current implementation is a bit primitive and will probably need
some changes as we add more Go applications.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlrYqnYACgkQJkb6MLrK
fwioaA/+N5K0vA/pT51/+yl3y9DPaazw1BJPklrbSx6NITntTjBhMrST9ZIfVvDd
wpa6vsbz9MHA62C1b0E9XQfKhxekGa9hm3b4g0UA+0jr01oMFv5WJ8+t3qYcjEmG
jBHAcJ3M+CjCp/oKDmqbQnPb2S+bywj2QlSXHQtRgqoHOdi+r74zYoderYftGPzg
IwQLEquUQmHNRCu1i5oCoEZG3qhPU9zVoEffAhucjoRSTrnY+NCA0Yoaw44DPypX
JaEcETWw372XOPZwLu9OMI6Ct3Jyf8hDCYJUdopkYpQJbbd8zwo6ssCdxzOUcZJF
/Ecpkh4qS/lutx2anxaqRcacsG4qNfTRvoINqMNGifXLjo9W1d8YDFcMBtpCzDH2
ZdVLbFMkuuVVw522/90moyJDPYiimjtT4JEJLr+KT4dqrDkwU5v3uDayhZhcK2AS
3wQp+LwIfsABSsOfUpdqKwclNfDrj0gGEWmIUfam1e9QpOCmUIiXIDFS4CRG/eLU
QpLLQeCwnhPt31evAf0zrvjyukkTrEDon6jQPIYr9vb72+oambkxxmbqFkykJQya
U/HekIjFopA70lPYzCv1RwBF5nMznlgE2xCxPB5BgW7ORDdf2tBqY8eIF0fK2Zo0
yxu6+mKkstnb8fyTnpZ41WJ7qE2Vc/VuOsnBCxeIKkSVCCJZVkI=
=Wjeu
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 22 Apr 2018 23:42
control message for bug #31174
(address . control@debbugs.gnu.org)
87po2qgbov.fsf@gnu.org
tags 31174 fixed
close 31174
T
T
Tomáš ?ech wrote on 23 Apr 2018 00:18
Re: [PATCH] gnu: Add go-golang-org-x-crypto-ssh-terminal.
(address . 31174-done@debbugs.gnu.org)
20180422221846.GA18921@doom
Pushed. Closing.

Thanks for review!

S_W
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEDOrssfr9jDQthC2PSiPjT6AzQ20FAlrdCjMACgkQSiPjT6Az
Q2297Q/+Pmim8N8e+SoJ7DlB1mRm6FXOGnssW+zGLRWy6ptsTi1Jz9NMHU5/h2zn
ju4+G4OAvIoDQG0wun5HWDHvG0pCr3vcx+sh/q6zDMI9M7g/zF0OTqz4SrUH0rLN
nYtTaFR2+b6XEWUysHKizOCSsi+/pqwHwceylXTFidqIrV2akhybkVctyvSV1gmC
/0IP/qxUynjnHgQta9cr22NC+kUbkP8byu7Wwvq8a3jL3u+B+k7P/J1tq1RzYycL
NopQadyUPyQrNwOS/fhczvUUwdKnXFxg5scn8XZesNEt49etf9OAhYSLoRir/lBw
fRmSFmUlKbkpJg0/oY1a2B1C7U7VqiF9ebUgSPsHrFKvXXxRovaxzyVf8W/AMJq9
ERkch1sk4wo5J6ZHQwIGcW6d+4rZf6CC/ByV/t4/l3StOvzmuHhh4XEZV5ZRJ4/9
cpnrYZhEYuW+dNoGCjHGZpJOWM6hpvZfQYOTzTfHOnaRg9D6gbR0TFqdDu2mBY3W
xz3Ck0NbqTH1BstJuj/QvKBEAR7m/Imc7fvqivHV619dko+oX4syA1k7g89OCNyG
mmnrYowDgvbYB2ZQlAY3zCV45IMhro0tL+6uaeeTOXnUsOll7VPQocWgJjtakuz+
M64rtP6u20T5upPQbK1UhlNjsnbVWuP7FS5OWfxoyZN03C4sXQw=
=m0VF
-----END PGP SIGNATURE-----


Closed
?