[PATCH] gnu: Add mbpfan.

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Rene
Owner
unassigned
Submitted by
Rene
Severity
normal

Debbugs page

Rene wrote 7 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
5q91mpyCT2ZRZojqp48_dQ9TlFSef_dANmrY3QsTWj1KtUHhahmPvDjAVEGf3sh1r7a2Ql_XOLtzpQjCuAJMblNdz5HXB2n5YnWh2W5xmAw=@protonmail.com
Hello team,
this is a proposed patch to add mbpfan.

Thank you
Rene
Attachment: file
From 48444809ee2d0f2993fb0c2a772f52a68f13b30a Mon Sep 17 00:00:00 2001
From: Rene <pacoon@protonmail.com>
Date: Sat, 14 Apr 2018 22:34:48 -0500
Subject: [PATCH] gnu: Add mbpfan.

* gnu/packages/linux.scm (mbpfan): New variable.
---
gnu/packages/linux.scm | 37 ++++++++++++++++++++++++++++++++++++-
1 file changed, 36 insertions(+), 1 deletion(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 26626ce8f..3125e64d9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016, 2017, 2018 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
+;;; Copyright © 2016, 2018 Rene Saavedra <pacoon@protonmail.com>
;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
@@ -4596,3 +4596,38 @@ emulates the behaviour of Gunnar Monell's older fbgrab utility.")
restriction, permission handling and more. This package provides userspace
interface to this kernel feature.")
(license license:lgpl2.1)))
+
+(define-public mbpfan
+ (package
+ (name "mbpfan")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/dgraziotin/mbpfan/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wifsws9icki95hhfh4zw1hmk07ddmkcz9mg5a9jr7q2kkrk01cx"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:make-flags (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "DESTDIR=" out)
+ "CC=gcc"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda _
+ (substitute* "Makefile"
+ (("/usr") ""))))
+ (delete 'configure)))) ; There's no configure phase.
+ (home-page "https://github.com/dgraziotin/mbpfan")
+ (synopsis "Simple daemon to control fan speed")
+ (description
+ "Mbpfan is a fan control daemon for Apple Macbooks, the daemon uses input
+from @code{coretemp} module and sets the fan speed using the @code{applesmc}
+module. It can be executed as a daemon or in the foreground with root
+privileges.")
+ (license license:gpl3)))
--
2.14.1
Marius Bakke wrote 7 years ago
87zi22bwy8.fsf@fastmail.com
Rene <pacoon@protonmail.com> writes:

Toggle quote (12 lines)
> Hello team,
> this is a proposed patch to add mbpfan.
>
> Thank you
> Rene
> From 48444809ee2d0f2993fb0c2a772f52a68f13b30a Mon Sep 17 00:00:00 2001
> From: Rene <pacoon@protonmail.com>
> Date: Sat, 14 Apr 2018 22:34:48 -0500
> Subject: [PATCH] gnu: Add mbpfan.
>
> * gnu/packages/linux.scm (mbpfan): New variable.

Thanks!

Applied with the following changes:
Toggle diff (24 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c0f33e72c..bc1e23fc1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4618,13 +4618,14 @@ interface to this kernel feature.")
(add-after 'unpack 'patch-paths
(lambda _
(substitute* "Makefile"
- (("/usr") ""))))
+ (("/usr") ""))
+ #t))
(delete 'configure)))) ; There's no configure phase.
(home-page "https://github.com/dgraziotin/mbpfan")
- (synopsis "Simple daemon to control fan speed")
+ (synopsis "Control fan speed on Macbooks")
(description
- "Mbpfan is a fan control daemon for Apple Macbooks, the daemon uses input
-from @code{coretemp} module and sets the fan speed using the @code{applesmc}
+ "mbpfan is a fan control daemon for Apple Macbooks. It uses input from
+the @code{coretemp} module and sets the fan speed using the @code{applesmc}
module. It can be executed as a daemon or in the foreground with root
privileges.")
- (license license:gpl3)))
+ (license license:gpl3+)))
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlrVJW8ACgkQoqBt8qM6
VPo6QQf+Os8e9xGFHWJ2ZM0a1oBRKRpPU2WnAnRRUE74zKjU+HCH8VXtUxUQvZXI
eyCk8Ni9LWhMtle2muKrs+sRGzirSPpLBVMlVMlYeB+gLLnvZL28zrL7xQ0iu7PB
NXzzaLQq3mriz7JmwF0BpXA06IShdLuoH97dUttwMw3XbupwsG/XNoXojhjEf9Ze
40v061s84NxqrI0YL4IbKaZeCFarX5Y4UJXvOSYzFaxspnJyg4xgpNfHziTzjJXP
oNNIt6s9ei/eYiBytIqaywEITbkVxf75EagERNFSvREuMlxLfPJefJ6v7lEIhXcP
momBqSVZCTiugTG9LGUzKiLGa7R3fA==
=UAZX
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 31166@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 31166
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help