Rene wrote 7 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Hello team,
this is a proposed patch to update xpad to 5.0.0.
Also tested inside a vm with ´guix system vm-image'.
Thank you
Rene
From 42e0a55e2be63483e17da84e9e1d9e9ceafaa05a Mon Sep 17 00:00:00 2001
From: Rene <pacoon@protonmail.com>
Date: Sat, 14 Apr 2018 12:19:52 -0500
Subject: [PATCH] gnu: xpad: Update to 5.0.0.
* gnu/packages/gnome.scm (xpad) Update to 5.0.0.
[arguments]: Add autogen phase.
[native-inputs]: Add autoconf and automake.
[inputs]: Move gtk+ from here ...
[native-inputs]: ... to here.
---
gnu/packages/gnome.scm | 21 +++++++++++++++------
1 file changed, 15 insertions(+), 6 deletions(-)
Toggle diff (44 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ed9f54be8..ef50f7d29 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6661,22 +6661,31 @@ is suitable as a default application in a Desktop environment.")
(define-public xpad
(package
(name "xpad")
- (version "4.8.0")
+ (version "5.0.0")
(source
(origin
(method url-fetch)
- (uri (string-append "https://launchpad.net/xpad/trunk/4.8.0/+download/"
+ (uri (string-append "https://launchpad.net/xpad/trunk/"
+ version "/+download/"
name "-" version ".tar.bz2"))
(sha256
(base32
- "17f915yyvfa2fsavq6wh0q0dfhib28b4k1gc0292b9xdlrvy7f22"))))
+ "02yikxg6z9bwla09ka001ppjlpbv5kbza3za9asazm5aiz376mkb"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'run-autogen
+ (lambda _
+ (system* "sh" "autogen.sh"))))))
(native-inputs
- `(("intltool" ,intltool)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gtk+:bin" ,gtk+ "bin")
+ ("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(inputs
- `(("gtk+" ,gtk+)
- ("gtksourceview" ,gtksourceview)
+ `(("gtksourceview" ,gtksourceview)
("libsm" ,libsm)))
(home-page "https://wiki.gnome.org/Apps/Xpad")
(synopsis "Virtual sticky note")
--
2.14.1