[PATCH] gnu: nestopia-ue: Update to 1.48.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 7 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20180414163226.20403-1-kkebreau@posteo.net
* gnu/packages/emulators.scm (nestopia-ue): Update to 1.48.
[source]: Simplify snippet.
[build-system]: Switch to cmake-build-system.
[inputs]: Remove glu and mesa. Add libepoxy.
[arguments]: Remove modified phases.
---
gnu/packages/emulators.scm | 31 ++++++-------------------------
1 file changed, 6 insertions(+), 25 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 1784111cd..2e825d930 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -992,7 +992,7 @@ towards a working Mupen64Plus for casual users.")
(define-public nestopia-ue
(package
(name "nestopia-ue")
- (version "1.47")
+ (version "1.48")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1001,43 +1001,24 @@ towards a working Mupen64Plus for casual users.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1dzrrjmvyqks64q5l5pfly80jb6qcsbj5b3dm40fijd5xnpbapci"))
+ "184y05z4k4a4m4022niy625kan0rklh8gcxyynxli1fss2sjjrpv"))
(modules '((guix build utils)))
(snippet
'(begin
;; We don't need libretro for the GNU/Linux build.
- (delete-file-recursively "libretro")
- ;; Use system zlib.
- (delete-file-recursively "source/zlib")
- (substitute* "source/core/NstZlib.cpp"
- (("#include \"../zlib/zlib.h\"") "#include <zlib.h>"))))))
- (build-system gnu-build-system)
+ (delete-file-recursively "libretro")))))
+ (build-system cmake-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
`(("ao" ,ao)
- ("glu" ,glu)
("gtk+" ,gtk+)
("libarchive" ,libarchive)
- ("mesa" ,mesa)
+ ("libepoxy" ,libepoxy)
("sdl2" ,sdl2)
("zlib" ,zlib)))
(arguments
- '(#:phases
- (modify-phases %standard-phases
- ;; The Nestopia build system consists solely of a Makefile.
- (delete 'configure)
- (add-before 'build 'remove-xdg-desktop-menu-call
- (lambda _
- (substitute* "Makefile"
- (("xdg-desktop-menu install .*") ""))))
- (add-before 'build 'remove-gdkwayland-include
- (lambda _
- (substitute* "source/unix/gtkui/gtkui.h"
- (("#include <gdk/gdkwayland\\.h>") "")))))
- #:make-flags (let ((out (assoc-ref %outputs "out")))
- (list "CC=gcc" "CXX=g++" (string-append "PREFIX=" out)))
- ;; There are no tests.
+ '(;; There are no tests.
#:tests? #f))
(home-page "http://0ldsk00l.ca/nestopia/")
(synopsis "Nintendo Entertainment System (NES/Famicom) emulator")
--
2.16.3
Marius Bakke wrote 7 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)
87h8oadcf4.fsf@fastmail.com
Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (6 lines)
> * gnu/packages/emulators.scm (nestopia-ue): Update to 1.48.
> [source]: Simplify snippet.
> [build-system]: Switch to cmake-build-system.
> [inputs]: Remove glu and mesa. Add libepoxy.
> [arguments]: Remove modified phases.

[...]

Toggle quote (13 lines)
> (modules '((guix build utils)))
> (snippet
> '(begin
> ;; We don't need libretro for the GNU/Linux build.
> - (delete-file-recursively "libretro")
> - ;; Use system zlib.
> - (delete-file-recursively "source/zlib")
> - (substitute* "source/core/NstZlib.cpp"
> - (("#include \"../zlib/zlib.h\"") "#include <zlib.h>"))))))
> - (build-system gnu-build-system)
> + (delete-file-recursively "libretro")))))
> + (build-system cmake-build-system)

The commit message says 'simplify snippet', but the actual change is to
not delete the zlib subfolder. Is zlib no longer bundled? If so,
please mention that in the commit message.

Apart from that LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlrVIN8ACgkQoqBt8qM6
VPpBLwf+MmfnOm7eK+spQtZX+EHaESwuovf5IRLlPk3aRqygN+l8BGYfmY/0fh9j
6OGeYIZzoWNp0y2Mj0jqHYQ3cJ+jBeSWFT1bNgYQor2JaVIY1IanvO6QjP+FUmr6
M1jAaKLo02EMBZh6cQyQkc0iqLiYdoTQJzwSyKKL+Ecqu4CSoxeLr4DsA2cNWmMI
bLvT3zaZOzvB6MG0IVfwZZDyVMsKUJJZHapsuKpkcOCQ4m0JAiLVsufGriwAq/Ds
g88EevGqnfSllA2qFORcXWgS1s7ZQfGVQtp1EH0rwHLzZYeZvS3Yv5+SnUId+NTT
WG9bOWc+OZNP+s8sk5KBIO/GEtfHgQ==
=Y2bu
-----END PGP SIGNATURE-----

Kei Kebreau wrote 7 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 31153@debbugs.gnu.org)
87y3hm4iew.fsf@posteo.net
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (29 lines)
> Kei Kebreau <kkebreau@posteo.net> writes:
>
>> * gnu/packages/emulators.scm (nestopia-ue): Update to 1.48.
>> [source]: Simplify snippet.
>> [build-system]: Switch to cmake-build-system.
>> [inputs]: Remove glu and mesa. Add libepoxy.
>> [arguments]: Remove modified phases.
>
> [...]
>
>> (modules '((guix build utils)))
>> (snippet
>> '(begin
>> ;; We don't need libretro for the GNU/Linux build.
>> - (delete-file-recursively "libretro")
>> - ;; Use system zlib.
>> - (delete-file-recursively "source/zlib")
>> - (substitute* "source/core/NstZlib.cpp"
>> - (("#include \"../zlib/zlib.h\"") "#include <zlib.h>"))))))
>> - (build-system gnu-build-system)
>> + (delete-file-recursively "libretro")))))
>> + (build-system cmake-build-system)
>
> The commit message says 'simplify snippet', but the actual change is to
> not delete the zlib subfolder. Is zlib no longer bundled? If so,
> please mention that in the commit message.
>
> Apart from that LGTM.

Thank you for reviewing this!

I've attached a revised patch with some other small but necessary
changes that I overlooked the first time around. If the patch below
looks good, then I will push it to master.
From 7738c755edc7dec075090e567a53f1f05df05e53 Mon Sep 17 00:00:00 2001
From: Kei Kebreau <kkebreau@posteo.net>
Date: Sat, 7 Apr 2018 00:11:39 -0400
Subject: [PATCH] gnu: nestopia-ue: Update to 1.48.
To: guix-patches@gnu.org

* gnu/packages/emulators.scm (nestopia-ue): Update to 1.48.
[source]: Simplify snippet; 3rd-party zlib is no longer bundled.
[build-system]: Switch to cmake-build-system.
[inputs]: Remove glu and mesa. Add libepoxy.
[arguments]: Remove #:make-flags. Re-enable 'configure' phase. Remove
'remove-xdg-desktop-menu-call' and 'remove-gdkwayland-include' phases. Add
'wrap-program' phase.
---
gnu/packages/emulators.scm | 36 ++++++++++++++----------------------
1 file changed, 14 insertions(+), 22 deletions(-)

Toggle diff (71 lines)
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 232e14b47..79947059b 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -993,7 +993,7 @@ towards a working Mupen64Plus for casual users.")
(define-public nestopia-ue
(package
(name "nestopia-ue")
- (version "1.47")
+ (version "1.48")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1002,42 +1002,34 @@ towards a working Mupen64Plus for casual users.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1dzrrjmvyqks64q5l5pfly80jb6qcsbj5b3dm40fijd5xnpbapci"))
+ "184y05z4k4a4m4022niy625kan0rklh8gcxyynxli1fss2sjjrpv"))
(modules '((guix build utils)))
(snippet
'(begin
;; We don't need libretro for the GNU/Linux build.
- (delete-file-recursively "libretro")
- ;; Use system zlib.
- (delete-file-recursively "source/zlib")
- (substitute* "source/core/NstZlib.cpp"
- (("#include \"../zlib/zlib.h\"") "#include <zlib.h>"))))))
- (build-system gnu-build-system)
+ (delete-file-recursively "libretro")))))
+ (build-system cmake-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
`(("ao" ,ao)
- ("glu" ,glu)
("gtk+" ,gtk+)
("libarchive" ,libarchive)
- ("mesa" ,mesa)
+ ("libepoxy" ,libepoxy)
("sdl2" ,sdl2)
("zlib" ,zlib)))
(arguments
'(#:phases
(modify-phases %standard-phases
- ;; The Nestopia build system consists solely of a Makefile.
- (delete 'configure)
- (add-before 'build 'remove-xdg-desktop-menu-call
- (lambda _
- (substitute* "Makefile"
- (("xdg-desktop-menu install .*") ""))))
- (add-before 'build 'remove-gdkwayland-include
- (lambda _
- (substitute* "source/unix/gtkui/gtkui.h"
- (("#include <gdk/gdkwayland\\.h>") "")))))
- #:make-flags (let ((out (assoc-ref %outputs "out")))
- (list "CC=gcc" "CXX=g++" (string-append "PREFIX=" out)))
+ ;; This fixes the file chooser crash that happens with GTK 3.
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (nestopia (string-append out "/bin/nestopia"))
+ (gtk (assoc-ref inputs "gtk+"))
+ (gtk-share (string-append gtk "/share")))
+ (wrap-program nestopia
+ `("XDG_DATA_DIRS" ":" prefix (,gtk-share)))))))
;; There are no tests.
#:tests? #f))
(home-page "http://0ldsk00l.ca/nestopia/")
--
2.17.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlrVasgACgkQ5qXuPBlG
eg1drxAAoYv4RLptdeYXzjnEbRsFVySp/bDtc3q0siE3lSrOC5aUAEUPmYcDQDcf
lTvisIST7FjBGCGrSg9kqG1BeKvZHDt/uNtUPQfaB98rXj4QSuSBoo1h1Xvbuwmo
vuYTLE1Tzvhhq4jaF6jfy2ZRjiunEZ1RXMBIvw2H3EaXZ10qR7m/o8vBSrpqfPrb
FVTMXcTTXVZI00qaIvC68CgqCyq88kc6U5HS4NkvRVdVmfEcr9ykC6Q/KBSCYyAE
0g7jwwJJ55w5vra+ruuLV/Qkn96IgwLGxm/UsqtWij5ukT6qUPsNzUAE9P63Anqs
Dfubjpa15YUoPln4K8gftvYmFL4YQTT7xF5OSrv5PlXowQ6Q3FB1OtBo2zBTua5Y
D/xCQ1gocLvBevVT1WNRExKh6wH1GMypL+tEjtpb28VOP1wcsgL/t4jdiUIuJ8XZ
XSBv1SVXnv4dr+b7/9YRQWb8mRplfs9GnlMPJ4arif4B70mGEMWt4l7UvX8utD+g
c0ODtCKB7LUhMe87WtMiCZc5QCitjsJc5VbF0nteXoUalGaHu91/1TMoPXo8Jwh5
Me+Nj1YUy5XciZst82jw3Y/kP6PmH0xNkqoFcz2f5Lqy7siXR5adRjxsC1hz23Mj
bXjK+m/lbe0PthaDBo6ls6YYp6BdWiluwQC5MRKt7RBJA318qps=
=kVxl
-----END PGP SIGNATURE-----

Marius Bakke wrote 7 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 31153@debbugs.gnu.org)
87efjdbgtx.fsf@fastmail.com
Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (37 lines)
> Marius Bakke <mbakke@fastmail.com> writes:
>
>> Kei Kebreau <kkebreau@posteo.net> writes:
>>
>>> * gnu/packages/emulators.scm (nestopia-ue): Update to 1.48.
>>> [source]: Simplify snippet.
>>> [build-system]: Switch to cmake-build-system.
>>> [inputs]: Remove glu and mesa. Add libepoxy.
>>> [arguments]: Remove modified phases.
>>
>> [...]
>>
>>> (modules '((guix build utils)))
>>> (snippet
>>> '(begin
>>> ;; We don't need libretro for the GNU/Linux build.
>>> - (delete-file-recursively "libretro")
>>> - ;; Use system zlib.
>>> - (delete-file-recursively "source/zlib")
>>> - (substitute* "source/core/NstZlib.cpp"
>>> - (("#include \"../zlib/zlib.h\"") "#include <zlib.h>"))))))
>>> - (build-system gnu-build-system)
>>> + (delete-file-recursively "libretro")))))
>>> + (build-system cmake-build-system)
>>
>> The commit message says 'simplify snippet', but the actual change is to
>> not delete the zlib subfolder. Is zlib no longer bundled? If so,
>> please mention that in the commit message.
>>
>> Apart from that LGTM.
>
> Thank you for reviewing this!
>
> I've attached a revised patch with some other small but necessary
> changes that I overlooked the first time around. If the patch below
> looks good, then I will push it to master.

LGTM, thank you!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlrWdwoACgkQoqBt8qM6
VPqgTgf9FVzXe4j6v+4I6vHtuwySH+UzKwaYbdSo8D4yF40Lljta/brVP+EOYFvH
ZGUeG5v6ZKaQUfFfxFXTRm8H1BHQ9AvnqiMyoJWygFOZc9wmCsyHL423ULE7HPz+
0a5t//DfsWCSeY20ad0jJSuUK7Y1m7RIy0Ryhp00JCRfmWzmmUbr6TjXzaTDtalS
d47vkPXRcwyHoOfGQFgpyrS7ZWKbnBoygqkUtYcYpIoMa97OwKTZuRtjOiCbSW1x
naNmEutDa+DMIQAvNalkmOGbOYnoRq4kvtHyTuKf4xEVUH3CV4eYZD9A2enRWjeW
AZlxtY+/f8kZifUCxV1A9Vip3mnm5A==
=Ee5E
-----END PGP SIGNATURE-----

Kei Kebreau wrote 7 years ago
(address . 31153-done@debbugs.gnu.org)
87vacp4bet.fsf@posteo.net
Done!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlrWjjsACgkQ5qXuPBlG
eg3KBw/8CgmcL2Qficmy8rhFC3hRCbFsiYWWX2vE6rS8a/6cWZtBBzGUIiJiBiJg
z1HmEDPeCnrjfNKoYK/cCTGsD0dR3V6vBbNrnXMzorXUBI6WkxtCH4R4VPzLJaLy
wF3j6yR7GwByvZaMr5N6+zjCmvrhPyOjOulHavxaFT0rg1QGuiANtt5eo4g5LVms
ir7OTemmqrls13Yxi5YaNQ3m4wDfKUDzSTFASgWzaN2lSjlOeDIb67JhN2DbsoIz
lvXdnXOjhnAbkkYMfQSoZEqQcr/VLw2s7W9p3CS8Ry20n/rEnhwFk1IIllSk7YqX
y1JaBnUEKq+0DPBgGSyVdO7tNKuMM6yqUpTrn4oTTYNjwsIghQzT21tvKvpdf+Bb
3oHWdJ72p0PyDOzac89TySFIoWmO2kZukOmdQYkIKCNTn6SVn0/dOwzAOm0Uul23
PQ5xT5CALrdkezh6EBdGsSzowdaNt+9niKOIVDlOBKnYbpVD244Nd0DBMOBSV7Tq
XvQyFQNRBU5cMUb0/telw2dmhJKIC3eyyrekOInQ7fWhay7NuMzUHNKGVeqxjkTE
Y+J1ERK7RikUieHfUzd3GcVwzYHrTiF3n1Uqv42tbmR1r5B7BEVK8x4SkpWBax7d
4Or78/kHL7VfRR3uf83rSqMKlRWBVHuTP7imzvz6qghuZhycauc=
=RDwB
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 31153@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 31153
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help