[PATCH] gnu: Add uefitool.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180405153617.1984-1-dannym@scratchpost.org
* gnu/packages/flashing-tools.scm (uefitool): New variable.
---
gnu/packages/flashing-tools.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index dd0eaa5df..9031faca6 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -445,3 +445,34 @@ ME as far as possible (it only edits ME firmware image files).")
;; This is an Intel thing.
(supported-systems '("x86_64-linux" "i686-linux"))))
+
+(define-public uefitool
+ (package
+ (name "uefitool")
+ (version "0.22.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/LongSoft/UEFITool/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "05jmhv7jpq08kqbd1477y1lgyjvcic3njrd0bmzdy7v7b7lnhl82"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "qmake" "-makefile")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "UEFITool" (string-append (assoc-ref outputs "out")
+ "/bin"))
+ #t)))))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (home-page "https://github.com/LongSoft/UEFITool/")
+ (synopsis "UEFI image editor")
+ (description "@code{uefitool} is a graphical UEFI image editor.")
+ (license license:bsd-2)))
Ludovic Courtès wrote 7 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 31070@debbugs.gnu.org)
87tvsltoiq.fsf@gnu.org
Hi,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (14 lines)
> * gnu/packages/flashing-tools.scm (uefitool): New variable.
> ---
> gnu/packages/flashing-tools.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
> index dd0eaa5df..9031faca6 100644
> --- a/gnu/packages/flashing-tools.scm
> +++ b/gnu/packages/flashing-tools.scm
> @@ -445,3 +445,34 @@ ME as far as possible (it only edits ME firmware image files).")
>
> ;; This is an Intel thing.
> (supported-systems '("x86_64-linux" "i686-linux"))))

[...]

Toggle quote (3 lines)
> + (synopsis "UEFI image editor")
> + (description "@code{uefitool} is a graphical UEFI image editor.")

Could you expand the acronym somewhere?

Also perhaps we need a ‘supported-systems’ field?

OK with changes along these lines, thank you!

Ludo’.
Danny Milosavljevic wrote 7 years ago
(no subject)
(address . control@debbugs.gnu.org)
20180415095837.64f66960@scratchpost.org
close 31026
close 31070
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlrTBi0ACgkQ5xo1VCww
uqUFIQf6Auv6j404VQzmvpLTMe/dxZzSmUoppixM1UmcwjVkL2xXFv5a5cBeQ4DC
26PiaflxJtLQ6yeyXFcjwwfsLW8g4NpKavJDzyLce04Mqnt0BSCLeAvmVpO/lqiV
p/sg6ZSQWR1K2MNbIiHgmcBadxtlGI46FQSuNp4DxFGFnhYdXZlklg9l3+6/ltpq
iMz9gQjsEVtidJRfI4O0GONLrdvhPKqKckC7jY4zZMoRwy5LdFJLtkH6ULo1JnKU
8fqJKytx3NrX0pSxb3DwKkq+f4qcY757kafrn/n7i4ioxhCDcWMOGm+Q6OLa8PQx
s4+GnGtBgk9JvR6ex/UDT8a+970+WQ==
=SuTz
-----END PGP SIGNATURE-----


?
Your comment

This issue is archived.

To comment on this conversation send an email to 31070@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 31070
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help