emacs-smartparens: sp-forward-barf-sexp broken

  • Open
  • quality assurance status badge
Details
4 participants
  • Alex Kost
  • Christopher Lemmer Webber
  • Oleg Pykhalov
  • Thorsten Wilms
Owner
unassigned
Submitted by
Thorsten Wilms
Severity
normal
T
T
Thorsten Wilms wrote on 5 Apr 2018 12:12
(address . bug-guix@gnu.org)
2f43d561-85df-20da-3e7c-9a991e2b6daa@freenet.de
With both emacs and smartparens installed via guix,
sp-backward-slurp-sexp, sp-forward-slurp-sexp work, but
sp-backwards-barf-sexp and sp-forward-barf-sexp fail with:
Wrong type argument: integer-or-marker-p, :beg-in

This is with no configuration and using the commands directly via M-x.
It still happens after (require 'smartparens-config). There doesn't seem
to be any matching tickets in smartparens's tracker and no matching
descriptions/solutions elsewhere.

I hesitate to report to the project directly, in case this is somehow
caused by anything specific to guix.

With | as cursor in: (diz fo (foo bar)| bob)
After toggle-debug-on-error:

Debugger entered--Lisp error: (wrong-type-argument integer-or-marker-p
:beg-in)
buffer-substring-no-properties(:beg-in :end-in)
sp-point-in-blank-sexp()
sp-forward-barf-sexp(nil)
funcall-interactively(sp-forward-barf-sexp nil)
call-interactively(sp-forward-barf-sexp record nil)
command-execute(sp-forward-barf-sexp record)
(let ((prefix-arg current-prefix-arg)) (setq real-this-command (setq
this-command (intern cmd))) (command-execute (intern cmd) (quote record)))
(closure ((sort) (pred) (cands "toggle-debug-on-error"
"sp-forward-slurp-sexp" "smartparens-strict-mode"
"sp-backward-barf-sexp" "eval-region" "eval-last-sexp" "replace-string"
"indent-region" "load-theme" "goto-line" "flush-lines" "package-install"
"menu-set-font" "replace-regexp" "load-file" "eval-buffer"
"package-refresh-contents" "delete-window" "describe-face" "version"
"whitespace-mode" "uncomment-region" "shell" "apropos" "cua-mode"
"speedbar" "eval-defun" "write-file" "ivy-recentf" "scheme-mode"
"list-packages" "sp-cheat-sheet" "close-rectangle" "ivy-switch-buffer"
"package-list-packages" "switch-to-buffer-other-frame"
"windmove-default-keybindings" "cd" "5x5" "arp" "dbx" "dig" "erc" "ert"
"eww" "ftp" "gdb" "irc" "jdb" ...) (initial-input) smex-ido-cache
smex-initialized-p info-lookup-mode t) (cmd) (if (featurep (quote smex))
(progn (smex-rank (intern cmd)))) (let ((prefix-arg current-prefix-arg))
(setq real-this-command (setq this-command (intern cmd)))
(command-execute (intern cmd) (quote record))))("sp-forward-barf-sexp")
funcall((closure ((sort) (pred) (cands "toggle-debug-on-error"
"sp-forward-slurp-sexp" "smartparens-strict-mode"
"sp-backward-barf-sexp" "eval-region" "eval-last-sexp" "replace-string"
"indent-region" "load-theme" "goto-line" "flush-lines" "package-install"
"menu-set-font" "replace-regexp" "load-file" "eval-buffer"
"package-refresh-contents" "delete-window" "describe-face" "version"
"whitespace-mode" "uncomment-region" "shell" "apropos" "cua-mode"
"speedbar" "eval-defun" "write-file" "ivy-recentf" "scheme-mode"
"list-packages" "sp-cheat-sheet" "close-rectangle" "ivy-switch-buffer"
"package-list-packages" "switch-to-buffer-other-frame"
"windmove-default-keybindings" "cd" "5x5" "arp" "dbx" "dig" "erc" "ert"
"eww" "ftp" "gdb" "irc" "jdb" ...) (initial-input) smex-ido-cache
smex-initialized-p info-lookup-mode t) (cmd) (if (featurep (quote smex))
(progn (smex-rank (intern cmd)))) (let ((prefix-arg current-prefix-arg))
(setq real-this-command (setq this-command (intern cmd)))
(command-execute (intern cmd) (quote record)))) "sp-forward-barf-sexp")
(unwind-protect (funcall action x) (ivy-recursive-restore))
(save-current-buffer (set-buffer (progn nil (or (progn nil (and
(vectorp ivy-last) (>= (length ivy-last) 25) (memq (aref ivy-last 0)
cl-struct-ivy-state-tags) t)) (signal (quote wrong-type-argument) (list
(quote ivy-state) ivy-last))) (aref ivy-last 13))) (unwind-protect
(funcall action x) (ivy-recursive-restore)))
(prog1 (save-current-buffer (set-buffer (progn nil (or (progn nil
(and (vectorp ivy-last) (>= ... 25) (memq ... cl-struct-ivy-state-tags)
t)) (signal (quote wrong-type-argument) (list (quote ivy-state)
ivy-last))) (aref ivy-last 13))) (unwind-protect (funcall action x)
(ivy-recursive-restore))) (if (or (eq ivy-exit (quote done)) (equal
(selected-window) (active-minibuffer-window)) (null
(active-minibuffer-window))) nil (select-window
(active-minibuffer-window))))
(if (eq action (quote identity)) (funcall action x) (select-window
(ivy--get-window ivy-last)) (prog1 (save-current-buffer (set-buffer
(progn nil (or (progn nil (and ... ... ... t)) (signal (quote
wrong-type-argument) (list ... ivy-last))) (aref ivy-last 13)))
(unwind-protect (funcall action x) (ivy-recursive-restore))) (if (or (eq
ivy-exit (quote done)) (equal (selected-window)
(active-minibuffer-window)) (null (active-minibuffer-window))) nil
(select-window (active-minibuffer-window)))))
(let* ((collection (progn nil (or (progn nil (and (vectorp ivy-last)
(>= ... 25) (memq ... cl-struct-ivy-state-tags) t)) (signal (quote
wrong-type-argument) (list (quote ivy-state) ivy-last))) (aref ivy-last
2))) (x (cond ((and (consp collection) (consp (car collection)) (let
(idx) (if ... ... ...)))) (ivy--directory (expand-file-name (progn nil
(or ... ...) (aref ivy-last 23)) ivy--directory)) ((equal (progn nil (or
... ...) (aref ivy-last 23)) "") ivy-text) (t (progn nil (or (progn nil
...) (signal ... ...)) (aref ivy-last 23)))))) (if (eq action (quote
identity)) (funcall action x) (select-window (ivy--get-window ivy-last))
(prog1 (save-current-buffer (set-buffer (progn nil (or (progn nil ...)
(signal ... ...)) (aref ivy-last 13))) (unwind-protect (funcall action
x) (ivy-recursive-restore))) (if (or (eq ivy-exit (quote done)) (equal
(selected-window) (active-minibuffer-window)) (null
(active-minibuffer-window))) nil (select-window
(active-minibuffer-window))))))
(progn (let* ((collection (progn nil (or (progn nil (and ... ... ...
t)) (signal (quote wrong-type-argument) (list ... ivy-last))) (aref
ivy-last 2))) (x (cond ((and (consp collection) (consp ...) (let ...
...))) (ivy--directory (expand-file-name (progn nil ... ...)
ivy--directory)) ((equal (progn nil ... ...) "") ivy-text) (t (progn nil
(or ... ...) (aref ivy-last 23)))))) (if (eq action (quote identity))
(funcall action x) (select-window (ivy--get-window ivy-last)) (prog1
(save-current-buffer (set-buffer (progn nil (or ... ...) (aref ivy-last
13))) (unwind-protect (funcall action x) (ivy-recursive-restore))) (if
(or (eq ivy-exit (quote done)) (equal (selected-window)
(active-minibuffer-window)) (null (active-minibuffer-window))) nil
(select-window (active-minibuffer-window)))))))
(if action (progn (let* ((collection (progn nil (or (progn nil ...)
(signal ... ...)) (aref ivy-last 2))) (x (cond ((and ... ... ...))
(ivy--directory (expand-file-name ... ivy--directory)) ((equal ... "")
ivy-text) (t (progn nil ... ...))))) (if (eq action (quote identity))
(funcall action x) (select-window (ivy--get-window ivy-last)) (prog1
(save-current-buffer (set-buffer (progn nil ... ...)) (unwind-protect
(funcall action x) (ivy-recursive-restore))) (if (or (eq ivy-exit ...)
(equal ... ...) (null ...)) nil (select-window
(active-minibuffer-window))))))))
(let ((action (ivy--get-action ivy-last))) (if action (progn (let*
((collection (progn nil (or ... ...) (aref ivy-last 2))) (x (cond (...)
(ivy--directory ...) (... ivy-text) (t ...)))) (if (eq action (quote
identity)) (funcall action x) (select-window (ivy--get-window ivy-last))
(prog1 (save-current-buffer (set-buffer ...) (unwind-protect ... ...))
(if (or ... ... ...) nil (select-window ...))))))))
(if ivy-inhibit-action nil (let ((action (ivy--get-action ivy-last)))
(if action (progn (let* ((collection (progn nil ... ...)) (x (cond ...
... ... ...))) (if (eq action (quote identity)) (funcall action x)
(select-window (ivy--get-window ivy-last)) (prog1 (save-current-buffer
... ...) (if ... nil ...))))))))
ivy-call()
(prog1 (unwind-protect (let ((fun (function ivy--minibuffer-setup))
setup-hook) (setq setup-hook (function (lambda nil (remove-hook (quote
minibuffer-setup-hook) setup-hook) (funcall fun)))) (unwind-protect
(progn (add-hook (quote minibuffer-setup-hook) setup-hook) (let* ((hist
...) (minibuffer-completion-table collection)
(minibuffer-completion-predicate predicate) (resize-mini-windows ...))
(if (and ivy-auto-select-single-candidate ... ...) (progn ... ...)
(read-from-minibuffer prompt ... ... nil hist)) (if (eq ivy-exit ...)
(progn ...)) (progn nil (or ... ...) (aref ivy-last 23)))) (remove-hook
(quote minibuffer-setup-hook) setup-hook))) (remove-hook (quote
post-command-hook) (function ivy--queue-exhibit)) (if (eq
ivy-display-function (quote ivy-display-function-overlay)) (progn
(ivy-overlay-cleanup))) (if (setq unwind (progn nil (or (progn nil (and
... ... ... t)) (signal (quote wrong-type-argument) (list ...
ivy-last))) (aref ivy-last 16))) (progn (funcall unwind))) (if (eq
ivy-exit (quote done)) nil (ivy-recursive-restore))) (ivy-call) (if (>
(length (progn nil (or (progn nil (and ... ... ... t)) (signal (quote
wrong-type-argument) (list ... ivy-last))) (aref ivy-last 23))) 0)
(progn (remove-text-properties 0 1 (quote (idx)) (progn nil (or (progn
nil (and ... ... ... t)) (signal (quote wrong-type-argument) (list ...
ivy-last))) (aref ivy-last 23))))))
(let ((ivy-recursive-last (and (active-minibuffer-window) ivy-last))
(transformer-fn (plist-get ivy--display-transformers-list (or caller
(and (functionp collection) collection)))) (ivy-display-function (if
(window-minibuffer-p) nil (cdr (assoc caller
ivy-display-functions-alist))))) (setq ivy-last (progn "Constructor for
objects of type `ivy-state'." nil (vector (quote cl-struct-ivy-state)
prompt collection predicate require-match initial-input history
preselect keymap update-fn sort (selected-frame) (selected-window)
(current-buffer) nil action unwind re-builder matcher dynamic-collection
transformer-fn default-directory caller nil def))) (ivy--reset-state
ivy-last) (prog1 (unwind-protect (let ((fun (function
ivy--minibuffer-setup)) setup-hook) (setq setup-hook (function (lambda
nil (remove-hook ... setup-hook) (funcall fun)))) (unwind-protect (progn
(add-hook (quote minibuffer-setup-hook) setup-hook) (let* (... ... ...
...) (if ... ... ...) (if ... ...) (progn nil ... ...))) (remove-hook
(quote minibuffer-setup-hook) setup-hook))) (remove-hook (quote
post-command-hook) (function ivy--queue-exhibit)) (if (eq
ivy-display-function (quote ivy-display-function-overlay)) (progn
(ivy-overlay-cleanup))) (if (setq unwind (progn nil (or (progn nil ...)
(signal ... ...)) (aref ivy-last 16))) (progn (funcall unwind))) (if (eq
ivy-exit (quote done)) nil (ivy-recursive-restore))) (ivy-call) (if (>
(length (progn nil (or (progn nil ...) (signal ... ...)) (aref ivy-last
23))) 0) (progn (remove-text-properties 0 1 (quote (idx)) (progn nil (or
(progn nil ...) (signal ... ...)) (aref ivy-last 23)))))))
(progn (let ((extra-actions (delete-dups (append (plist-get
ivy--actions-list t) (plist-get ivy--actions-list this-command)
(plist-get ivy--actions-list caller))))) (if extra-actions (progn (setq
action (cond ((functionp action) (cons 1 ...)) ((null action) (cons 1
...)) (t (delete-dups ...))))))) (let ((extra-sources (plist-get
ivy--sources-list caller))) (if extra-sources (progn (setq
ivy--extra-candidates nil) (let ((--dolist-tail-- extra-sources)) (while
--dolist-tail-- (let (...) (cond ... ...) (setq --dolist-tail-- ...)))))
(setq ivy--extra-candidates (quote ((original-source)))))) (let
((ivy-recursive-last (and (active-minibuffer-window) ivy-last))
(transformer-fn (plist-get ivy--display-transformers-list (or caller
(and (functionp collection) collection)))) (ivy-display-function (if
(window-minibuffer-p) nil (cdr (assoc caller
ivy-display-functions-alist))))) (setq ivy-last (progn "Constructor for
objects of type `ivy-state'." nil (vector (quote cl-struct-ivy-state)
prompt collection predicate require-match initial-input history
preselect keymap update-fn sort (selected-frame) (selected-window)
(current-buffer) nil action unwind re-builder matcher dynamic-collection
transformer-fn default-directory caller nil def))) (ivy--reset-state
ivy-last) (prog1 (unwind-protect (let ((fun (function
ivy--minibuffer-setup)) setup-hook) (setq setup-hook (function (lambda
nil ... ...))) (unwind-protect (progn (add-hook ... setup-hook) (let*
... ... ... ...)) (remove-hook (quote minibuffer-setup-hook)
setup-hook))) (remove-hook (quote post-command-hook) (function
ivy--queue-exhibit)) (if (eq ivy-display-function (quote
ivy-display-function-overlay)) (progn (ivy-overlay-cleanup))) (if (setq
unwind (progn nil (or ... ...) (aref ivy-last 16))) (progn (funcall
unwind))) (if (eq ivy-exit (quote done)) nil (ivy-recursive-restore)))
(ivy-call) (if (> (length (progn nil (or ... ...) (aref ivy-last 23)))
0) (progn (remove-text-properties 0 1 (quote (idx)) (progn nil (or ...
...) (aref ivy-last 23))))))))
(progn (let ((--cl-keys-- --cl-rest--)) (while --cl-keys-- (cond
((memq (car --cl-keys--) (quote (:predicate :require-match
:initial-input :history :preselect :def :keymap :update-fn :sort :action
:unwind :re-builder :matcher :dynamic-collection :caller
:allow-other-keys))) (setq --cl-keys-- (cdr (cdr --cl-keys--)))) ((car
(cdr (memq ... --cl-rest--))) (setq --cl-keys-- nil)) (t (error "Keyword
argument %s not one of (:predicate :require-match :initial-input
:history :preselect :def :keymap :update-fn :sort :action :unwind
:re-builder :matcher :dynamic-collection :caller)" (car
--cl-keys--)))))) (progn (let ((extra-actions (delete-dups (append
(plist-get ivy--actions-list t) (plist-get ivy--actions-list
this-command) (plist-get ivy--actions-list caller))))) (if extra-actions
(progn (setq action (cond (... ...) (... ...) (t ...)))))) (let
((extra-sources (plist-get ivy--sources-list caller))) (if extra-sources
(progn (setq ivy--extra-candidates nil) (let ((--dolist-tail--
extra-sources)) (while --dolist-tail-- (let ... ... ...)))) (setq
ivy--extra-candidates (quote ((original-source)))))) (let
((ivy-recursive-last (and (active-minibuffer-window) ivy-last))
(transformer-fn (plist-get ivy--display-transformers-list (or caller
(and ... collection)))) (ivy-display-function (if (window-minibuffer-p)
nil (cdr (assoc caller ivy-display-functions-alist))))) (setq ivy-last
(progn "Constructor for objects of type `ivy-state'." nil (vector (quote
cl-struct-ivy-state) prompt collection predicate require-match
initial-input history preselect keymap update-fn sort (selected-frame)
(selected-window) (current-buffer) nil action unwind re-builder matcher
dynamic-collection transformer-fn default-directory caller nil def)))
(ivy--reset-state ivy-last) (prog1 (unwind-protect (let ((fun ...)
setup-hook) (setq setup-hook (function ...)) (unwind-protect (progn ...
...) (remove-hook ... setup-hook))) (remove-hook (quote
post-command-hook) (function ivy--queue-exhibit)) (if (eq
ivy-display-function (quote ivy-display-function-overlay)) (progn
(ivy-overlay-cleanup))) (if (setq unwind (progn nil ... ...)) (progn
(funcall unwind))) (if (eq ivy-exit (quote done)) nil
(ivy-recursive-restore))) (ivy-call) (if (> (length (progn nil ... ...))
0) (progn (remove-text-properties 0 1 (quote ...) (progn nil ... ...))))))))
(let* ((predicate (car (cdr (plist-member --cl-rest-- (quote
:predicate))))) (require-match (car (cdr (plist-member --cl-rest--
(quote :require-match))))) (initial-input (car (cdr (plist-member
--cl-rest-- (quote :initial-input))))) (history (car (cdr (plist-member
--cl-rest-- (quote :history))))) (preselect (car (cdr (plist-member
--cl-rest-- (quote :preselect))))) (def (car (cdr (plist-member
--cl-rest-- (quote :def))))) (keymap (car (cdr (plist-member --cl-rest--
(quote :keymap))))) (update-fn (car (cdr (plist-member --cl-rest--
(quote :update-fn))))) (sort (car (cdr (plist-member --cl-rest-- (quote
:sort))))) (action (car (cdr (plist-member --cl-rest-- (quote
:action))))) (unwind (car (cdr (plist-member --cl-rest-- (quote
:unwind))))) (re-builder (car (cdr (plist-member --cl-rest-- (quote
:re-builder))))) (matcher (car (cdr (plist-member --cl-rest-- (quote
:matcher))))) (dynamic-collection (car (cdr (plist-member --cl-rest--
(quote :dynamic-collection))))) (caller (car (cdr (plist-member
--cl-rest-- (quote :caller)))))) (progn (let ((--cl-keys-- --cl-rest--))
(while --cl-keys-- (cond ((memq (car --cl-keys--) (quote ...)) (setq
--cl-keys-- (cdr ...))) ((car (cdr ...)) (setq --cl-keys-- nil)) (t
(error "Keyword argument %s not one of (:predicate :require-match
:initial-input :history :preselect :def :keymap :update-fn :sort :action
:unwind :re-builder :matcher :dynamic-collection :caller)" (car
--cl-keys--)))))) (progn (let ((extra-actions (delete-dups (append ...
... ...)))) (if extra-actions (progn (setq action (cond ... ... ...)))))
(let ((extra-sources (plist-get ivy--sources-list caller))) (if
extra-sources (progn (setq ivy--extra-candidates nil) (let (...) (while
--dolist-tail-- ...))) (setq ivy--extra-candidates (quote (...))))) (let
((ivy-recursive-last (and (active-minibuffer-window) ivy-last))
(transformer-fn (plist-get ivy--display-transformers-list (or caller
...))) (ivy-display-function (if (window-minibuffer-p) nil (cdr ...))))
(setq ivy-last (progn "Constructor for objects of type `ivy-state'." nil
(vector (quote cl-struct-ivy-state) prompt collection predicate
require-match initial-input history preselect keymap update-fn sort
(selected-frame) (selected-window) (current-buffer) nil action unwind
re-builder matcher dynamic-collection transformer-fn default-directory
caller nil def))) (ivy--reset-state ivy-last) (prog1 (unwind-protect
(let (... setup-hook) (setq setup-hook ...) (unwind-protect ... ...))
(remove-hook (quote post-command-hook) (function ivy--queue-exhibit))
(if (eq ivy-display-function ...) (progn ...)) (if (setq unwind ...)
(progn ...)) (if (eq ivy-exit ...) nil (ivy-recursive-restore)))
(ivy-call) (if (> (length ...) 0) (progn (remove-text-properties 0 1 ...
...))))))))
ivy-read("M-x " ("toggle-debug-on-error" "sp-forward-slurp-sexp"
"smartparens-strict-mode" "sp-backward-barf-sexp" "eval-region"
"eval-last-sexp" "replace-string" "indent-region" "load-theme"
"goto-line" "flush-lines" "package-install" "menu-set-font"
"replace-regexp" "load-file" "eval-buffer" "package-refresh-contents"
"delete-window" "describe-face" "version" "whitespace-mode"
"uncomment-region" "shell" "apropos" "cua-mode" "speedbar" "eval-defun"
"write-file" "ivy-recentf" "scheme-mode" "list-packages"
"sp-cheat-sheet" "close-rectangle" "ivy-switch-buffer"
"package-list-packages" "switch-to-buffer-other-frame"
"windmove-default-keybindings" "cd" "5x5" "arp" "dbx" "dig" "erc" "ert"
"eww" "ftp" "gdb" "irc" "jdb" "man" ...) :predicate nil :require-match t
:history counsel-M-x-history :action (closure ((sort) (pred) (cands
"toggle-debug-on-error" "sp-forward-slurp-sexp"
"smartparens-strict-mode" "sp-backward-barf-sexp" "eval-region"
"eval-last-sexp" "replace-string" "indent-region" "load-theme"
"goto-line" "flush-lines" "package-install" "menu-set-font"
"replace-regexp" "load-file" "eval-buffer" "package-refresh-contents"
"delete-window" "describe-face" "version" "whitespace-mode"
"uncomment-region" "shell" "apropos" "cua-mode" "speedbar" "eval-defun"
"write-file" "ivy-recentf" "scheme-mode" "list-packages"
"sp-cheat-sheet" "close-rectangle" "ivy-switch-buffer"
"package-list-packages" "switch-to-buffer-other-frame"
"windmove-default-keybindings" "cd" "5x5" "arp" "dbx" "dig" "erc" "ert"
"eww" "ftp" "gdb" "irc" "jdb" ...) (initial-input) smex-ido-cache
smex-initialized-p info-lookup-mode t) (cmd) (if (featurep (quote smex))
(progn (smex-rank (intern cmd)))) (let ((prefix-arg current-prefix-arg))
(setq real-this-command (setq this-command (intern cmd)))
(command-execute (intern cmd) (quote record)))) :sort nil :keymap
(keymap (67108908 . counsel--info-lookup-symbol) (67108910 .
counsel-find-sym
This message was truncated. Download the full message here.
A
A
Alex Kost wrote on 5 Apr 2018 21:25
(name . Thorsten Wilms)(address . t_w_@freenet.de)(address . 31069@debbugs.gnu.org)
87o9ix8nha.fsf@gmail.com
Thorsten Wilms (2018-04-05 12:12 +0200) wrote:

Toggle quote (5 lines)
> With both emacs and smartparens installed via guix,
> sp-backward-slurp-sexp, sp-forward-slurp-sexp work, but
> sp-backwards-barf-sexp and sp-forward-barf-sexp fail with:
> Wrong type argument: integer-or-marker-p, :beg-in

It probably wouldn't help but... all these commands work for me without
any error (I use smartparens 1.11 installed with Guix).

I don't use "smartparens-mode", I use these commands directly (bound to
some keys). This is the configuration for smartparens I have in my
emacs config file:

(with-eval-after-load 'smartparens
(require 'smartparens-config nil t)
(setq
sp-navigate-reindent-after-up nil
sp-ignore-modes-list nil
sp-wrap-entire-symbol 'globally))

--
Alex
T
T
Thorsten Wilms wrote on 6 Apr 2018 22:35
(name . Alex Kost)(address . alezost@gmail.com)(address . 31069@debbugs.gnu.org)
c5728883-472b-8f0c-c1b3-abdfa752c5cf@freenet.de
On 05.04.2018 21:25, Alex Kost wrote:

Toggle quote (14 lines)
> It probably wouldn't help but... all these commands work for me without
> any error (I use smartparens 1.11 installed with Guix).
>
> I don't use "smartparens-mode", I use these commands directly (bound to
> some keys). This is the configuration for smartparens I have in my
> emacs config file:
>
> (with-eval-after-load 'smartparens
> (require 'smartparens-config nil t)
> (setq
> sp-navigate-reindent-after-up nil
> sp-ignore-modes-list nil
> sp-wrap-entire-symbol 'globally))

1.11 here, too.

That piece of configuration doesn't affect the issue; but now I can say
that it doesn't matter if smartparens-mode or smartparens-strict-mode or
neither is active, slurp works, barf doesn't.

I'm back to paredit, but would still like to figure this out.


--
Thorsten Wilms
A
A
Alex Kost wrote on 7 Apr 2018 17:19
(name . Thorsten Wilms)(address . t_w_@freenet.de)(address . 31069@debbugs.gnu.org)
87sh87xcv5.fsf@gmail.com
Thorsten Wilms (2018-04-06 22:35 +0200) wrote:

Toggle quote (24 lines)
> On 05.04.2018 21:25, Alex Kost wrote:
>
>> It probably wouldn't help but... all these commands work for me without
>> any error (I use smartparens 1.11 installed with Guix).
>>
>> I don't use "smartparens-mode", I use these commands directly (bound to
>> some keys). This is the configuration for smartparens I have in my
>> emacs config file:
>>
>> (with-eval-after-load 'smartparens
>> (require 'smartparens-config nil t)
>> (setq
>> sp-navigate-reindent-after-up nil
>> sp-ignore-modes-list nil
>> sp-wrap-entire-symbol 'globally))
>
> 1.11 here, too.
>
> That piece of configuration doesn't affect the issue; but now I can say
> that it doesn't matter if smartparens-mode or smartparens-strict-mode or
> neither is active, slurp works, barf doesn't.
>
> I'm back to paredit, but would still like to figure this out.

Sorry, I don't know what could cause your problem. My only idea is
maybe you have some mixed (incompatible) packages both from Guix and
from (M)ELPA (for example, "dash.el" from Melpa and "smartparens" from
Guix). Look at "M-x list-load-path-shadows".

--
Alex
T
T
Thorsten Wilms wrote on 7 Apr 2018 20:54
(name . Alex Kost)(address . alezost@gmail.com)(address . 31069@debbugs.gnu.org)
b10b8ff2-8015-c5c0-b853-e48f480934d8@freenet.de
On 07.04.2018 17:19, Alex Kost wrote:

Toggle quote (5 lines)
> Sorry, I don't know what could cause your problem. My only idea is
> maybe you have some mixed (incompatible) packages both from Guix and
> from (M)ELPA (for example, "dash.el" from Melpa and "smartparens" from
> Guix). Look at "M-x list-load-path-shadows".

No worries, thanks for your input!

There's nothing here that wasn't installed via guix.
list-load-path-shadows says:

/home/thorwil/.guix-profile/share/emacs/site-lisp/site-start hides
/gnu/store/6cflji7h6y0v15dvnccv7paaa7894gdc-emacs-25.3/share/emacs/site-lisp/site-start
/home/thorwil/.guix-profile/share/emacs/site-lisp/guix-emacs hides
/gnu/store/6cflji7h6y0v15dvnccv7paaa7894gdc-emacs-25.3/share/emacs/site-lisp/guix-emacs


So far all this happened on Ubuntu with just Emacs and packages for it
installed via guix. Now I tried what happens on Guix SD, with
emacs-smartparens as only Emacs package, run in the shell, no init.el.
After just M-x smartparens-mode, again: slurp works, barf doesn't.

I would conclude that this is a direct smartparens bug, if it wasn't for
your report of having it working (which I do not doubt).

--
Thorsten Wilms
O
O
Oleg Pykhalov wrote on 7 Apr 2018 21:09
(name . Thorsten Wilms)(address . t_w_@freenet.de)
87o9iultph.fsf@gmail.com
Thorsten Wilms <t_w_@freenet.de> writes:

Toggle quote (5 lines)
> On 05.04.2018 21:25, Alex Kost wrote:
>
>> It probably wouldn't help but... all these commands work for me without
>> any error (I use smartparens 1.11 installed with Guix).

[…]

Toggle quote (2 lines)
> 1.11 here, too.

I'm on 1.11 and GuixSD have the same issue.

Toggle quote (5 lines)
> That piece of configuration doesn't affect the issue; but now I can
> say that it doesn't matter if smartparens-mode or
> smartparens-strict-mode or neither is active, slurp works, barf
> doesn't.

Same for me.

Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEc+OyAXw1EaDPCmAPckbhHGm3lWkFAlrJF1oACgkQckbhHGm3
lWmaAhAAvD1t+SY9CA3FPoqLdzl3JC9CG7dTsTfGuhkxKWH+1mq0DKbbC6TP8SMb
g64KP+JlkAF5/qeBh5s2TWcaOxWk2yx+wdozzbbuIYnHN7z4fYkX7/OIUzfOsy+A
n+ax43h53knOthmcWgPGJ/Uep+ovH5Hf881UeJ1nFZsvb/MYLn82oVOwKkvXUseD
/nMPcXKChFpM6Z/2LnuJXiYpB93dZu0yj8G1q8XMESuurfe7V3UJgjzKpG9hsLtl
u5/94h8eW+Y0+sqAIUGPwzVh0heG6Rs0UopVn0VELPypDq2kweFAn3R5UK7Z7U+K
tKl/pzeqTSecbmbn3YU9MJw9y5znMNN97HtmzzxgVZqCsEwm756MYiwwKJPdaS0u
Od7W4/ryO4htfn7Vz5/ByO9e0Ij1AYIgEWiZoEYP0RmVyDdDZJIkqqHkVbRB5ohB
etmNt5J//BXeMsclI8GhrtRnG3ttoASJ0yhDXGd5uK4ZBK8pXX6wGHDQdkC5R7yN
1vEBMwhU44zqyVFdtGHGlujY3E9SCpSikcsvmnq/TUsykbzVsqxCauTfHkRm1GEl
L/W2KiMGRU9FJ2z1509cKxbD71htdE9YnpVAaFHxWoaZjg0BXTnGk0zx6mpdTdq7
Hj49YJB9SQdVtJwvXAcZQWMjqkQ4vVuvseAEh8AL12iF7mF2a7M=
=hsP0
-----END PGP SIGNATURE-----

A
A
Alex Kost wrote on 8 Apr 2018 20:21
(name . Oleg Pykhalov)(address . go.wigust@gmail.com)
876051v9t3.fsf@gmail.com
Oleg Pykhalov (2018-04-07 22:09 +0300) wrote:

Toggle quote (20 lines)
> Thorsten Wilms <t_w_@freenet.de> writes:
>
>> On 05.04.2018 21:25, Alex Kost wrote:
>>
>>> It probably wouldn't help but... all these commands work for me without
>>> any error (I use smartparens 1.11 installed with Guix).
>
> […]
>
>> 1.11 here, too.
>
> I'm on 1.11 and GuixSD have the same issue.
>
>> That piece of configuration doesn't affect the issue; but now I can
>> say that it doesn't matter if smartparens-mode or
>> smartparens-strict-mode or neither is active, slurp works, barf
>> doesn't.
>
> Same for me.

Hm, barf commands definitely work for me. Maybe I just should update my
emacs packages to reproduce it (although I use smartparens 1.11 but I
have not updated my profile for several months) :-)

--
Alex
C
C
Christopher Lemmer Webber wrote on 19 Apr 2018 01:34
(address . t_w_@freenet.de)
87vaco5btg.fsf@dustycloud.org
Thorsten Wilms writes:

Toggle quote (27 lines)
> On 07.04.2018 17:19, Alex Kost wrote:
>
>> Sorry, I don't know what could cause your problem. My only idea is
>> maybe you have some mixed (incompatible) packages both from Guix and
>> from (M)ELPA (for example, "dash.el" from Melpa and "smartparens" from
>> Guix). Look at "M-x list-load-path-shadows".
>
> No worries, thanks for your input!
>
> There's nothing here that wasn't installed via guix.
> list-load-path-shadows says:
>
> /home/thorwil/.guix-profile/share/emacs/site-lisp/site-start hides
> /gnu/store/6cflji7h6y0v15dvnccv7paaa7894gdc-emacs-25.3/share/emacs/site-lisp/site-start
> /home/thorwil/.guix-profile/share/emacs/site-lisp/guix-emacs hides
> /gnu/store/6cflji7h6y0v15dvnccv7paaa7894gdc-emacs-25.3/share/emacs/site-lisp/guix-emacs
>
>
> So far all this happened on Ubuntu with just Emacs and packages for it
> installed via guix. Now I tried what happens on Guix SD, with
> emacs-smartparens as only Emacs package, run in the shell, no
> init.el. After just M-x smartparens-mode, again: slurp works, barf
> doesn't.
>
> I would conclude that this is a direct smartparens bug, if it wasn't
> for your report of having it working (which I do not doubt).

I have the same problem BTW. It started happening after a recent
upgrade.
?