[PATCH 0/2] gnu: translate-shell: Update to 0.9.6.7-1.bb9f32d.

  • Done
  • quality assurance status badge
Details
2 participants
  • Oleg Pykhalov
  • Marius Bakke
Owner
unassigned
Submitted by
Oleg Pykhalov
Severity
normal
O
O
Oleg Pykhalov wrote on 25 Mar 2018 11:54
(address . guix-patches@gnu.org)(name . Oleg Pykhalov)(address . go.wigust@gmail.com)
20180325095455.3806-1-go.wigust@gmail.com
Hello Guix,

Those patch series fix a ‘git lint’ home-page warning and update
‘translate-shell’ package.

Oleg Pykhalov (2):
gnu: translate-shell: Update home-page.
gnu: translate-shell: Update to 0.9.6.7-1.bb9f32d.

gnu/packages/dictionaries.scm | 94 ++++++++++++++++++++++++-------------------
1 file changed, 52 insertions(+), 42 deletions(-)

--
2.16.2
O
O
Oleg Pykhalov wrote on 25 Mar 2018 11:57
[PATCH 1/2] gnu: translate-shell: Update home-page.
(address . 30933@debbugs.gnu.org)(name . Oleg Pykhalov)(address . go.wigust@gmail.com)
20180325095706.4508-1-go.wigust@gmail.com
* gnu/packages/dictionaries.scm (translate-shell)[home-page]: Append slash.
---
gnu/packages/dictionaries.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index 3f50070ef..5cd5724f5 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -274,7 +274,7 @@ and a Python library.")
(native-inputs
`(("emacs" ,emacs-minimal)
("util-linux" ,util-linux))) ; hexdump, for the test
- (home-page "https://www.soimort.org/translate-shell")
+ (home-page "https://www.soimort.org/translate-shell/")
(synopsis "Translations from the command line")
(description
"Translate Shell (formerly Google Translate CLI) is a command-line
--
2.16.2
O
O
Oleg Pykhalov wrote on 25 Mar 2018 11:57
[PATCH 2/2] gnu: translate-shell: Update to 0.9.6.7-1.bb9f32d.
(address . 30933@debbugs.gnu.org)(name . Oleg Pykhalov)(address . go.wigust@gmail.com)
20180325095706.4508-2-go.wigust@gmail.com
* gnu/packages/dictionaries.scm (translate-shell): Update to
0.9.6.7-1.bb9f32d.
[arguments](make-flags): Add "NETWORK_ACCESS=no test".
[phases]: Add 'change-file-permissions' phase.
---
gnu/packages/dictionaries.scm | 94 ++++++++++++++++++++++++-------------------
1 file changed, 52 insertions(+), 42 deletions(-)

Toggle diff (114 lines)
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index 5cd5724f5..bafae77bf 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -24,6 +24,7 @@
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
@@ -237,48 +238,57 @@ and a Python library.")
(license gpl3+)))
(define-public translate-shell
- (package
- (name "translate-shell")
- (version "0.9.6.4")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/soimort/" name "/archive/v"
- version ".tar.gz"))
- (sha256
- (base32
- "1fg6nf1plvgimc57fsdr9rcjbf7jvmk5jrlj5ya509vpdcdgvj2s"))
- (file-name (string-append name "-" version ".tar.gz"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'configure) ; no configure phase
- (add-after 'install 'emacs-install
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (dest (string-append out "/share/emacs/site-lisp"))
- (emacs (string-append (assoc-ref inputs "emacs") "/bin/emacs")))
- (install-file "google-translate-mode.el" dest)
- (emacs-generate-autoloads ,name dest)))))
- #:make-flags (list (string-append "PREFIX=" %output))
- #:imported-modules (,@%gnu-build-system-modules (guix build emacs-utils))
- #:modules ((guix build gnu-build-system)
- (guix build emacs-utils)
- (guix build utils))
- #:test-target "test"))
- (propagated-inputs
- `(("curl" ,curl)
- ("fribidi" ,fribidi)
- ("rlwrap" ,rlwrap)))
- (native-inputs
- `(("emacs" ,emacs-minimal)
- ("util-linux" ,util-linux))) ; hexdump, for the test
- (home-page "https://www.soimort.org/translate-shell/")
- (synopsis "Translations from the command line")
- (description
- "Translate Shell (formerly Google Translate CLI) is a command-line
+ (let ((commit "bb9f32d3145125ba664b6b05bf0a2fd34108e9d2"))
+ (package
+ (name "translate-shell")
+ (version (git-version "0.9.6.7" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/soimort/translate-shell.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vl50vfd4kn0mazj3j30m75xldcra23skrd3qhx3kav2613a9y3i"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure phase
+ (add-after 'unpack 'change-file-permissions
+ (lambda _
+ (chmod "translate" #o755)
+ #t))
+ (add-after 'install 'emacs-install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (dest (string-append out "/share/emacs/site-lisp"))
+ (emacs (string-append (assoc-ref inputs "emacs")
+ "/bin/emacs")))
+ (install-file "google-translate-mode.el" dest)
+ (emacs-generate-autoloads ,name dest)))))
+ #:make-flags (list (string-append "PREFIX=" %output)
+ "NETWORK_ACCESS=no test")
+ #:imported-modules (,@%gnu-build-system-modules
+ (guix build emacs-utils))
+ #:modules ((guix build gnu-build-system)
+ (guix build emacs-utils)
+ (guix build utils))
+ #:test-target "test"))
+ (propagated-inputs
+ `(("curl" ,curl)
+ ("fribidi" ,fribidi)
+ ("rlwrap" ,rlwrap)))
+ (native-inputs
+ `(("emacs" ,emacs-minimal)
+ ("util-linux" ,util-linux))) ; hexdump, for the test
+ (home-page "https://www.soimort.org/translate-shell/")
+ (synopsis "Translations from the command line")
+ (description
+ "Translate Shell (formerly Google Translate CLI) is a command-line
translator powered by Google Translate (default), Bing Translator,
Yandex.Translate and Apertium. It gives you easy access to one of these
translation engines from your terminal.")
- (license public-domain)))
+ (license public-domain))))
--
2.16.2
M
M
Marius Bakke wrote on 26 Mar 2018 20:03
87tvt2iujd.fsf@fastmail.com
Oleg Pykhalov <go.wigust@gmail.com> writes:

Toggle quote (5 lines)
> * gnu/packages/dictionaries.scm (translate-shell): Update to
> 0.9.6.7-1.bb9f32d.
> [arguments](make-flags): Add "NETWORK_ACCESS=no test".
> [phases]: Add 'change-file-permissions' phase.

[...]
Toggle quote (47 lines)
> (define-public translate-shell
> - (package
> - (name "translate-shell")
> - (version "0.9.6.4")
> - (source
> - (origin
> - (method url-fetch)
> - (uri (string-append "https://github.com/soimort/" name "/archive/v"
> - version ".tar.gz"))
> - (sha256
> - (base32
> - "1fg6nf1plvgimc57fsdr9rcjbf7jvmk5jrlj5ya509vpdcdgvj2s"))
> - (file-name (string-append name "-" version ".tar.gz"))))
> - (build-system gnu-build-system)
> - (arguments
> - `(#:phases
> - (modify-phases %standard-phases
> - (delete 'configure) ; no configure phase
> - (add-after 'install 'emacs-install
> - (lambda* (#:key inputs outputs #:allow-other-keys)
> - (let* ((out (assoc-ref outputs "out"))
> - (dest (string-append out "/share/emacs/site-lisp"))
> - (emacs (string-append (assoc-ref inputs "emacs") "/bin/emacs")))
> - (install-file "google-translate-mode.el" dest)
> - (emacs-generate-autoloads ,name dest)))))
> - #:make-flags (list (string-append "PREFIX=" %output))
> - #:imported-modules (,@%gnu-build-system-modules (guix build emacs-utils))
> - #:modules ((guix build gnu-build-system)
> - (guix build emacs-utils)
> - (guix build utils))
> - #:test-target "test"))
> - (propagated-inputs
> - `(("curl" ,curl)
> - ("fribidi" ,fribidi)
> - ("rlwrap" ,rlwrap)))
> - (native-inputs
> - `(("emacs" ,emacs-minimal)
> - ("util-linux" ,util-linux))) ; hexdump, for the test
> - (home-page "https://www.soimort.org/translate-shell/")
> - (synopsis "Translations from the command line")
> - (description
> - "Translate Shell (formerly Google Translate CLI) is a command-line
> + (let ((commit "bb9f32d3145125ba664b6b05bf0a2fd34108e9d2"))
> + (package
> + (name "translate-shell")
> + (version (git-version "0.9.6.7" "1" commit))

There are only five commits since this version. I assume the git
checkout is because of the patch that adds "NETWORK_ACCESS"?

The patch itself is smaller than the reindent from the let binding, so I
would prefer to simply add it.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlq5NeYACgkQoqBt8qM6
VPoK9AgAk9z2Tye5C8atlU1vZJUiHOSvMmnj20ywfOcY+WDuXpwTYQ3pKFcuS2Af
WHAFLtEVhBK3wzL2Cno4ueWE9QfW0i8ZCAofEqIojQ38o7xoS3lSw0jnAh0ONvkO
ND/nKm3BrJIo5gw+3hcXPLG+eCtCl1BjFXwMeT78OoqdFZjchvmKt1Ruojru3x8n
FK9X+M7CS+m+mnI5aVgHTyXq0NhLLnifftNvEHCDIPZpJiiyAtI+Hzok4qnUV9Yd
3Va4mdKNjOCc83no4vWnXY56xnQzWc0Hq7h8aO/CY5vrnvbvduU9OsL7LNFHScXN
EGT5Ab3pIZVgpf5GTK3yLBw09uydow==
=BF3E
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 26 Mar 2018 20:03
Re: [bug#30933] [PATCH 1/2] gnu: translate-shell: Update home-page.
87r2o6iuie.fsf@fastmail.com
Oleg Pykhalov <go.wigust@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/dictionaries.scm (translate-shell)[home-page]: Append slash.

I'd squash this with the next commit, but no strong opinion. LGTM!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlq5NgkACgkQoqBt8qM6
VPrseQf+K0Q0nkH5g2zQXcsNqOBg8ZMUWHEk105mB5+fmeoLZa8hlA7Ri14s2udM
c0BLU6L8Kxp7vllbCfL3nEllq8S5QE2gGo4nxNBjgoCmL2XesYN+Z8Xocox3exz1
bN+ZsrL6qscflNH6/x16z7d0HozUhyjT0TopGYXxDFY3QSRozWXqD5bBdk240so3
ywAh8dOjESzT4pDVSlaYx7HNj/a5kSkk8cEAeiTxCnb5YA1+75+zA+s16dc+iTQW
+NWU23KDYMnMp4H0etDJ1OLZ3AQT034K/OIFGs+xMnoXwXLQdcOl0D6Jv+JQC5r4
knvU5tvjSZGTu5F+RMdAAHEcpiLWBg==
=XSWU
-----END PGP SIGNATURE-----

O
O
Oleg Pykhalov wrote on 26 Mar 2018 21:50
Re: [bug#30933] [PATCH 2/2] gnu: translate-shell: Update to 0.9.6.7-1.bb9f32d.
(name . Marius Bakke)(address . mbakke@fastmail.com)
87vadi1uqs.fsf@gmail.com
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (7 lines)
> Oleg Pykhalov <go.wigust@gmail.com> writes:
>
>> * gnu/packages/dictionaries.scm (translate-shell): Update to
>> 0.9.6.7-1.bb9f32d.
>> [arguments](make-flags): Add "NETWORK_ACCESS=no test".
>> [phases]: Add 'change-file-permissions' phase.

[…]

Toggle quote (8 lines)
>> + (version (git-version "0.9.6.7" "1" commit))
>
> There are only five commits since this version. I assume the git
> checkout is because of the patch that adds "NETWORK_ACCESS"?
>
> The patch itself is smaller than the reindent from the let binding, so I
> would prefer to simply add it.

OK. Thank you for a review.

Pushe as 196c8b3739d16241da73c78536ce86aaab948677

I'll close the bug report.

Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEc+OyAXw1EaDPCmAPckbhHGm3lWkFAlq5TxwACgkQckbhHGm3
lWkngQ/+K/EOF3ME8drs3C/hc6Z0F+matYvcyw1whEqwJeMNwRCNd/+v8uMhho6v
YYOL/UxaxhRpGNWaCGTDCcQYVbCyIOSEu7938D52yVNyOC0DKpgKdXkB9kDaH9H/
CsPJqjs1Y0S+x9BF+7GerVe1dEXAWj+MNqhOYVIMgEq3RWIRIVFzCCYvyEak5Rpv
tUZocVHbBpY7KWBm1FQVfgoPvIgGAPozUDj91ta9yx5o82s4Mi/Yav6X0pkV2Dj0
OdoiMn2EEdJIWdRhKZfK53GQHHjoZPrC35MPrdH7T34QkOZEgY9Ry7BYvpv4bGG3
K2hsDEdxO9fsRjJMYsdbp/6G7r6iCCRMj4mY2comos/72oNzHpnx4a5ompKwJDfY
i1me9lKXz9QwS2QDbwmjnseWZF09hWUnfvMj5Dr7pAXUwD7bFbdyGq41mhfqAMrD
c+bc0lOHh4rmzIVUuFUHwaWwiUYhqqckcs3nJ8VIjTdwnneW8LfRe3axetg1slhW
q/bwT4dcZa37CnYc31mG8AUFmpyFus8P0w+Nul1nUGj6CajueYwzXkLHiVy47a0M
zCfkdYKYOXS7TE1y/4ZytbaXvy9BIvAL7COZAJYcEmNQ7t+8jgs30ZGA0LFmERo5
t3yOwbgbrWALLI98I0u32WEtH2qnnpiS/gJeUjeibmh5twQ0onk=
=tVgV
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 30933@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30933
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch