[PATCH] gnu: Add emacs-puppet-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Marius Bakke
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
20180324155920.970-1-mail@cbaines.net
* gnu/packages/emacs.scm (emacs-puppet-mode): New variable.
---
gnu/packages/emacs.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index de0ee358d..a6dc5d866 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2772,6 +2772,30 @@ This provides a basic API and common UI widgets such as popup tooltips
and popup menus.")
(license license:gpl3+)))
+(define-public emacs-puppet-mode
+ (let ((commit "b3ed5057166a4f49dfa9be638523a348b55a2fd2")
+ (revision "1"))
+ (package
+ (name "emacs-puppet-mode")
+ (version (git-version "0.3" revision commit))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://raw.githubusercontent.com/voxpupuli/puppet-mode/"
+ commit "/puppet-mode.el"))
+ (sha256
+ (base32
+ "1indycxawsl0p2aqqg754f6735q3cmah9vd886rpn0ncc3ipi1xm"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/voxpupuli/puppet-mode")
+ (synopsis "Emacs major mode for the Puppet configuration language")
+ (description
+ "This package provides support for the Puppet configuration language,
+including syntax highlighting, indentation of expressions and statements,
+linting of manifests and integration with Puppet Debugger.")
+ (license license:gpl3+))))
+
(define-public emacs-god-mode
(let ((commit "6cf0807b6555eb6fcf8387a4e3b667071ef38964")
(revision "1"))
--
2.16.2
Marius Bakke wrote 7 years ago
87370mk9j6.fsf@fastmail.com
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-puppet-mode): New variable.

[...]
Toggle quote (7 lines)
> +(define-public emacs-puppet-mode
> + (let ((commit "b3ed5057166a4f49dfa9be638523a348b55a2fd2")
> + (revision "1"))
> + (package
> + (name "emacs-puppet-mode")
> + (version (git-version "0.3" revision commit))

Maybe mention why we can't take the 0.3 tag?

Toggle quote (7 lines)
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://raw.githubusercontent.com/voxpupuli/puppet-mode/"
> + commit "/puppet-mode.el"))

It would be nice to install the README too, but no strong opinion.

Toggle quote (12 lines)
> + (sha256
> + (base32
> + "1indycxawsl0p2aqqg754f6735q3cmah9vd886rpn0ncc3ipi1xm"))))
> + (build-system emacs-build-system)
> + (home-page "https://github.com/voxpupuli/puppet-mode")
> + (synopsis "Emacs major mode for the Puppet configuration language")
> + (description
> + "This package provides support for the Puppet configuration language,
> +including syntax highlighting, indentation of expressions and statements,
> +linting of manifests and integration with Puppet Debugger.")
> + (license license:gpl3+))))

Perhaps mention in a comment that it includes ASL code, as mentioned in
puppet-mode.el.

LGTM otherwise.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlq5M70ACgkQoqBt8qM6
VPorcAf9H1dlyH/fV7E2fpvJjKHvVEnlE5dp7rOSJEJAJBTwdcFL9x922rB2d4sv
N/tNM6IPS1wcQ3EOQoFg/lPihA6P0RxtwfZP5kNdCqdlR93NB5yiuZ+XoIWZrBrA
K6iIsyKGvSARwVZ5wXi2gL5xhd9vV8Oujk/AVgQCicMk2xaylu3NqdL9OqruVDk7
i7ubyPJgoRlOZgvjuGMBYYaReDK4heTfeWYFWJWj6oM7nnk7jnrShztXJa8grxpX
7cwNpcc1utclbZ13HwdYhgp9chiODW7Kuqgc2OziAZ6XCzDCIrcdQTW6W3PbywnT
7uTcma4KXLrCwJxS2Kme2DRhaHVttQ==
=23pp
-----END PGP SIGNATURE-----

Christopher Baines wrote 7 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 30925@debbugs.gnu.org)
87603mgxp1.fsf@cbaines.net
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (39 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/packages/emacs.scm (emacs-puppet-mode): New variable.
>
> [...]
>
>> +(define-public emacs-puppet-mode
>> + (let ((commit "b3ed5057166a4f49dfa9be638523a348b55a2fd2")
>> + (revision "1"))
>> + (package
>> + (name "emacs-puppet-mode")
>> + (version (git-version "0.3" revision commit))
>
> Maybe mention why we can't take the 0.3 tag?
>
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://raw.githubusercontent.com/voxpupuli/puppet-mode/"
>> + commit "/puppet-mode.el"))
>
> It would be nice to install the README too, but no strong opinion.
>
>> + (sha256
>> + (base32
>> + "1indycxawsl0p2aqqg754f6735q3cmah9vd886rpn0ncc3ipi1xm"))))
>> + (build-system emacs-build-system)
>> + (home-page "https://github.com/voxpupuli/puppet-mode")
>> + (synopsis "Emacs major mode for the Puppet configuration language")
>> + (description
>> + "This package provides support for the Puppet configuration language,
>> +including syntax highlighting, indentation of expressions and statements,
>> +linting of manifests and integration with Puppet Debugger.")
>> + (license license:gpl3+))))
>
> Perhaps mention in a comment that it includes ASL code, as mentioned in
> puppet-mode.el.

Hey Marius,

Thanks for taking a look at this. I don't follow about the ASL code
through, what's that?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlr9kmpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xdtuw/8CLHhZXVYWrxf/SP5HBvNLj1/QBd4t7vDBH3mFTVWAq6Qiufe2udjgZmB
bL4PvYSiPchvVzsZEVXp/suShBqD8w67UMYMqK14m9eq2lM7eNeEBWE0fwQiNNJz
Mti5p3WBoYyRMDg7jmi1Wu6ki4VDvstFnTd+rFY2nEbCvkJS/LCtWPYswZy0LYSF
jTcrDu9kjl9sjXoDUn2La0ZoTHPIOI7hLvrXBPlgA0oGh6NOEI7HwgFtMFXf0l/8
nCAOH8eapgJpOn/030VPO1Y/I7B1+6Dqb/+74b+L9gHvWLDTCgsH01X4hnX8V4dY
X/5N3IjdkmBZORrlC1sgdOxXBJXPiSgrEK56R5bzn9qidrrTkR+bS7RoSk3pWpwF
2WyE1a8RfnSstxAB0vob4ugDOEzU+a7QsUeq3juPAnOLpEktmEeZwhJjzy/LXWRc
Nwu3tclbBiGgkGPQx1leE69310xABPbDJIRGuIRdJiQMyjlV09R0pwbTsuErWaZ7
1AgwDPNLIN2OUSp2UQpap/RjEolJHtY7jfZf0LnJQjICEni/FsmOBf2CcD2OidfM
XGy6M5+5BP23+R/zcnOK6jWceYhwxlyLQ/U8tidiaGUpVwjJZ3ekvyoylfRFHQSs
/huNWdORHnU8bQrwRYxLCtOtl6ljxNMV01b3ByqrWOfGNndaa8U=
=ouMb
-----END PGP SIGNATURE-----

Christopher Baines wrote 7 years ago
[PATCH] gnu: Add emacs-puppet-mode.
(address . 30925@debbugs.gnu.org)
20180611184621.4911-1-mail@cbaines.net
* gnu/packages/emacs.scm (emacs-puppet-mode): New variable.
---
gnu/packages/emacs.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9caa01a0f..039f52a56 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3014,6 +3014,33 @@ This provides a basic API and common UI widgets such as popup tooltips
and popup menus.")
(license license:gpl3+)))
+(define-public emacs-puppet-mode
+ (let ((commit "b3ed5057166a4f49dfa9be638523a348b55a2fd2")
+ (revision "1"))
+ (package
+ (name "emacs-puppet-mode")
+ ;; The last release, 0.3 was several years ago, and there have been many
+ ;; commits since
+ (version (git-version "0.3" revision commit))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://raw.githubusercontent.com/voxpupuli/puppet-mode/"
+ commit "/puppet-mode.el"))
+ (sha256
+ (base32
+ "1indycxawsl0p2aqqg754f6735q3cmah9vd886rpn0ncc3ipi1xm"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/voxpupuli/puppet-mode")
+ (synopsis "Emacs major mode for the Puppet configuration language")
+ (description
+ "This package provides support for the Puppet configuration language,
+including syntax highlighting, indentation of expressions and statements,
+linting of manifests and integration with Puppet Debugger.")
+ ;; Also incorporates work covered by the Apache License, Version 2.0
+ (license license:gpl3+))))
+
(define-public emacs-god-mode
(let ((commit "6cf0807b6555eb6fcf8387a4e3b667071ef38964")
(revision "1"))
--
2.17.1
Christopher Baines wrote 7 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 30925@debbugs.gnu.org)
87zi012lxk.fsf@cbaines.net
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (15 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/packages/emacs.scm (emacs-puppet-mode): New variable.
>
> [...]
>
>> +(define-public emacs-puppet-mode
>> + (let ((commit "b3ed5057166a4f49dfa9be638523a348b55a2fd2")
>> + (revision "1"))
>> + (package
>> + (name "emacs-puppet-mode")
>> + (version (git-version "0.3" revision commit))
>
> Maybe mention why we can't take the 0.3 tag?

I've sent a new patch with a comment.

Toggle quote (9 lines)
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://raw.githubusercontent.com/voxpupuli/puppet-mode/"
>> + commit "/puppet-mode.el"))
>
> It would be nice to install the README too, but no strong opinion.

I've gone for leaving it out for now, just to keep the package simple.

Toggle quote (15 lines)
>> + (sha256
>> + (base32
>> + "1indycxawsl0p2aqqg754f6735q3cmah9vd886rpn0ncc3ipi1xm"))))
>> + (build-system emacs-build-system)
>> + (home-page "https://github.com/voxpupuli/puppet-mode")
>> + (synopsis "Emacs major mode for the Puppet configuration language")
>> + (description
>> + "This package provides support for the Puppet configuration language,
>> +including syntax highlighting, indentation of expressions and statements,
>> +linting of manifests and integration with Puppet Debugger.")
>> + (license license:gpl3+))))
>
> Perhaps mention in a comment that it includes ASL code, as mentioned in
> puppet-mode.el.

I've added this now :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlsexXdfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XddhRAAtCKUCd6eA+449AXy94dX5PdF7mFvW14T1HoMOG8lID6OXJ1MgpMu3qby
UaDTuWt/K5Ll6gq/EiU1N5vtAnk9zku9xiOX+eR8jDp608PX5RD8fMA6UZniwkLK
ezDPuCr5g2TT545VV4yLlKVEY1b5hHYbh0Cc3IsheJJ0EYPhwVuXVlbz+i/LQBIB
YC1z3BZppMqTTDuNFzy0C/wk+TvCs9SgLYSBHtWjjou2NshIzfwwoEF51GuhhLLe
U0JnkghmjjiO4Mg1j25GdH7Iqu9hNbRFFyTVHuTwqMMpuvNN/a2CcFcF3Rkp9b9+
C8E/nDAyjuUhpjF//PasaD479pAQH5i1NqAhZC6qw3malbd3NnEW8pB4IkH6S6FK
9XoUInuLtLAjk9iY2P+/VAyiNKPx9DTkP0VOFCSbBknoalw18dqHQolNzM3UORI5
jrc0BnqwEXr6Sx5q3HSjhcTJf5fL8Yy4L1bgAyzdxyMYPmMLjyaVNYQ0yvtp3utX
fmVCytVcAIdR/hVX/MA4Ute/k5SRJ8uJ2Cf8zdg9n9C/iFnye82lpIEi8jSYlLJn
BDqehLany1EoaFlAIBpvEn5G25X7hoIOYgy49jrGhWavcNR9U0CnO9jpehTFnoZJ
T4XHhdFQaD/xFzYF0eT+mU/PD1airdHFbWPPP6sgJf0zY7lQOFw=
=Z1LP
-----END PGP SIGNATURE-----

Marius Bakke wrote 7 years ago
87sh5tp2lv.fsf@fastmail.com
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-puppet-mode): New variable.

LGTM, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlsex4wACgkQoqBt8qM6
VPrVdQf/T6Q5ZAsTkbmopZY9E7jm/PLGpkiZybuG0RWfIQ8/Gs/xoxdv+yH2wniR
jnEsXiN0ld/xYthGrtxxO058tvS+nS/q5z4Ocio2TIBc5t9KIJkqHxK9orss5s45
cWoXrS77w6Tq45qoXlDQrkW0V6JqAGfgKiZedPCqW5WcZFSKPgrPwdPOJNDfMnqj
mXNSGHsS6MeAThBcEhrLjhOj3byy8q+To5zAaxlu2+Yms+iUH+5xM0+PEyDwOorw
81B255XkLQe46IiMJnrMbBtZmh5uRfMuWr9/GC4a+Dk0Ocd+n1aQWVepKyh1S4/1
Id7y9qVYq5DG3Nj8KWa34OEF6+Uwvw==
=Hb2i
-----END PGP SIGNATURE-----

Christopher Baines wrote 7 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 30925-done@debbugs.gnu.org)
87tvq832zl.fsf@cbaines.net
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (6 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/packages/emacs.scm (emacs-puppet-mode): New variable.
>
> LGTM, thanks!

Great, I've pushed this now :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlsfbx5fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfMEQ//RpfOzbErzq5ywP6xb2sLNCw2b7CpD6Hm39i2g+1JFd42IIBA+54y+tQK
0rhPu93XAcjEs/PLqBEoJFG1CWIMNtFc07he3RcwRxRFPs67odXx7tRUUgnM9Nr5
3f/eVGOL1PkqL9HcfRlEBm4nnbCaRZIz37UhQflpEn2LtNWDPo3AvP4ayMOjABBs
F2StM3LUqcdp3LgAY62IuDJW9y9bb1wxKTzb/C1lNpNu/5+XN5V8A0SRDf9884BN
WKzt8YWtFCsKYz+paNr00b2h7DjMT+DGYyLnHXG3e7E8d5J2krwj0sTYQ218BoLO
VJcgqTqlDKRjQ2/8KlDfGSrxs/0VE70qL9A6/aQqq8IQUW7ZCc4czmjbdIxoZyZJ
P/8JFFV2yXg88uvRXQH8ysQHFmCHLakG35oDi/sL/5Li2RO/L5Pi/7mcSLWL5/d2
WZYjfUvsIfvfR68ctFs0ZMxi4v7m2M0fJUMdZIhikLQroKI9rsdO2JjIsV5oa6LV
pr/ZiV3YjbLQOh2eFkdX/cb4xKGdQniGs35V0fcdVeoQdb5aRgRHgtEOvpldlqTx
60UKHClUFFtHsO0rYxGnKoCWDqO6jV4hJNMln/rPRf6gsYgtz/tkBF226M8DUMy6
3gw2/5HTeyGnDjlM0pljBWwNBff9FROTyA5A/we/Ql2Hwa2ePKU=
=sY9j
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30925@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30925
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help